Дан массив целых чисел?

Информатика | 5 - 9 классы

Дан массив целых чисел.

Все нечетные элементы удвоить, я четные умень­шить вдвое.

Ответить на вопрос
Ответы (1)
Novizkayaliza 20 февр. 2020 г., 13:02:07

/ / Дан массив целых чисел.

Все нечетные элементы удвоить, а четные уменьшить вдвое.

Var a : array [1.

10] of real ; / / возьмем массив из 10 чисел i, x : byte ;

begin randomize ; for i : = 1 to 10 do / / заполняем исходный массив случайными числами (до 1000) begin a[i] : = random(1000) ; writeln (i, ' элемент исходного массива ', a[i]) ; end ; writeln () ; for i : = 1 to 10 do begin x : = i mod 2 ; / / определяем четный или нет элемент массива if x = 0 then / / если элемент четный begin a[i] : = a[i] / 2 ; writeln (i, ' элемент массива - четный ', a[i]) ; end else / / если элемент нечетный begin a[i] : = a[i] * 2 ; writeln (i, ' элемент массива - нечетный ', a[i]) ; end ; end ;

end.

Carbon196 9 апр. 2020 г., 00:17:28 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Определить ко - во четных элементов и кол - во элементов, оканчивающихся на цифру 5.

LeXaNiCH777 21 окт. 2020 г., 20:28:32 | 10 - 11 классы

Дан массив целых чисел А(10)?

Дан массив целых чисел А(10).

Все нечетные элементы удвоить.

Wordless 26 янв. 2020 г., 21:32:02 | 10 - 11 классы

Дан массив целых чисел?

Дан массив целых чисел.

Все элементы, оканчивающиеся цифрой 4, уменьшить вдвое на с + +.

Mskrylova2003 20 июн. 2020 г., 16:45:23 | 5 - 9 классы

Создать массив из 12 целых чисел?

Создать массив из 12 целых чисел.

Нечетные элементы увеличить на их номер.

Положительные элементы уменьшить в три раза.

Misha032 7 июн. 2020 г., 16:08:37 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Напечатать все четные элементы.

Alexsisenov 20 окт. 2020 г., 09:41:29 | 5 - 9 классы

Дан массив из N чисел?

Дан массив из N чисел.

N - четное.

Написать программу, меняющую местами элементы с четными и нечетными номерами.

Плиз помогите оч надо.

Mmp7272 2 сент. 2020 г., 23:19:54 | 10 - 11 классы

Все четные положительные элементы целочисленного массива уменьшить вдвое, все нечетные положительные увеличить на 2, а у всех остальных поменять знак?

Все четные положительные элементы целочисленного массива уменьшить вдвое, все нечетные положительные увеличить на 2, а у всех остальных поменять знак.

Tanzila8928000 13 июл. 2020 г., 01:43:29 | 10 - 11 классы

Дан линейный массив из 11 целых чисел найти произведение нечетных элементов?

Дан линейный массив из 11 целых чисел найти произведение нечетных элементов.

Jador1 26 сент. 2020 г., 10:03:20 | 10 - 11 классы

Двумерные массивы?

Двумерные массивы.

Дан двумерный массив чисел.

Первый нечетный элемент каждой строки удвоить (предполагается, что в каждой строке есть нечетный элемент).

Yusufbek 16 мар. 2020 г., 22:47:12 | 5 - 9 классы

Массив содержит N случайных двузначных чисел?

Массив содержит N случайных двузначных чисел.

Определить сколько в данном массиве четных чисел.

Вывести все его элементы с нечетными номерами.

Вы находитесь на странице вопроса Дан массив целых чисел? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.