Описать процедуру SortInc3(A,B, C), меняющую содержимое переменных A, B, C таким образом, чтобы их значения оказались упорядоченными по возрастанию (A, B,C — вещественные параметры, являющиеся одновре?

Информатика | 10 - 11 классы

Описать процедуру SortInc3(A,

B, C), меняющую содержимое переменных A, B, C таким образом, чтобы их значения оказались упорядоченными по возрастанию (A, B,

C — вещественные параметры, являющиеся одновременно входными и выходными).

С помощью этой процедуры упорядочить по возрастанию два данных набора из трех чисел : (A1, B1, C1) и (A2, B2, C2).

Ответить на вопрос
Ответы (1)
20Milanka02 4 мая 2020 г., 22:54:28

Procedure SwapInc(var a, b : real) ;

begin a : = a + b ; b : = a - b ; a : = a - b ;

end ;

procedure SortInc3(var a, b, c : real) ;

begin if a > ; b then SwapInc(a, b) ; if b > ; c then SwapInc(b, c) ; if a > ; b then SwapInc(a, b) ;

end ;

var a, b, c : real ; i : integer ;

begin for i : = 1 to 2 do begin write ('a', i, ' = ') ; readln(a) ; write ('b', i, ' = ') ; readln(b) ; write ('c', i, ' = ') ; readln(c) ; SortInc3(a, b, c) ; writeln(a, ' ', b, ' ', c) ; end ;

end.

MarfaB 9 мая 2020 г., 02:12:37 | 10 - 11 классы

Составьте программу сортировки по возрастанию значений трех переменных A ; B ; C?

Составьте программу сортировки по возрастанию значений трех переменных A ; B ; C.

Georg0660 3 янв. 2020 г., 04:04:04 | 10 - 11 классы

Помогите с программой в паскале с помощью процедуры Процедура выводит N целых случайных чисел с интервала a, b?

Помогите с программой в паскале с помощью процедуры Процедура выводит N целых случайных чисел с интервала a, b.

Wownastya 29 янв. 2020 г., 00:20:48 | 10 - 11 классы

1. Написать процедуру, меняющую значения двух переменных а и b местами?

1. Написать процедуру, меняющую значения двух переменных а и b местами.

2. Используя процедуру обмена значений двух переменных, упорядочьте по возрастанию переменные a, b, c.

Bsbannerok 7 дек. 2020 г., 15:41:03 | 1 - 4 классы

Написать программу, которая сможет определить, есть ли среди цифр заданного целого трёхзначного числа одинаковые?

Написать программу, которая сможет определить, есть ли среди цифр заданного целого трёхзначного числа одинаковые.

Даны три переменные вещественного типа : A, B, C.

Если их значения упорядочены по возрастанию или убыванию, то удвоить их ; в противном случае заменить значение каждой переменной на противоположное.

Вывести новые значения переменных A, B, C.

Sofya55 14 дек. 2020 г., 17:35:22 | 10 - 11 классы

Составьте программу сортировки по возрастанию значений трех переменных A ; B ; C?

Составьте программу сортировки по возрастанию значений трех переменных A ; B ; C.

Viktoriyafomen 18 мар. 2020 г., 02:48:46 | 5 - 9 классы

Pascal?

Pascal.

Даны три переменные вещественного типа : A, B, C.

Если их значения упо - рядочены по возрастанию или убыванию, то удвоить их ; в противном слу - чае заменить значение каждой переменной на противоположное.

Вывести новые значения переменных A, B, C.

Abdulvobova 13 февр. 2020 г., 01:55:39 | 10 - 11 классы

Помогите решить вторую?

Помогите решить вторую.

1. Даны три числа а, b, с.

Удвойте эти числа, если они являются упорядоченными по возрастанию.

2. Проверьте, есть ли среди трех заданных чисел равные.

Просто1111111115 29 февр. 2020 г., 23:22:03 | 5 - 9 классы

СДЕЛАТЬ В PACKALABC Даны значения трех вещественных переменных а, b и с Обменять местами их значения при этом нельзя использовать никаких дополнительных переменных (a = b, b = c, c = a)?

СДЕЛАТЬ В PACKALABC Даны значения трех вещественных переменных а, b и с Обменять местами их значения при этом нельзя использовать никаких дополнительных переменных (a = b, b = c, c = a).

Zamudrakow 14 дек. 2020 г., 05:40:11 | 5 - 9 классы

Напишите процедуру, которая выводит на экран решение линейного алгебраического уравнения ?

Напишите процедуру, которая выводит на экран решение линейного алгебраического уравнения .

Параметры и являются параметрами процедуры.

Gfgfggf45644 28 дек. 2020 г., 03:52:50 | 5 - 9 классы

Вычислить Y = A + B + C , применив : а) - процедуру ввода данных ; - процедуру вычисления Y ; - процедуру вывода результата ; - глобальные переменные ;PASCAL ABC?

Вычислить Y = A + B + C , применив : а) - процедуру ввода данных ; - процедуру вычисления Y ; - процедуру вывода результата ; - глобальные переменные ;

PASCAL ABC.

Вы перешли к вопросу Описать процедуру SortInc3(A,B, C), меняющую содержимое переменных A, B, C таким образом, чтобы их значения оказались упорядоченными по возрастанию (A, B,C — вещественные параметры, являющиеся одновре?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.