Найти сумму цифр четырехзначного числа Program nfff ; var ab, S, a, b : integer ; Begin WriteLn('найти сумму цифр четырехзначного числа') ; Write('Введите ab = ') ; ReadLn(ab) ; b : = ab mod 10 ; a : ?

Информатика | 5 - 9 классы

Найти сумму цифр четырехзначного числа Program nfff ; var ab, S, a, b : integer ; Begin WriteLn('найти сумму цифр четырехзначного числа') ; Write('Введите ab = ') ; ReadLn(ab) ; b : = ab mod 10 ; a : = ab div 10 ; S : = a + b ; writeln('S = ', S) ; End.

Ответить на вопрос
Ответы (1)
БаКсИк27 12 янв. 2020 г., 13:54:30

Program nfff ;

var abcd, S, a, b, c, d : integer ; Begin WriteLn('найти сумму цифр четырехзначного числа') ;

Write('Введите abcd = ') ; ReadLn(abcd) ;

a : = abcd div 1000 ;

b : = abcd div 100 ;

b : = b mod 10 ;

c : = abcd mod 100 ;

c : = c div 10 ;

d : = abcd mod 10 ;

S : = a + b + c + d ; writeln('S = ', S) ; End.

Nurazaya 28 июл. 2020 г., 12:06:52 | 10 - 11 классы

Дано четырехзначное число?

Дано четырехзначное число.

Найти сумму квадратов второй и третьей цифры.

Valelelentinaa 31 мая 2020 г., 23:32:48 | 10 - 11 классы

Дано четырехзначное число?

Дано четырехзначное число.

Найти : сумму его цифр.

Написать программу на Pascal'е.

Вел2013 29 февр. 2020 г., 03:11:55 | 5 - 9 классы

Найти сумму цифр четырехзначного числа через цикл с постусловием?

Найти сумму цифр четырехзначного числа через цикл с постусловием.

Neka200 9 авг. 2020 г., 08:35:35 | 10 - 11 классы

Дано натуральное четырехзначное число n?

Дано натуральное четырехзначное число n.

Найти сумму его цифр.

Irakorshunova 3 окт. 2020 г., 14:22:46 | 5 - 9 классы

Найти сумму цифр четырехзначного числа в паскалях?

Найти сумму цифр четырехзначного числа в паскалях.

Artyomka31 11 мая 2020 г., 04:37:07 | 5 - 9 классы

Ребята помогите?

Ребята помогите!

Решать пыталась, но прога выводит ошибки!

Найти все четырехзначные натуральные числа, у которых сумма крайних цифр равна сумме сред - них цифр, а само число делится на число А!

Imtmawr 8 мар. 2020 г., 01:31:44 | 5 - 9 классы

Решение задач в паскале с помощью div и mod 8 класс?

Решение задач в паскале с помощью div и mod 8 класс.

Дано четырехзначное число .

Нужно вычислить квадрат суммы всех цифр.

Помогите пожалуйста!

Глупыйшкольник 23 сент. 2020 г., 11:34:24 | 5 - 9 классы

Определить равен ли квадрат заданного четырехзначного числа кубу суммы цифр этого числа?

Определить равен ли квадрат заданного четырехзначного числа кубу суммы цифр этого числа.

Vavdhksb 6 янв. 2020 г., 20:50:15 | 5 - 9 классы

С клавиатуры вводится четырехзначное число?

С клавиатуры вводится четырехзначное число.

Необходимо подсчитать сумму цифр этого числа.

Ааабббвввгоггг 15 нояб. 2020 г., 05:50:38 | 5 - 9 классы

Распишите, пожалуйста, подробно?

Распишите, пожалуйста, подробно.

Что именно записать Задача 1.

Используя операции div и mod, найти сумму цифр случайного трехзначного числа.

На экран должно быть выведено само число и сумма цифр этого числа.

Задача 2.

Получить четырехзначное число, полученное из случайного двузначного числа, приписыванием цифры единиц в качестве цифры тысяч, а цифры десятков – в качестве цифры сотен.

(например, из числа 32 получится число 2332).

Перед вами страница с вопросом Найти сумму цифр четырехзначного числа Program nfff ; var ab, S, a, b : integer ; Begin WriteLn('найти сумму цифр четырехзначного числа') ; Write('Введите ab = ') ; ReadLn(ab) ; b : = ab mod 10 ; a : ?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.