Решение задач в паскале с помощью div и mod 8 класс?

Информатика | 5 - 9 классы

Решение задач в паскале с помощью div и mod 8 класс.

Дано четырехзначное число .

Нужно вычислить квадрат суммы всех цифр.

Помогите пожалуйста!

Ответить на вопрос
Ответы (1)
Катя1Куцкина 8 мар. 2020 г., 01:31:45

Var a, sum, i, ii : integer ;

begin

sum : = 0 ;

readln(a) ;

for i : = 1 to 4 do

begin

ii : = a mod10 ;

a : = a div10 ;

sum : = sum + ii * ii ;

end ;

writeln(sum) ;

end.

Anna202025 9 авг. 2020 г., 08:32:25 | 5 - 9 классы

Нужно написать программу для нахождения суммы цифр любого трехзначного числа, вводимого с клавиатуры во время работы программы)) как это сделать с помощью mod или div без цикла?

Нужно написать программу для нахождения суммы цифр любого трехзначного числа, вводимого с клавиатуры во время работы программы)) как это сделать с помощью mod или div без цикла?

Nurazaya 28 июл. 2020 г., 12:06:52 | 10 - 11 классы

Дано четырехзначное число?

Дано четырехзначное число.

Найти сумму квадратов второй и третьей цифры.

BGrygorenko 24 апр. 2020 г., 03:14:36 | 5 - 9 классы

Язык программирования Паскаль Вычислить 27 div 4 27 mod 4 - 7 div 2 - 7 mod 2 - 14 div 3 - 14 mod 3?

Язык программирования Паскаль Вычислить 27 div 4 27 mod 4 - 7 div 2 - 7 mod 2 - 14 div 3 - 14 mod 3.

Cordelia 14 окт. 2020 г., 20:22:46 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Паскаль

дано четырехзначное число, заменить нулем максимальную цифру.

Irakorshunova 3 окт. 2020 г., 14:22:46 | 5 - 9 классы

Найти сумму цифр четырехзначного числа в паскалях?

Найти сумму цифр четырехзначного числа в паскалях.

Antonkhvorov 20 июн. 2020 г., 12:56:51 | 10 - 11 классы

1) дано натуральное а?

1) дано натуральное а.

Верно ли, что данное число состоит из 3 цифр?

2) дано натуральное число.

Верно ли, что в данном числе четыре цифры?

3) Даны два натуральных числа.

Определить в каком числе первая цифра больше.

4) Дано натуральное n.

Найти количество 6, входящих в данное число.

Нужно решить в программе паскаль.

Если поможет, то мы учим цикл в паскале, div, mod.

Marmarina83 12 авг. 2020 г., 09:54:20 | 5 - 9 классы

Turbo Pascal Человек ввел трехзначное число, при помощи функций div и mod найти их сумму?

Turbo Pascal Человек ввел трехзначное число, при помощи функций div и mod найти их сумму.

Kry0182000 10 февр. 2020 г., 19:53:01 | 10 - 11 классы

Напишите программу на языке Паскаль для решения следующей задачи : Для любого трехзначного вводимого числа найти сумму первой и последней цифры?

Напишите программу на языке Паскаль для решения следующей задачи : Для любого трехзначного вводимого числа найти сумму первой и последней цифры.

(Подсказка.

Используйти тип данных integer и операции div и mod).

Perehoghina01 16 июн. 2020 г., 00:48:43 | 10 - 11 классы

Получить случайное трехзначное число и вывести через запятую все его отдельные цифры?

Получить случайное трехзначное число и вывести через запятую все его отдельные цифры.

Сделать для программы Паскаль!

Без mod и div.

Fazipan 21 нояб. 2020 г., 18:51:38 | 10 - 11 классы

Что означает div и mod в паскале?

Что означает div и mod в паскале?

На этой странице вы найдете ответ на вопрос Решение задач в паскале с помощью div и mod 8 класс?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.