Дано число n?

Информатика | 10 - 11 классы

Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

Пример Ввод Вывод 150 2 30.

Ответить на вопрос
Ответы (1)
31651 27 июн. 2020 г., 04:06:53

Var

n, w : integer ;

begin

readln(n) ;

w : = n mod 60 ;

n : = n div 60 ;

writeln(n, ' ', w) ;

end.

Zvezdochkina01 20 окт. 2020 г., 16:33:48 | 5 - 9 классы

Написать программу подсчета количества часов, минут и секунд в данном числе суток?

Написать программу подсчета количества часов, минут и секунд в данном числе суток.

Напишите на C + +.

Rome341 21 янв. 2020 г., 05:39:56 | 10 - 11 классы

Помогите пожалуйста написать алгоритм к этой задаче : Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество ми?

Помогите пожалуйста написать алгоритм к этой задаче : Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Lstava 29 авг. 2020 г., 16:10:38 | 10 - 11 классы

Написать программу с процедурой подсчет кол - во часов, минут, секунд в данном числе суток входные данные число суток?

Написать программу с процедурой подсчет кол - во часов, минут, секунд в данном числе суток входные данные число суток.

Sergey228989 24 мар. 2020 г., 22:20:56 | 5 - 9 классы

Дано число n?

Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Входные данные Вводится число n - целое, положительное, не превышает 107.

Выходные данные Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

Leonsalus 9 апр. 2020 г., 11:30:22 | 5 - 9 классы

1. Составьте программу, решающую следующую задачу : С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг?

1. Составьте программу, решающую следующую задачу : С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг.

Какое наименьшее количество (K) коробок потребуется для перевозки N килограмм конфет?

Вводимое и в ыводимое .

Для заданного числа суток определить количество часов, минут и секунд.

Вводимое количество сутокВыводимое количество часов, минут, секунд7 суток = 168 часов = 10080 минут = 604800 секунд1 сутки = 24 часов = 1440 минут = 86400 секунд10 суток = 240 часов = 14400 минут = 864000 секунд2 суток = 48 часов = 2880 минут = 172800 секунд.

KISYNA 3 сент. 2020 г., 10:30:26 | 5 - 9 классы

Для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (с)?

Для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (с).

Кристина1309 2 янв. 2020 г., 13:51:03 | 5 - 9 классы

PASCAL ABC?

PASCAL ABC!

Составьте программу подсчета количества часов, минут и секунд в данном количестве суток.

Количество суток вводится с клавиатуры.

20051049 30 дек. 2020 г., 00:17:07 | 5 - 9 классы

Для тех, кто знает Python?

Для тех, кто знает Python!

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Самое главное - как сделать, чтобы всегда выводилось двузначное количество минут и секунд?

Misha13Misha13 11 июн. 2020 г., 14:04:04 | 5 - 9 классы

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд?

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Входные данные Вводится целое число n.

Выходные данные Выведите ответ на задачу, соблюдая требуемый формат.

Примеры Входные данные 3602 Выходные данные 1 : 00 : 02 Входные данные 129700 Выходные данные 12 : 01 : 40.

Arsentimur 12 окт. 2020 г., 11:41:26 | 5 - 9 классы

JAVA Дано число n?

JAVA Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

На этой странице сайта размещен вопрос Дано число n? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.