Найти все симметричные натуральные числа из промежутка от A до B ( А и B вводятся с клавиатуры)?

Информатика | 5 - 9 классы

Найти все симметричные натуральные числа из промежутка от A до B ( А и B вводятся с клавиатуры).

Ответить на вопрос
Ответы (1)
Veronikapetrova 25 июн. 2020 г., 10:58:31

Var i, a, b, n, n2, j : longint ; s : string ; flag : boolean ;

begin Write('Введите через пробел границы диапазона : ') ; Readln(a, b) ; if b < ; a then begin n : = a ; a : = b ; b : = n end ; if a < ; 11 then a : = 11 ; for i : = a to b do begin Str(i, s) ; n : = Length(s) ; n2 : = n div 2 ; flag : = true ; j : = 1 ; repeat flag : = (s[j] = s[n - j + 1]) ; j : = j + 1 until (not flag) or (j > ; n2) ; if flag then Write(i, ' ') end ;

end.

Тестовое решение :

Введите через пробел границы диапазона : 800 1500

808 818 828 838 848 858 868 878 888 898 909 919 929 939 949 959 969 979 989 999 1001 1111 1221 1331 1441.

Asia271 12 мая 2020 г., 22:59:44 | 5 - 9 классы

С клавиатуры вводится натуральное число?

С клавиатуры вводится натуральное число.

Определите сколько в его записи нечетных чисел.

VOLAN97 27 июл. 2020 г., 16:21:50 | 5 - 9 классы

1)найти количесво делителей натурального числа, сколько из них чётных?

1)найти количесво делителей натурального числа, сколько из них чётных?

2) дано натуральное число : найти две первые цыфры числа верно ли, что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа, которые состоят из разных цыфр, а их сумма равна А(А вводится с клавиатуры) 4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры).

88777sin 15 окт. 2020 г., 17:53:05 | 10 - 11 классы

Найти все симметричные натуральные числа (палиндромы) из промежутка от А до В (А и В вводятся с клавиатуры) Решать через массив?

Найти все симметричные натуральные числа (палиндромы) из промежутка от А до В (А и В вводятся с клавиатуры) Решать через массив.

Zoya22 10 февр. 2020 г., 13:54:03 | 5 - 9 классы

С клавиатуры вводится натуральное число n?

С клавиатуры вводится натуральное число n.

Найдите и выведите самую большую цифру этого числа.

КРОЛЛЬ 17 февр. 2020 г., 04:49:02 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить, есть ли в нем цифра равная а (а вводится с клавиатуры).

ShilinaLera1 14 дек. 2020 г., 22:08:36 | 5 - 9 классы

Найти количество четных чисел в промежутке от 1 до N?

Найти количество четных чисел в промежутке от 1 до N.

N вводится с клавиатуры.

В Паскале!

Kir71 3 окт. 2020 г., 07:05:30 | 5 - 9 классы

С клавиатуры вводится натуральное число k, затем последовательно вводится k чисел с плавающей точкой?

С клавиатуры вводится натуральное число k, затем последовательно вводится k чисел с плавающей точкой.

Найти сумму этих чисел и наименьшее них.

Паскаль.

Marina19821119 5 мая 2020 г., 17:14:32 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Найти количество цифр данного числа больших b(b вводится с клавиатуры).

Лаура200011 29 мар. 2020 г., 12:30:09 | 5 - 9 классы

С клавиатуры вводится натуральное число n?

С клавиатуры вводится натуральное число n.

Посчитать сумму натурального числа от 1 до n?

Donierakramov 2 нояб. 2020 г., 04:52:03 | 5 - 9 классы

Для каждого натурального числа в промежутке [m ; n] вывести все делители, кроме единицы и самого числа?

Для каждого натурального числа в промежутке [m ; n] вывести все делители, кроме единицы и самого числа.

M и n вводятся с клавиатуры.

Выводить в формате число : делители.

Если вам необходимо получить ответ на вопрос Найти все симметричные натуральные числа из промежутка от A до B ( А и B вводятся с клавиатуры)?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.