Даны действительные положительные числа a, b, c, которые являются длинами сторон треугольника?

Информатика | 5 - 9 классы

Даны действительные положительные числа a, b, c, которые являются длинами сторон треугольника.

Напишите программу позволяющую найти радиус вписанной и описанной окружности.

Ответить на вопрос
Ответы (1)
KokosMandarin 12 февр. 2020 г., 12:44:27

Var

a, b, c, p, r1, r2 : real ;

begin readln(a, b, c) ; p : = (a + b + c) / 2 ; r1 : = (a * b * c) / (4 * sqrt(p * (p - a) * (p - b) * (p - c))) ; / / описанная r2 : = sqrt(((p - a) * (p - b) * (p - c)) / p) ; / / вписанная writeln(r1 : 1 : 5, ' ', r2 : 1 : 5) ; readln ; readln

end.

Andreeys 2 июл. 2020 г., 05:24:31 | 5 - 9 классы

Задача 35?

Задача 35.

Решить Паскалем.

Дана сторона равностороннего треугольника.

Найти площадь этого треугольника, его высоты, радиусы вписанной и выписанной окружностей.

KaterinaKot 29 янв. 2020 г., 03:26:02 | 5 - 9 классы

Помогите с программой : Дана сторона равностороннего треугольника?

Помогите с программой : Дана сторона равностороннего треугольника.

Найти площадь этого треугольника, его высоту, радиусы вписанной и описанной окружностей.

В программе Microsoft Visual Studio C#.

Snehka 18 янв. 2020 г., 08:31:53 | 1 - 4 классы

Помогите пожалуйста решить задачки на C + + ?

Помогите пожалуйста решить задачки на C + + .

1)Треугольник задан длинами сторон.

Найти :

а)длины высот ;

б)длины медиан ;

в)длины биссектрис ;

г)радиусы вписанной и описанной окружностей.

По С + + надо срочно!

Заранее спасибо.

Программирую на visual2010express.

Парkур 14 нояб. 2020 г., 15:28:10 | 5 - 9 классы

Паскаль напишите пожалуйста программу Срочно, прошу?

Паскаль напишите пожалуйста программу Срочно, прошу!

Даны действительные положительные числа a, b, c, которые задают длины сторон треугольника и угол между ними.

Напишите программу, позволяющую найти длину третьей стороны и два остальных угла.

Соня183 11 янв. 2020 г., 21:06:13 | 10 - 11 классы

Даны три натуральных числа, являющиеся длинами сторон треугольника?

Даны три натуральных числа, являющиеся длинами сторон треугольника.

Число ввести с клавиатуры.

Определить является ли треугольник прямоугольным, если эти отрезки позволяют его построить.

Написать программу на паскале только на паскале и не на другом языке!

Aksentiy10 8 мая 2020 г., 15:53:34 | 10 - 11 классы

Составить программу для решения задачи : 1)Даны действительные, положительные числа x, y, z?

Составить программу для решения задачи : 1)Даны действительные, положительные числа x, y, z.

Выяснить, существует ли треугольник с длинами сторон x, y, z.

Если треугольник, то является ли он равносторонним?

2)Дан одномерный массив.

Найти количество смен знака между соседними элементами массива.

Программа - Паскаль.

Koromyslova 17 мар. 2020 г., 05:27:56 | 5 - 9 классы

Сделать программу в pascal?

Сделать программу в pascal.

Пользователь вводит радиус окружности и стороны прямоугольника , программа в графическом режиме выводит нам получившийся прямоугольник (вписанный , описанный, или посторонний), и над ним надпись (окружность вписана / описана / посторонняя.

021 17 мая 2020 г., 22:00:21 | 10 - 11 классы

1. Дана сторона равностороннего треугольника?

1. Дана сторона равностороннего треугольника.

Найти площадь этого треугольника и радиусы вписанной и описанной окружностей.

Nika438 25 февр. 2020 г., 03:12:58 | 5 - 9 классы

Pascal 1?

Pascal 1.

Дан прямоугольный треугольник с катетами a и b.

Составьте программу для вычисления гипотенузы c, периметра, площади, радиуса вписанной и описанной окружности.

Напишите программу в pascal.

Лолошка1359 6 мар. 2020 г., 23:15:28 | 10 - 11 классы

Составить блок - схему и написать программу на языке PascalABC?

Составить блок - схему и написать программу на языке PascalABC.

NET. 1.

Даны действительные положительные числа x, y, z.

Выяснить, существует ли треугольник с длинами сторон x, y, z.

2. Даны три действительных числа.

Выбрать из них те, которые принадлежат интервалу (1, 3).

Перед вами страница с вопросом Даны действительные положительные числа a, b, c, которые являются длинами сторон треугольника?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.