Напистаь программу удаления из строки чётных или нечётных чисел в Паскале?

Информатика | 10 - 11 классы

Напистаь программу удаления из строки чётных или нечётных чисел в Паскале.

Ответить на вопрос
Ответы (1)
Sanver 30 апр. 2020 г., 12:17:33

Что значит из строки?

Формулируйте лучше.

Можно делать через обычный массив, примерно так

var a : array [1.

100] of integer ; / / Вместо 100 - максимальное количество чисел i, n : integer ;

begin / / Если колчисетво чисел вводится, то этот код

read (n) ;

for i : = 1 to n do read (a[i]) ; / / Если же по уловию задачи задана только строка чисел, то использовать следующий / / код

while not eoln (input) do

begin n : = n + 1 ; read (a[n]) ;

end ; / / Далее для обоих вариантов.

For i : = 1 to n do if a[i] mod 2 = 0 then write (a[i], ' ') ; / / Выведет четные, для нечетных заменить = 0 на = 1

end.

Lena22099 11 нояб. 2020 г., 06:55:02 | 5 - 9 классы

Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел?

Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел.

Число n вводится с клавиатуры .

Выполнить программу для n = 13 , записать результат.

Mart2354 24 мая 2020 г., 13:46:22 | 5 - 9 классы

Составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10?

Составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10.

(через паскаль).

Art87 8 сент. 2020 г., 20:23:40 | 5 - 9 классы

По теме обработка строк в паскале записать программу с любыми двумя словами?

По теме обработка строк в паскале записать программу с любыми двумя словами.

(объединение строк, длина строки, копирование, поиск, удаление).

Alisjurawlyowa 10 окт. 2020 г., 20:59:38 | 5 - 9 классы

Составьте программу, которая находит сумму чётных чисел и произведение нечётных чисел в диапазоне от 1 до 10?

Составьте программу, которая находит сумму чётных чисел и произведение нечётных чисел в диапазоне от 1 до 10.

Koshak109 23 сент. 2020 г., 21:31:22 | 10 - 11 классы

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс?

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс.

Shkololo228339 21 апр. 2020 г., 13:14:36 | 10 - 11 классы

Задан массив из 10 целых чисел?

Задан массив из 10 целых чисел.

Написать программу которая находт - сумму всех элементов массива - колличество чётных и нечётных элементов массива.

Andeychend1 12 окт. 2020 г., 05:29:37 | 5 - 9 классы

Составте программу вычеления суммы нечётных и произведения чётных чисел в диапазоне от 40 до 60?

Составте программу вычеления суммы нечётных и произведения чётных чисел в диапазоне от 40 до 60.

Grin25 6 авг. 2020 г., 07:37:10 | 5 - 9 классы

Составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10?

Составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10.

Millerr 17 апр. 2020 г., 07:48:37 | 5 - 9 классы

Помогите пожалуйста ?

Помогите пожалуйста .

Паскаль .

Составьте программу нахождения произведения нечётных чисел 3•5•7.

•13.

5SERGEY5 14 окт. 2020 г., 15:52:02 | 10 - 11 классы

Дан массив x(7)?

Дан массив x(7).

Найти номера нечётных элементов, стоящих на чётных местах (паскаль).

На этой странице находится ответ на вопрос Напистаь программу удаления из строки чётных или нечётных чисел в Паскале?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.