По теме обработка строк в паскале записать программу с любыми двумя словами?

Информатика | 5 - 9 классы

По теме обработка строк в паскале записать программу с любыми двумя словами.

(объединение строк, длина строки, копирование, поиск, удаление).

Ответить на вопрос
Ответы (1)
Atataaa 8 сент. 2020 г., 20:23:42

Var s1, s2 : string ; i, n1, n2 : integer ;

begin writeln('Введите первое слово') ; readln(s1) ; writeln('Введите второе слово') ; readln(s2) ; writeln('Объединение слов : ', s1 + s2) ; writeln('Длина первого слова : ', length(s1)) ; writeln('Длина второго слова : ', length(s2)) ; for i : = 1 to length(s1) do if s1[i] = 'а' then inc(n1) ; for i : = 1 to length(s2) do if s2[i] = 'a' then inc(n2) ; writeln('В первом слове ', n1, ' букв "а" ') ; writeln('Во втором слове ', n2, ' букв "а" ') ; writeln('Первые 5 букв первого слова : ', copy(s1, 1, 5)) ; writeln('Первые 5 букв второго слова : ', copy(s2, 1, 5)) ; delete(s1, length(s1) - 4, 5) ; delete(s2, length(s2) - 4, 5) ; writeln('Результат удаления последних 5 букв первого слова : ', s1) ; writeln('Результат удаления последних 5 букв второго слова : ', s2) ;

end.

Efimoveevgeniy 2 авг. 2020 г., 12:07:00 | 10 - 11 классы

Дана строка заменить все вхождения "по" на "под"?

Дана строка заменить все вхождения "по" на "под".

Написать программу на Паскале.

Sevan255906 14 июн. 2020 г., 18:08:01 | 10 - 11 классы

Как написать программу "Бегущая строка" на языке Паскаль?

Как написать программу "Бегущая строка" на языке Паскаль?

Sportgirl 20 дек. 2020 г., 02:01:38 | 5 - 9 классы

Дана строка ?

Дана строка .

Написать программу для вывода на экран первой буквы строки.

Срочно!

(паскаль).

Julis1 4 янв. 2020 г., 16:00:42 | 10 - 11 классы

Написать программу, которая запишет в текстовый файл 6 разных строк?

Написать программу, которая запишет в текстовый файл 6 разных строк.

Строки вводятся с клавиатуры.

Паскаль.

Kras22 17 янв. 2020 г., 12:55:20 | 10 - 11 классы

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом?

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом.

Написать программу меняющую части строки до и после пробела местами и добавляющую в конец строки восклицательный знак.

Решить в паскале.

Alya2001Alina 30 апр. 2020 г., 12:17:29 | 10 - 11 классы

Напистаь программу удаления из строки чётных или нечётных чисел в Паскале?

Напистаь программу удаления из строки чётных или нечётных чисел в Паскале.

Golden6 3 окт. 2020 г., 07:48:36 | 10 - 11 классы

Составить программу которая удаляет из заданной строки заданное слово паскаль?

Составить программу которая удаляет из заданной строки заданное слово паскаль.

Gauharrr 19 февр. 2020 г., 07:10:49 | 5 - 9 классы

Напишите программу паскаль, которая удаляет из строки слог То?

Напишите программу паскаль, которая удаляет из строки слог То.

АнетаХ 15 июн. 2020 г., 10:09:08 | 10 - 11 классы

Составить программу в паскале которая проверяет наличие введенного слова в строке?

Составить программу в паскале которая проверяет наличие введенного слова в строке.

Непонятно 6 дек. 2020 г., 01:10:08 | 10 - 11 классы

Программа вводит две строки?

Программа вводит две строки.

Из более длинной строки программа выводит все символы, коды которых > ; 70.

В короткой строке заменяет все «!

» знаки на « * » и выводит короткую строку на экран.

На странице вопроса По теме обработка строк в паскале записать программу с любыми двумя словами? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.