Дан массив x(7)?

Информатика | 10 - 11 классы

Дан массив x(7).

Найти номера нечётных элементов, стоящих на чётных местах (паскаль).

Ответить на вопрос
Ответы (2)
Paulinesmiley 14 окт. 2020 г., 15:52:08

Мне лениво каждый раз вводить значения от руки, поэтому массив заполняется рандомно (в задаче нет четкого указания) но если нужен ввод с клавы, его нетрудно заменить :

вместо A[i] : = random(20) ; write(A[i] : 4)

надо readln (A[i]) - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

program aaa ;

var A : array[1.

7] of integer ; i : byte ;

begin randomize ; / / запускаем генератор случайных чисел / / формируем и одновременно выводим массив writeln ('Исходный массив : ') ; for i : = 1 to 7 do begin A[i] : = random(20) ; / / рандомное значение write(A[i] : 4) / / вывод массива end ; writeln ; / / проверяем условие и выводим номера нужных элементов : writeln ('номера нечётных элементов, стоящих на чётных местах : ') ; writeln ; for i : = 1 to 7 do if ((i mod 2) = 0) and ((A[i] mod 2) = 1) then writeln (i : 3)

end.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Результат работы программы :

Исходный массив : 13 16 7 11 11 5 17

номера нечётных элементов, стоящих на чётных местах : 4 6.

Kseniyashcherb 14 окт. 2020 г., 15:52:09

А мне еще более лениво, поэтому решение на PascalABC.

Net 3.

2

Зачем напрягаться, если автор жадный и задачу за 5 баллов ставит?

Begin var x : = ArrRandom(7, - 20, 20) ; x.

Println ; x.

Select((e, i) - > ; (e, i)).

Where(a - > ; (a[0] mod 2< ; > ; 0) and (a[1] mod 2 = 0)).

Select(a - > ; a[1] + 1).

Println

end.

Пример

20 9 13 - 9 7 - 8 - 6

3 5.

Jenny0919 7 нояб. 2020 г., 17:49:00 | 10 - 11 классы

Паскаль?

Паскаль.

Дана квадратная матрица(случайные числа от - 10 до 10) организовать вывод в виде матрицы.

Подсчитать количество чётных и нечётных элементов главной диагонали.

Vugyggvyub 12 апр. 2020 г., 16:32:30 | 10 - 11 классы

Паскаль, помогите?

Паскаль, помогите!

В числовом массиве из 10 элементов, заданных случайным образом от - 100 до 500.

Найти : 1) сумму положительных элементов, стоящих на чётных местах ; 2) произведение элементов массива, кратных 3 и стоящих на нечётных местах ;

Ventler1002 15 мая 2020 г., 07:08:20 | 10 - 11 классы

Решить задачу в Паскале (абв - всё в одной программе)"В числовом массиве из 10 элементов, заданных с клавиатуры :а) найти сумму положительных эелементов, стоящих на чётных местах ;б) найти произведени?

Решить задачу в Паскале (абв - всё в одной программе)

"В числовом массиве из 10 элементов, заданных с клавиатуры :

а) найти сумму положительных эелементов, стоящих на чётных местах ;

б) найти произведение элементов массива, кратных 3 и стоящих на нечётных местах ;

в) найти кол - во двузначных чисел в массиве.

"

СРОЧНО!

Жду верного решения : ) спасибо заранее.

Monstepilya 28 мар. 2020 г., 08:26:14 | 10 - 11 классы

Дан массив из n чисел?

Дан массив из n чисел.

Найти номер первого чётного элемента массива ; если чётных элементов нет, то ответом должно быть число 0.

Помогите написать программу в паскаль.

Егорик 12 дек. 2020 г., 23:26:46 | 10 - 11 классы

Дано шестизначное число?

Дано шестизначное число.

Найти произведение цифр, стоящих на чётных местах.

Tatohka3331 29 февр. 2020 г., 04:13:41 | 10 - 11 классы

Паскаль ?

Паскаль .

Вычеркиватели.

Вычеркните из слова Х буквы, стоящие на чётных местах.

Zhasmin19770 19 янв. 2020 г., 23:34:20 | 5 - 9 классы

Паскаль : Массив состоит из 20 элементов?

Паскаль : Массив состоит из 20 элементов.

Найти сумму нечётных элементов.

Найти сумму чётных элементов.

Надо сделать с использованием Random.

Помогите плиз!

AvraamliNkoln 16 окт. 2020 г., 09:59:02 | 5 - 9 классы

Массив содержит N случайных двузначных чисел?

Массив содержит N случайных двузначных чисел.

Определить сколько в данном массиве чётных чисел.

Вывести все его элементы с нечётными номерами.

Маша999910 26 мар. 2020 г., 23:07:43 | 5 - 9 классы

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале)?

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале).

Данил3468 13 дек. 2020 г., 19:24:22 | 10 - 11 классы

Найти сумму положительных элементов массива, стоящих на чётных местахПОМОГИТЕ, ПРОШУ?

Найти сумму положительных элементов массива, стоящих на чётных местах

ПОМОГИТЕ, ПРОШУ!

СРОЧНО!

20б! .

Перед вами страница с вопросом Дан массив x(7)?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.