С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем?

Информатика | 10 - 11 классы

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем.

Найти количество отрицательных чисел и сумму чисел кратных 4.

Ответить на вопрос
Ответы (1)
Ibra0589 31 дек. 2020 г., 04:01:53

Var

x, s, count : longint ;

begin

x : = 1 ;

s : = 0 ;

count : = 0 ;

while x < ; > ; 0 do

begin

read(x) ;

if x < ; 0 then

inc(count) ;

if x mod 4 = 0 then

s : = s + x ;

end ;

writeln(count, ' ', s) ;

end.

Сень123 26 сент. 2020 г., 08:30:05 | 5 - 9 классы

ПОМОГИТЕ С ПАСКАЛЕМ?

ПОМОГИТЕ С ПАСКАЛЕМ.

С клавиатуры вводятся 7 целых чисел.

Вычислить количество отрицательных членов этой последовательности.

Zarechnev03 31 мая 2020 г., 23:07:23 | 10 - 11 классы

Вводить с клавиатуры 10 целых чисел, выдать на экран количество положительных чисел, количество отрицательных , количество нулевых?

Вводить с клавиатуры 10 целых чисел, выдать на экран количество положительных чисел, количество отрицательных , количество нулевых.

Bugor150287 18 янв. 2020 г., 22:07:11 | 5 - 9 классы

Найти сумму целых положительных чисел из промежутка от А до В, кратных 4 (значения переменных А и В вводятся клавиатуры)?

Найти сумму целых положительных чисел из промежутка от А до В, кратных 4 (значения переменных А и В вводятся клавиатуры).

Максим3467 24 июл. 2020 г., 23:49:16 | 5 - 9 классы

Срооооочно?

Срооооочно!

Вводится последовательность из N целых чисел.

Найти количество четных чисел.

Знаток121095 5 мар. 2020 г., 07:35:27 | 5 - 9 классы

С клавиатуры вводится несколько чисел?

С клавиатуры вводится несколько чисел.

Найти сумму чисел кратных 5 и кол - во положительных.

823a 14 сент. 2020 г., 08:45:24 | 5 - 9 классы

Последовательно вводится n - целых чисел?

Последовательно вводится n - целых чисел.

Найти сумму чётных чисел.

Asdfar2002 24 окт. 2020 г., 11:55:33 | 10 - 11 классы

С клавиатуры вводится n чисел?

С клавиатуры вводится n чисел.

Найти сумму и количество трехзначных и нечетных чисел.

Pascal.

Mahamusatova 29 дек. 2020 г., 20:31:57 | 10 - 11 классы

Пожалуйста, помогите?

Пожалуйста, помогите!

Срочно!

В ПАСКАЛЕ : 1) найти количество положительных целых чисел от 45 до 215 ; 2) Найти сумму положительных целых чисел от - 50 до 200, кратных 5 и 8 ; 3) Найти сумму и количество отрицательных четных целых чисел, введенных с клавиатуры.

Печать результата по вводу числа 0.

Maksimdonchenko 3 дек. 2020 г., 10:14:31 | 10 - 11 классы

Пусть с клавиатуры вводятся последовательно N целых чисел?

Пусть с клавиатуры вводятся последовательно N целых чисел.

Найти количество двухзначных чисел.

Маркуша9 4 нояб. 2020 г., 07:58:30 | 5 - 9 классы

ДАМ 40?

ДАМ 40!

БАЛЛОВ!

ПОМОГИТЕ!

Написать программу, в которой вводится последовательность целых чисел, оканчивающаяся нулем (т.

Е. признак окончания ввода чисел в последовательности – ввод нуля).

Программа должна посчитать и вывести количество отрицательных чисел в этой последовательности.

Программу реализовать двумя способами : при помощи цикла с пред - и пост - условием.

Вы находитесь на странице вопроса С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.