Даны два числа?

Информатика | 5 - 9 классы

Даны два числа.

Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы.

Даны три числа.

Если хотя бы одно из чисел - отрицательное, то найти Iа + b + cI иначе а + b + c + d в корне.

Даны три числа.

Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа ПОМОГИТЕ ОЧЕНЬ ПРОШУ.

Ответить на вопрос
Ответы (1)
Sasha2993270 21 сент. 2020 г., 20:12:55

Уже писал, но попал в баг(

Так вот.

В паскале это будет так :

1)var a, b, c : integer ;

begin readln(a, b) ; if a div 2 = 0 then c : = (a + b) * (a + b) * (a + b) ; else c : = a * a * a + b * b * b ; writeln(c) ;

end.

2)var a, b, c : integer ; d : real ;

begin readln(a, b, c) ; if (a< ; 0) or (b< ; 0) or (c< ; 0) then d : = abs(a + b + c) else d : = sqrt(a + b + c) ; writeln(d : 0 : 2) ;

end.

3)var a, b, c : integer ;

begin readln(a, b, c) ; if (a * b * c< ; 0) then begin a : = a * a ; b : = b * b ; c : = c * c ; end else begin a : = abs(a) ; b : = abs(b) ; c : = abs(c) ; end ; writeln( a, ' ', b, ' ', c) ;

end.

Вот так вот.

Hilki826 12 янв. 2020 г., 18:35:09 | 5 - 9 классы

1) Даны два числа?

1) Даны два числа.

Если они оба четные, то найдите сумму чисел, иначе разность.

2) Даны два числа.

Если сумма чисел больше 1, то найдите целую часть от деления, иначе остаток от деления.

Пожалуйста с понятным решением.

Помошник107 3 февр. 2020 г., 19:47:01 | 10 - 11 классы

PascalОпределить среди 3 введенных чисел сумму отрицательных и положительных?

Pascal

Определить среди 3 введенных чисел сумму отрицательных и положительных.

Если больше сумма положительных, то найти разность первого и второго числа, а иначе найти произведение 3 - х чисел.

ТОЛЬКО ПРОГРАММА.

Анжелика2012 4 нояб. 2020 г., 23:22:59 | 5 - 9 классы

Даны числа a и b?

Даны числа a и b.

Если оба отрицательные, то возвести каждое в квадрат иначе, увеличить на 100.

P. S.

Программа Pascal.

Vladlalalaalala 7 дек. 2020 г., 22:41:27 | 5 - 9 классы

Ввести число?

Ввести число.

Если оно положительное, возвести его в квадрат, иначе возвести его в куб.

NRyabikovaNN 25 сент. 2020 г., 05:39:05 | 10 - 11 классы

Написать программу в Pascal даны целые числа а1?

Написать программу в Pascal даны целые числа а1.

Аn. Если в данной последовательности ни одно четное число не расположено после нечетного.

То получить все отрицательные члены последовательности иначе - положительное.

Виталия15032011 15 окт. 2020 г., 06:29:34 | 5 - 9 классы

Даны 3 числа a, b, c?

Даны 3 числа a, b, c.

Если a< ; b< ; c то найти сумму этих чисел, иначе найти произведение.

Informator19 7 июн. 2020 г., 15:53:58 | 5 - 9 классы

Даны два числа a и b, если они равны, то вывести сумму, иначе произведение?

Даны два числа a и b, если они равны, то вывести сумму, иначе произведение.

НастёнаNastua 16 дек. 2020 г., 07:43:07 | 10 - 11 классы

Определить минимум из 3 введенных чисел?

Определить минимум из 3 введенных чисел.

Если минимум отрицательное число, то найти сумму трех чисел, а иначе найти их произведение

В паскале.

Iolantamalceva 25 окт. 2020 г., 22:48:04 | 5 - 9 классы

Помогите пожалуйста информатикой?

Помогите пожалуйста информатикой!

1. Дано число а если это число не четное и больше 10 тогда увеличить это число в 5 раз иначе в 10 раз.

Даны числа а и b если число а кратно b тогда найти сумму иначе разность.

Даны числа а и b если первое число кратно 2 или кратно 3 второе число тогда к 1 числу прибавить 10 иначе ко второму числу прибавить 20.

Postriganalla 8 дек. 2020 г., 15:39:13 | 5 - 9 классы

Информатика 9 класс2) Даны 4 числа , если сумма первых двух больше или равна сумме вторых двух, то найти сумму и произведение этих чисел, иначе найти среднее арифметическое и увеличить каждое число на?

Информатика 9 класс

2) Даны 4 числа , если сумма первых двух больше или равна сумме вторых двух, то найти сумму и произведение этих чисел, иначе найти среднее арифметическое и увеличить каждое число на 3.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Даны два числа?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.