ПОМОГИТЕ, ПОЖАЛУЙСТА?

Информатика | 10 - 11 классы

ПОМОГИТЕ, ПОЖАЛУЙСТА!

Написать программу, которая получает возраст человека от 0 до 120 лет и выводит со словом "год", "года", "лет".

Ответить на вопрос
Ответы (1)
Эльмира23011985 22 июл. 2020 г., 18:00:36

Ищем закономерности.

Год : 1, 21, 31, 41, 51, 61, 71, 81, 91, 101

(оканчиваетсянаединицу, исключение : 11 и 111)

Года : 2 - 4, 22 - 24, 32 - 34, 42 - 44, 52 - 54, 62 - 64, 72 - 74, 82 - 84, 92 - 94, 102 - 104

(оканчиваетсяна2, 3или4, исключения : 12, 13, 14, 112, 113, 114)

Лет : 0, 5 - 20, 25 - 30, 35 - 40, 45 - 50, 55 - 60, 65 - 70, 75 - 80, 85 - 90, 95 - 100, 105 - 120

(оканчиваетсяна0, 5 - 9, плюс исключения изпрошлыхпунктов)

У исключений есть общее : остаток при делениина100будетвпромежуткеот11до14.

N - возраст

Языкпрограммирования : Паскаль

var

n : integer ;

begin

read (n) ;

n : = n mod 100 ;

if n in [11.

14] then

writeln ('лет') ;

else

begin

n : = nmod10 ;

case n of

1 : writeln ('год') ;

2.

4 : writeln ('года') ;

0, 5.

9 : writeln ('лет') ;

end ;

readln ;

end.

Nikker 8 сент. 2020 г., 03:45:37 | 10 - 11 классы

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В БЕЙСИКЕ Дано целое число n (1 ≤ n ≤ 99), определяющее возраст человека (в годах)?

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В БЕЙСИКЕ Дано целое число n (1 ≤ n ≤ 99), определяющее возраст человека (в годах).

Для этого числа напечатать фразу «мне n лет», учитывая при этом, что при некоторых значениях n слово «лет» надо заменить на слово «год» или «года».

Izzatullo 29 янв. 2020 г., 04:51:13 | 5 - 9 классы

Написать программу которая запрашивает возраст мужчины и сообщает сколько лет ему осталось до пенсии?

Написать программу которая запрашивает возраст мужчины и сообщает сколько лет ему осталось до пенсии.

Cbojarin 25 дек. 2020 г., 00:49:31 | 5 - 9 классы

Ребята, СРОЧНО, прошу, помогите, пожалуйста с заданием?

Ребята, СРОЧНО, прошу, помогите, пожалуйста с заданием!

Выполнить нужно в Кумире.

"Ввести возраст человека (от 1 до 150 лет) и вывести его вместе с последующим словом «год», «года» или «лет»".

AndreyAgafonov4 1 июл. 2020 г., 06:46:19 | 5 - 9 классы

Вывести возраст человека ( от 1 до 99) и вывести возраст со словом ( год, года или лет) эот через программу паскаль) помогите как ниписать в программе типо такого : program qq ; и тд?

Вывести возраст человека ( от 1 до 99) и вывести возраст со словом ( год, года или лет) эот через программу паскаль) помогите как ниписать в программе типо такого : program qq ; и тд.

ПолиТвикс 20 авг. 2020 г., 16:52:18 | 10 - 11 классы

Помогите составить программу в Паскале?

Помогите составить программу в Паскале.

Дан возраст человека мужского пола в годах.

Вывести на экран возрастную категорию : до года - младенец, от года до 11 лет - мальчик, от 12до 15 лет - подросток, от 16 до 25 - юноша, от 26 до 50 лет - мужчина, более 60 лет - старик.

Nayvert24 6 нояб. 2020 г., 21:56:45 | 5 - 9 классы

Ввести возраст человека(от 1 до 100 лет) и вывести его вместе с последующим словом?

Ввести возраст человека(от 1 до 100 лет) и вывести его вместе с последующим словом.

("Год", "Года" или "Лет").

Novikova656 17 окт. 2020 г., 13:17:55 | 10 - 11 классы

Составить программу для c + + "Ввести возраст человека и вывести его вместе со словом ГОД, ГОДА, ЛЕТ(пример вам 1 год, вам 2 года, вам 55 лет)?

Составить программу для c + + "Ввести возраст человека и вывести его вместе со словом ГОД, ГОДА, ЛЕТ(пример вам 1 год, вам 2 года, вам 55 лет).

Naskaol 19 мар. 2020 г., 13:39:30 | 1 - 4 классы

Написать в Паскале программу : Ввести возраст человека (от 1 до 150 лет) и вывести его вместе с предыдущим словам "год", "года" или "лет"?

Написать в Паскале программу : Ввести возраст человека (от 1 до 150 лет) и вывести его вместе с предыдущим словам "год", "года" или "лет".

Zombi355282 12 окт. 2020 г., 03:12:24 | 10 - 11 классы

Напишите программу, которая при вводе с клавиатуры возраста человека, выводит сообщение «Я с тобой дружу», если возраст меньше 17 лет и «Я с тобой не дружу», если меньше 17?

Напишите программу, которая при вводе с клавиатуры возраста человека, выводит сообщение «Я с тобой дружу», если возраст меньше 17 лет и «Я с тобой не дружу», если меньше 17.

Karymovemil 9 нояб. 2020 г., 09:57:58 | 5 - 9 классы

Уровень A?

Уровень A.

Напишите программу, которая получает три числа – рост трёх спортсменов, и выводит сообщение 'По росту.

', если числа введены по возрастанию, или сообщение 'Не по росту!

', если они введены в другом порядке Пример : Введите рост трёх спортсменов : 165 170 172 По росту.

Пример : Введите рост трёх спортсменов : 175 170 172 Не по росту.

Уровень B.

Напишите программу, которая получает с клавиатуры номер месяца и выводит название соответствующего ему время года или сообщение об ошибке.

Пример : Введите номер месяца : 5 Весна.

Уровень C.

Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом 'год', 'года' или 'лет'.

Например, '21 год', '22 года', '25 лет'.

Пример : Введите возраст : 18 Вам 18 лет.

Пример : Введите возраст : 21 Вам 21 год.

Пример : Введите возраст : 22 Вам 22 года.

Вы открыли страницу вопроса ПОМОГИТЕ, ПОЖАЛУЙСТА?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.