Написать программу и доказать её работоспособность?

Информатика | 5 - 9 классы

Написать программу и доказать её работоспособность.

Условие задачи : Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных.

Pascal ABC Полное решение задачи, заранее спасибо).

Ответить на вопрос
Ответы (1)
Alinusa1991 27 апр. 2020 г., 15:15:23

Program z8 ;

uses crt ;

var a : array[1.

259] of shortint ;

i, k, n : byte ;

s : integer ;

begin

clrscr ;

randomize ;

write('Vvedi razmernost massiva = ') ;

readln(n) ;

for i : = 1 to n do begin

a[i] : = random(100 - - 100 + 1) + - 100 ;

write(a[i] : 4) ;

if a[i]< ; 0 then

s : = s + a[i] ;

if odd(a[i]) then

k : = k + 1 ;

end ;

writeln ;

writeln('Сумма отрицательных элементов равна ', s) ;

writeln('Кол - во нечётных элементов равно ', k) ;

readkey

end.

Zhantonina 13 янв. 2020 г., 02:03:15 | 5 - 9 классы

(Pascal) Задача : Ввести массив из 5 элементов с клавиатуры?

(Pascal) Задача : Ввести массив из 5 элементов с клавиатуры.

Вывести элементы на экран и найти их сумму.

РЕШИТЕ ПОЗЯЗЯ!

Zinenko05 20 сент. 2020 г., 13:25:24 | 10 - 11 классы

Написать программу для решения следующей задачи : Имеется массив чисел, вводимый с клавиатуры?

Написать программу для решения следующей задачи : Имеется массив чисел, вводимый с клавиатуры.

Вычислить сумму и произведение всех чисел массива.

Результаты вывести на экран.

Язык c + + .

Спасибо.

Ira1234567891234 16 окт. 2020 г., 23:50:41 | 10 - 11 классы

Разработать блок схему и написать программу в QBASIC Дан массив А из 20 элементов?

Разработать блок схему и написать программу в QBASIC Дан массив А из 20 элементов.

Найти сумму отрицательных элементов массива.

Результат вывести на печать.

Инфинитив 23 июл. 2020 г., 13:42:12 | 10 - 11 классы

В одномерном массиве А , состоящий из N действительных элементов , вычислить : a ) сумму отрицательных элементов массива ; b ) количество элементов , удовлетворяющих условию 7 Pascal?

В одномерном массиве А , состоящий из N действительных элементов , вычислить : a ) сумму отрицательных элементов массива ; b ) количество элементов , удовлетворяющих условию 7 Pascal.

Klublena2011 27 июн. 2020 г., 01:58:52 | 5 - 9 классы

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран?

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран.

1) подсчитать количество элементов в массиве, значения которых больше 3.

2) найти сумму всех отрицательных элементов массива.

3) заменить все отрицательные элементы массива их индексами.

Вывести новый массив на экран

4)найти максимальный элемент.

2001viola 24 янв. 2020 г., 05:33:36 | 5 - 9 классы

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25?

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.

Программа должна :

1)выводить на экран сначала все элементы массива, стоящие на чётных местах, а затем - все элементы массива, стоящие на нечётных местах ;

2)вывести на экран сумму всех элементов массива, значение которых кратны 3 или 5.

3)найти минимальное значение и максимальное значение элементов массива.

Lenagosa 1 мая 2020 г., 08:00:24 | 5 - 9 классы

Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных?

Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных.

Паскаль.

Vika19973 10 февр. 2020 г., 04:51:12 | 10 - 11 классы

Pascal ABC?

Pascal ABC.

Написать программу, которая находит сумму четных элементов массива произвольного размера (размер и элементы массива вводятся с клавиатуры).

Arkalash2003 24 сент. 2020 г., 04:42:05 | 5 - 9 классы

Помогите решить задачу в Pascal ABC, с помощью массивов?

Помогите решить задачу в Pascal ABC, с помощью массивов!

1. Найти количество и среднее арифметическое всех отрицательных элементов массива из 20 элементов (генерируются случайные числа от - 10 до + 10).

Заранее огромное спасибо)))).

Vasyapupkin201 2 июл. 2020 г., 19:43:53 | 5 - 9 классы

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран?

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран.

Язык Паскаль.

Перед вами страница с вопросом Написать программу и доказать её работоспособность?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.