Определить кол - во нечетных цифр в числе?

Информатика | 5 - 9 классы

Определить кол - во нечетных цифр в числе.

Ответить на вопрос
Ответы (1)
Koks1994 7 июл. 2020 г., 18:00:58

Var k, x : integer ;

begin

k : = 0 ;

writeln('Введите число x') ;

read(x) ;

while x> ; 0 do begin

if x mod 10 mod 2< ; > ; 0 then k : = k + 1 ;

x : = x div 10 ;

end ;

writeln(k) ;

end.

Svetaromanova 9 нояб. 2020 г., 06:14:30 | 10 - 11 классы

Определите будет ли заданное число нечетным трехзначн?

Определите будет ли заданное число нечетным трехзначн.

Zhuzhechko 28 авг. 2020 г., 06:24:19 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль.

Akdjsfw 30 янв. 2020 г., 17:02:43 | 5 - 9 классы

Введено трехзначное число?

Введено трехзначное число.

Если сумма его цифр нечетна, то увеличить число вдвое.

Помогите пожалуйста.

Fakerjke 10 нояб. 2020 г., 04:19:49 | 5 - 9 классы

Составьте программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом ?

Составьте программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом .

Пример ввода :

1245

Пример вывода :

5 - нечетное число.

Podgornyyn 25 нояб. 2020 г., 03:16:45 | 10 - 11 классы

Вводится целое положительное число?

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

Yanovskyshura 23 нояб. 2020 г., 23:24:06 | 5 - 9 классы

Паскаль, цикл с предусловием while?

Паскаль, цикл с предусловием while.

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

SofArkadiu 12 нояб. 2020 г., 19:12:02 | 5 - 9 классы

PASCAL ABC, программа?

PASCAL ABC, программа!

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

Mikki01 26 июн. 2020 г., 06:52:56 | 5 - 9 классы

Найти кол - во нечетных делителей числа больших К?

Найти кол - во нечетных делителей числа больших К.

Помогите.

Olegos2000 31 мар. 2020 г., 11:07:46 | 10 - 11 классы

Для введённого с клавиатуры 6 - значного числа определить, являются ли все цифры числа нечетные?

Для введённого с клавиатуры 6 - значного числа определить, являются ли все цифры числа нечетные.

Написать программу на C + +.

Неумная 6 дек. 2020 г., 11:29:40 | 5 - 9 классы

Дано число?

Дано число.

Определить чему равна сумма нечетных цифр в этом числе.

Если вам необходимо получить ответ на вопрос Определить кол - во нечетных цифр в числе?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.