Обнулить все отрицательные элементы массива и посчитать количество остальных?

Информатика | 10 - 11 классы

Обнулить все отрицательные элементы массива и посчитать количество остальных.

Ответить на вопрос
Ответы (1)
Папочка3 23 июн. 2020 г., 17:30:31

Var counter, i, N : integer ; mas : array[1.

9999] of integer ;

begin readln(N) ; for i : = 1 to N do readln(mas[i]) ; for i : = 1 to N do if mas[i]< ; 0 then mas[i] : = 0 else counter : = counter + 1 ; for i : = 1 to N do write(mas[i], ' ') ;

end.

Gfhhgjugkjhf 11 дек. 2020 г., 01:09:15 | 5 - 9 классы

Найти наибольший среди элементов массива А(10), остальные обнулить?

Найти наибольший среди элементов массива А(10), остальные обнулить.

Iissrr 8 нояб. 2020 г., 13:25:41 | 10 - 11 классы

Напишите в виде программы для паскаля?

Напишите в виде программы для паскаля.

В массиве А(5) посчитать количество положительных и отрицательных элементов.

Sveta25831983 24 мар. 2020 г., 05:37:04 | 10 - 11 классы

В линейном массиве посчитать количество элементов, значение которых совпадает с ихиндексом?

В линейном массиве посчитать количество элементов, значение которых совпадает с их

индексом.

Mirysa230902 6 дек. 2020 г., 07:15:14 | 10 - 11 классы

Найти количество положительных и отрицательных элементов в одномерном массиве?

Найти количество положительных и отрицательных элементов в одномерном массиве.

01092006 22 янв. 2020 г., 12:08:21 | 5 - 9 классы

1) Массив из 30 элементов?

1) Массив из 30 элементов.

Посчитать отдельно среднее арифметическое положительных и отрицательных 2) Посчитать количество нечетных элементов массива.

Совсем не понимаю информатику, пожалуйста, помогите с этими задачами!

: С.

MAXCHEBOTKOV 30 янв. 2020 г., 14:37:22 | 5 - 9 классы

Написать программу Заполнить массив из 15 элементов случайными числами ( - 20 ; 80) Посчитать сумму всех элементов массива Посчитать количество отрицательных элементов?

Написать программу Заполнить массив из 15 элементов случайными числами ( - 20 ; 80) Посчитать сумму всех элементов массива Посчитать количество отрицательных элементов.

Ангелина2003ангел 8 янв. 2020 г., 15:03:48 | 5 - 9 классы

Дан одномерный массив целых чисел состоящий из 22 двух элементов посчитать количество отрицательных элементов массива, а так же количество элементов которые делятся на 9?

Дан одномерный массив целых чисел состоящий из 22 двух элементов посчитать количество отрицательных элементов массива, а так же количество элементов которые делятся на 9.

Помогите отредактировать программу.

Масяня329 24 сент. 2020 г., 22:22:50 | 5 - 9 классы

ИНФОРМАТИКА, ПОМОГИТЕ?

ИНФОРМАТИКА, ПОМОГИТЕ.

ПАСКАЛЬ, МАССИВЫ.

Задать случайным образом 10 элементов массива : целые числа из интервала от - 5 до 50.

Найти : 2) произведение элементов, стоящих на чётных местах ; 3) количество отрицательных элементов.

4) Ввести с клавиатуры 12 элементов числового массива.

Все положительные увеличить на 100, все отрицательные обнулить.

Loginov1919 22 сент. 2020 г., 03:27:00 | 1 - 4 классы

Посчитать количество положительных элементов массива из 10 чисел?

Посчитать количество положительных элементов массива из 10 чисел.

Juliakisa24 4 окт. 2020 г., 09:30:27 | 5 - 9 классы

В одномерном массиве из 10 чисел посчитать количество всех элементов, кратных 7 и сумму остальных элементов?

В одномерном массиве из 10 чисел посчитать количество всех элементов, кратных 7 и сумму остальных элементов.

Перед вами страница с вопросом Обнулить все отрицательные элементы массива и посчитать количество остальных?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.