Пожалуйста помогите решить желательно все или хотя бы одну (P?

Информатика | 5 - 9 классы

Пожалуйста помогите решить желательно все или хотя бы одну (P.

S. программа для программы Turbo Pascal) 1.

Написать программу, которая предлагает ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот.

(123 - 321) 3.

Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Ответить на вопрос
Ответы (1)
Aina2000 29 нояб. 2020 г., 16:48:30

1 и 2 работают до макс.

Значения integer, а не только трехзначные

var i, s : integer ;

begin

readln(i) ;

while i> ; 0 do begin

s : = i mod 10 ;

i : = i div 10 ;

end ;

writeln(s) ;

end.

Var i : integer ;

begin

readln(i) ;

while i> ; 0 do begin

write(i mod 10) ;

i : = i div 10 ;

end ;

end.

Var a, b, c : integer ;

begin

readln(a, b, c) ;

writeln('Sum = ', a + b + c, ' Proizvedenie = ', a * b * c, ' Sr.

Arifm = ', (a + b + c) / 3) ;

end.

20050830 10 сент. 2020 г., 22:01:51 | 10 - 11 классы

Создайте программу, которая предлагает ввести с клавиатуры две строки a и b, соеденяет их и выводит результат слиния?

Создайте программу, которая предлагает ввести с клавиатуры две строки a и b, соеденяет их и выводит результат слиния.

Rord2014 16 нояб. 2020 г., 12:22:12 | 5 - 9 классы

Написать на Паскале программу нахождения суммы, произведения и среднего значения элементов массива, кол - во элементов ввести в программе?

Написать на Паскале программу нахождения суммы, произведения и среднего значения элементов массива, кол - во элементов ввести в программе.

Galinasokollska 8 мая 2020 г., 06:22:24 | 5 - 9 классы

Найти сумму чисел?

Найти сумму чисел.

Числа ввести с клавиатуры.

Написать программу.

Blood971 16 февр. 2020 г., 17:30:53 | 5 - 9 классы

Написать программу, выдающую результат - равна ли сумма цифр введенного положительного числа 10 с защитой от неверного ввода?

Написать программу, выдающую результат - равна ли сумма цифр введенного положительного числа 10 с защитой от неверного ввода.

(неверный вод - если сумма не равна 10 то программа должна заново спросить какие числа он хочет ввести) Делать в Turbo Pascal.

Rom99 29 сент. 2020 г., 01:32:33 | 1 - 4 классы

Написать программу, которая просит пользователя ввести три числа и находит их среднее арифметическое?

Написать программу, которая просит пользователя ввести три числа и находит их среднее арифметическое.

Chernyshovaali 19 сент. 2020 г., 15:44:36 | 5 - 9 классы

Как на Pascal ABC написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры?

Как на Pascal ABC написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры?

Количество цифр в числе не известно!

Число целочисленное!

Желательно с объяснениями ( вне программы ).

Заранее спасибо!

Керим1 11 авг. 2020 г., 21:30:24 | 10 - 11 классы

Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры?

Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры.

Milckamilana20 9 апр. 2020 г., 22:29:50 | 5 - 9 классы

Ввести три числа найти их разность и среднее арифметическое?

Ввести три числа найти их разность и среднее арифметическое.

( написать программу в паскаль).

Tyurikov4444 12 авг. 2020 г., 19:16:51 | 5 - 9 классы

Составьте программу, которая предлагает ввести с клавиатуры две строки, а затем выводит эти строки в алфавитном порядке?

Составьте программу, которая предлагает ввести с клавиатуры две строки, а затем выводит эти строки в алфавитном порядке.

Людмила286368 17 дек. 2020 г., 19:25:42 | 5 - 9 классы

Помогите написать программу в Паскале, пожалуйстаНаписать программу : Ввести двухзначное число?

Помогите написать программу в Паскале, пожалуйста

Написать программу : Ввести двухзначное число.

На этой странице находится ответ на вопрос Пожалуйста помогите решить желательно все или хотя бы одну (P?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.