Дано натуральное число?

Информатика | 5 - 9 классы

Дано натуральное число.

Проверить, является ли число двузначным, и равна ли первая цифра числа второй.

Ответить на вопрос
Ответы (1)
PatriciaAtom1 9 мар. 2020 г., 10:15:37

Var x, a, b : integer ;

Begin

write('x = ') ; readln(x) ;

if (x div 10) = 0 then writeln('Число однозначное.

') else if (x div 100) = 0 then begin write('Число двухзначное, ') ; a : = x div 10 ; b : = x mod 10 ; if a = b then writeln('и его первая цифра равна второй.

') else writeln('и его первая цифране равна второй.

') ; end else writeln('Это число многозначное.

') ;

End.

Сашка16 13 дек. 2020 г., 22:53:20 | 5 - 9 классы

Четырехзначное число, у которого первая цифра равно второй а третья четвертой, является квадратом двузначного числа?

Четырехзначное число, у которого первая цифра равно второй а третья четвертой, является квадратом двузначного числа.

Найти эти числа.

(паскаль, циклы).

Fff555 23 окт. 2020 г., 01:29:44 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Определить : является ли сумма его цифр двузначным числом.

Tatanka212128 16 авг. 2020 г., 19:41:15 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Определить : а) является ли сумма его цифр двузначным числом ; б) больше ли числа а сумма его цифр.

Drashchiker 21 февр. 2020 г., 23:43:56 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Найти сумму первой и последней цифры этого числа.

Sasha031205 9 авг. 2020 г., 12:18:53 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Является ли сумма его цифр однозначным числом.

Dedit 2 мая 2020 г., 03:57:07 | 5 - 9 классы

Дано 3 двузначных числа?

Дано 3 двузначных числа.

Вывести на экран те числа, в которых сумма цифр является четным числом.

Вадим2351 14 мая 2020 г., 00:59:34 | 10 - 11 классы

Дано натуральное число n?

Дано натуральное число n.

Проверить будут ли все цифры числа различными паскаль.

Верочка1234 16 сент. 2020 г., 10:21:23 | 5 - 9 классы

Проверить, является ли число трехзначным, у которого первая цифра равна последней?

Проверить, является ли число трехзначным, у которого первая цифра равна последней.

(В паскале).

НАСТАСЬЯ0071 20 апр. 2020 г., 04:49:51 | 10 - 11 классы

Дано натуральное число n ?

Дано натуральное число n .

Переставить местами первую и последнюю цифры этого числа.

Vksolopova 6 мар. 2020 г., 16:16:29 | 10 - 11 классы

Даны два целых двузначных числа?

Даны два целых двузначных числа.

Верное ли, что все цифры первого числа больше соответствующих цифр второго числа?

Написать программу для Pascal.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Дано натуральное число?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.