Составить программу вычисления произведения не нулевых элементов массива (а) вещественных чисел [1?

Информатика | 10 - 11 классы

Составить программу вычисления произведения не нулевых элементов массива (а) вещественных чисел [1.

5] . решите пожалуйста.

Ответить на вопрос
Ответы (1)
Aivengo78 18 авг. 2020 г., 01:56:23

Var a : array [1.

5] of real ; / / Массив из пяти вещественных элементов i : integer ; / / Переменная для цикла s : real ; / / Значение произведения

begin s : = 1 ; for i : = 1 to 5 do / / Вводим элементы массива begin writeln('Введите ', i, ' элемент массива') ; readln(a[i]) ; if a[i] < ; > ; 0 then s : = s * a[i] ; {Если элемент массива не равен 0, то умножаем значение произведения на элемент массива} end ; writeln('Произведение не нулевых элементов массива : ', s) ; {Выводим значение произведения}

end.

Merkava163rus 13 июн. 2020 г., 01:32:59 | 5 - 9 классы

1) Составьте программу вычисления в массиве A(N) суммы всех чисел, кратных 3?

1) Составьте программу вычисления в массиве A(N) суммы всех чисел, кратных 3.

2) Составьте программу вычисления в массиве B(8) суммы отрицательных элементов.

3) Составьте программу вычисления среднего арифметического элементов массива.

Пожалуйста.

Очень надо!

Elyagolowina 3 окт. 2020 г., 02:38:18 | 5 - 9 классы

Составить программу вычисления произведения маленького и наибольшего элементов заданной последовательности чисел?

Составить программу вычисления произведения маленького и наибольшего элементов заданной последовательности чисел.

Abdusalamova99 8 апр. 2020 г., 20:11:35 | 10 - 11 классы

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0?

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0.

2)В массиве М из 10 целых чисел найти количество элементов равных 3.

3)В массиве из 8 целых найти номер массива с наибольшим значением.

4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента.

5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Vладимир64 31 янв. 2020 г., 13:04:51 | 10 - 11 классы

В одномерном массиве B, состоящем из 20 вещественных чисел, найтинаибольший элемент и указать его номер в массиве?

В одномерном массиве B, состоящем из 20 вещественных чисел, найтинаибольший элемент и указать его номер в массиве.

Составить схему алгоритма и программу на языке программированияBasic для решения задачи по обработке одномерного массива.

Паоом 19 нояб. 2020 г., 14:16:45 | 10 - 11 классы

1. Составьте программу вычисления в массиве с(15) произведения элементов , кратных 9 2?

1. Составьте программу вычисления в массиве с(15) произведения элементов , кратных 9 2.

Составьте программу вычисления в массиве b(25) среднего арифметического с нечетными числами.

Koshak109 23 сент. 2020 г., 21:31:22 | 10 - 11 классы

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс?

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс.

Ellaelmi 15 мая 2020 г., 13:55:22 | 5 - 9 классы

Составить программу для вычисления суммы элементов массива из 12 целых чисел?

Составить программу для вычисления суммы элементов массива из 12 целых чисел.

Bjfyyf 6 апр. 2020 г., 11:04:38 | 10 - 11 классы

Составить программу вычисления в одномерном массиве С произведения четных и положительных элементов и сумму элементов меньших 6?

Составить программу вычисления в одномерном массиве С произведения четных и положительных элементов и сумму элементов меньших 6.

Kubaeva91 15 мая 2020 г., 21:59:40 | 10 - 11 классы

Составьте программу вычисления суммы тех элементов одномерного массива А(N), что расположены перед нулевым элементом данного массива?

Составьте программу вычисления суммы тех элементов одномерного массива А(N), что расположены перед нулевым элементом данного массива.

Andriymama 19 апр. 2020 г., 21:15:08 | 5 - 9 классы

Программу в паскале?

Программу в паскале.

Составить программу нахождения произведения положительных чисел одномерного массива В(10), элементы которого задаются датчиком случайных чисел.

На странице вопроса Составить программу вычисления произведения не нулевых элементов массива (а) вещественных чисел [1? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.