Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0?

Информатика | 10 - 11 классы

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0.

2)В массиве М из 10 целых чисел найти количество элементов равных 3.

3)В массиве из 8 целых найти номер массива с наибольшим значением.

4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента.

5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Ответить на вопрос
Ответы (1)
Epolinarija 8 апр. 2020 г., 20:11:41

1) Program Massiv1 ; Uses Crt ; var k : array[1.

12] of real ; i, c : integer ;

begin clrscr ; write('Введите элементы массива k : ') ; c : = 0 ; for i : = 1 to 12 do begin readln(k[i]) ; if (k[i]< ; 0) then Inc(c) ; end ; writeln ; writeln ; for i : = 1 to 12 do write(k[i] : 4 : 4) ; writeln ; writeln('Количество элементов < ; 0 : ', c) ; readkey ;

end.

2) Program Massiv2 ; Uses Crt ; var m : array[1.

10] of integer ; i, c : integer ;

begin clrscr ; write('Введите элементы массива m : ') ; c : = 0 ; for i : = 1 to 10 do begin readln(m[i]) ; if (m[i] = 3) then Inc(c) ; end ; writeln ; writeln ; for i : = 1 to 12 do write(m[i] : 4) ; writeln ; writeln('Количество элементов = 3 : ', c) ; readkey ;

end.

В третьем задании видимо имеется ввиду номер элемента этого массива, т.

К по условию задачи массив у нас один.

3) Program Massiv3 ; Uses Crt ; var m : array[1.

8] of integer ; i, c, max : integer ;

begin clrscr ; write('Введите элементы массива m : ') ; c : = 0 ; for i : = 1 to 8 do readln(m[i]) ; writeln ; writeln ; max : = m[1] for i : = 1 to 8 do begin if (m[i]> ; max) then begin max : = m[i] ; c : = i end ; write(m[i] : 4) ;

end ; writeln('Индекс максимального элемента = : ', c) ; readkey ;

end.

4) Program Massiv4 ; Uses Crt ; var m : array[1.

12] of integer ; i, c, max, sum : integer ;

begin clrscr ; write('Введите элементы массива m : ') ; c : = 0 ; sum : = 0 ; for i : = 1 to 12 do readln(m[i]) ; writeln ; writeln ; max : = m[1] for i : = 1 to 12 do begin if (m[i]> ; max) then begin max : = m[i] ; c : = i end ; write(m[i] : 4) ;

end ;

for i : = 1 to c - 1 do sum : = sum + m[i] ; writeln('Количество элементов расположенных до max : ', с - 1) ; writeln('Сумма элементов расположенных до max : ', sum) ; readkey ;

end.

В пятом задании видимо имеется ввиду значения элементов массиваменьшие чем сумма первого и последнего

5) Program Massiv5 ; Uses Crt ; var k : array[1.

15] of real ; sum : real ; i, c : integer ;

begin clrscr ; write('Введите элементы массива k : ') ; c : = 0 ; for i : = 1 to 15 do readln(k[i]) ; sum : = k[1] + k[15] ; writeln ; writeln ; for i : = 1 to 15 do begin write(k[i] : 4 : 4) ; if (k[i]< ; sum) tnen Inc(c) ; end ; writeln ; writeln('Количество элементов : ', c) ; readkey ;

end.

Миньон4 2 янв. 2020 г., 08:46:10 | 10 - 11 классы

Дан массив всех целых чисел ?

Дан массив всех целых чисел .

Найти сумму элементов в массиве.

(Паскаль).

Ariname 14 мая 2020 г., 07:02:43 | 5 - 9 классы

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива?

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел, найти количество отрицательных элементов массива.

3. Дан массив целых чисел, найти количество чётных чисел в массиве.

Zarolik 23 авг. 2020 г., 08:39:14 | 5 - 9 классы

Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива?

Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива.

Длина массива N задается пользователем как константное выражение.

Исходные данные задать вручную или с помощью генератора случайных чисел, учитывая формат элементов массива А.

Тип результата определяется из контекста.

- Вычислить количество отрицательных элементов массива ; - сумму модулей элементов массива, расположенных после максимального элемента.

Настя631прдлвптррии 2 июн. 2020 г., 15:30:58 | 5 - 9 классы

1) Удвоить все элементы массива?

1) Удвоить все элементы массива.

2)Найти сумму элементов двух массивов одинаковой размерности.

4) Найти Минимальные элементы массива и его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива 7) Определить количество максимальных элементов массива P.

S Ребят, все в паскале.

Заранее спасибо = *.

Aleksey2123 3 апр. 2020 г., 17:23:28 | 10 - 11 классы

В МАССИВЕ ИЗ 10 НАЙТИ СУММУ ПОЛОЖИТЕЛЬНЫХ ЧИСЕЛ, ОКАНЧИВАЮЩИХСЯ НА 4 ЭЛЕМЕНТЫ МАССИВА ЦЕЛЫЕ ЧИСЛА?

В МАССИВЕ ИЗ 10 НАЙТИ СУММУ ПОЛОЖИТЕЛЬНЫХ ЧИСЕЛ, ОКАНЧИВАЮЩИХСЯ НА 4 ЭЛЕМЕНТЫ МАССИВА ЦЕЛЫЕ ЧИСЛА.

Аrtemka 1 авг. 2020 г., 20:03:36 | 5 - 9 классы

Найти сумму первых k элементов массива А(20) ; сколько чисел массива не превышает среднее значение суммы n элементов массива?

Найти сумму первых k элементов массива А(20) ; сколько чисел массива не превышает среднее значение суммы n элементов массива.

Aylovat40 16 окт. 2020 г., 08:55:54 | 10 - 11 классы

Дан одномерный массив из 12 чисел?

Дан одномерный массив из 12 чисел.

Элементами массива являются целые числа.

Найти максимальный элемент указанного массива.

Artem1918 1 янв. 2020 г., 05:23:47 | 10 - 11 классы

Создать два одномерных массива, состоящих из целых чисел?

Создать два одномерных массива, состоящих из целых чисел.

Элементы массива вводятся с клавиатуры.

В первом массиве найти номер первого нечетного элемента массива.

Во втором массиве найти первый четный элемент массива.

Решить на Pascal ABC (При решении задач обязательно использовать одномерные массивы и процедуры или функции работы с одномерными массивами.

).

Dmae 5 сент. 2020 г., 11:03:43 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

СРОЧНО!

Задан линейный массив состоящий из n целых чисел.

Массив вводят с клавиатуры.

Найти максимальный элемент массива и его индексный номер.

Найдите количество массива равный 4.

Найти сумму элементов массива.

RuTheKiLLer 24 дек. 2020 г., 16:03:46 | 5 - 9 классы

В одном массиве целых чисел найти сумму max и min элементов массива?

В одном массиве целых чисел найти сумму max и min элементов массива.

На этой странице сайта размещен вопрос Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.