Написать программу на Паскале : "если введенное целое число является трехзначным, то удалить из него среднюю цифру ; если число двухзначное, то удвоить крайние цифры ; иначе – выдать сообщение «Ошибка?

Информатика | 10 - 11 классы

Написать программу на Паскале : "если введенное целое число является трехзначным, то удалить из него среднюю цифру ; если число двухзначное, то удвоить крайние цифры ; иначе – выдать сообщение «Ошибка ввода».

".

Ответить на вопрос
Ответы (1)
Darya3257775 10 мар. 2020 г., 17:19:52

Program z1 ;

uses crt ;

var n : integer ;

begin

writeln(''вв число') ;

readln(n) ;

if n> ; 999 then writeln('ошибка ввода') else

if n> ; 100 then writeln((n div 100) * 10 + n mod 10 ) else

writeln((((n div 10) * 2) * 10) + ((n mod 10) * 2)) ;

end.

Wedoma 27 апр. 2020 г., 02:36:46 | 5 - 9 классы

1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом?

1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом.

2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом.

8 класс.

Leva2222222 25 нояб. 2020 г., 12:31:49 | 5 - 9 классы

Как составить программу?

Как составить программу?

Составьте программу, определяющею, является ли последняя цифра введенного целого числа нечетным числом?

Myrick 10 авг. 2020 г., 07:02:32 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти сумму цифр числа.

(Написать программу на языке Паскаль).

Lenyanikolenko 11 сент. 2020 г., 09:26:25 | 5 - 9 классы

Помогите))С клавиатуры вводится целое 4 - х значное число?

Помогите))С клавиатуры вводится целое 4 - х значное число.

Выдать сообщение о том, есть ли в этом числе четные цифры и указать их количество.

НА ПАСКАЛЕ.

Лили20151 10 сент. 2020 г., 02:02:35 | 5 - 9 классы

Составить программу по задаче :Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное"?

Составить программу по задаче :

Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное".

Elektricman242 19 июл. 2020 г., 06:10:30 | 5 - 9 классы

Составьте, программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом?

Составьте, программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом.

Viktoriavir4en 13 нояб. 2020 г., 14:50:13 | 5 - 9 классы

С клавиатуры вводится целое число, содержащие не более 7 цифр?

С клавиатуры вводится целое число, содержащие не более 7 цифр.

Определить максимальную цифру в этом числе.

Программа Паскаль.

Цикл с пред условием.

Liubakhas 7 мар. 2020 г., 20:00:40 | 10 - 11 классы

Помогите по информатике?

Помогите по информатике!

Срочно!

Опять паскаль!

Задача : Написать программу, которая выдает значение TRUE, если сумма цифр, введенного пользователем трехзначного числа, больше десяти, и значение FALSE в противном случае.

Alina30001 11 июн. 2020 г., 10:10:43 | 10 - 11 классы

Дано целое четырехзначное число?

Дано целое четырехзначное число.

Если число четное, найти произведение его цифр, иначе перевернуть число, записав его цифры в обратном порядке.

Написать программу в Паскале.

Kenzzo 24 нояб. 2020 г., 17:16:23 | 5 - 9 классы

Написать программу которая считает количество цифр в числе и их сумму?

Написать программу которая считает количество цифр в числе и их сумму.

Паскаль.

Число вводится с клавиатуры.

На этой странице находится вопрос Написать программу на Паскале : "если введенное целое число является трехзначным, то удалить из него среднюю цифру ; если число двухзначное, то удвоить крайние цифры ; иначе – выдать сообщение «Ошибка?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.