Определим как «красивое» целое положительное трехзначное число Х, для которого выполняется следующее условие : сумма квадратов первой и последней цифр равна квадрату средней цифры?

Информатика | 5 - 9 классы

Определим как «красивое» целое положительное трехзначное число Х, для которого выполняется следующее условие : сумма квадратов первой и последней цифр равна квадрату средней цифры.

Напишите программу, которая выводит на экран все «красивые» числа и их количество.

Ответить на вопрос
Ответы (1)
Abela 31 дек. 2020 г., 18:44:13

Program zadacha_1 ;

var a, b, c, a2, d : integer ;

begind : = 0 ;

for a : = 100 to 999 do begin

a2 : = a ;

b : = a2 mod 10 ;

a2 : = a2 div 10 ;

c : = a2 mod 10 ;

a2 : = a2 div 10 ;

if sqr(b) + sqr(a2) = sqr(c) then writeln(a) ;

if sqr(b) + sqr(a2) = sqr(c) then d : = d + 1 ;

end ;

writeln('количество = = > ; ', d) ;

end.

Mikipiki 15 янв. 2020 г., 09:27:05 | 5 - 9 классы

Дано целое число?

Дано целое число.

Напишите программу, которая выводит на экран последнюю цифру данного числа, затем возводит её в квадрат и выводит на экран монитора результат

только плиз до 7 класса

помогите плиз я проболел эту тему.

Ka2002 2 апр. 2020 г., 01:56:59 | 5 - 9 классы

Определим как горка целое положительное трёхзначное число x для которого выполняется следующие условия сумма первой и последней цифры равна средней цифре язык Qbasic?

Определим как горка целое положительное трёхзначное число x для которого выполняется следующие условия сумма первой и последней цифры равна средней цифре язык Qbasic.

Madina42 23 июл. 2020 г., 21:15:51 | 5 - 9 классы

Напишите программу, которая выводит на экран трехзначные положительные числа, делящиеся на 80 с остатком 45?

Напишите программу, которая выводит на экран трехзначные положительные числа, делящиеся на 80 с остатком 45.

Renatbergaliev7 1 мая 2020 г., 20:39:31 | 10 - 11 классы

Напишите программу, которая выводит на экран все цифры числа начиная с первой?

Напишите программу, которая выводит на экран все цифры числа начиная с первой.

(на Паскале).

Эдвардик 3 авг. 2020 г., 13:26:54 | 5 - 9 классы

Дано целое положительное четырехзначное число?

Дано целое положительное четырехзначное число.

Напишите программу, позволяющую определить сумму двух первых цифр и разность двух последних цифр.

Nastenkasergee 11 сент. 2020 г., 21:40:15 | 10 - 11 классы

Программу на Си?

Программу на Си.

Найти все трехзначные числа, сумма цифр которых равна данному целому числу.

Kalerija 31 мая 2020 г., 10:44:10 | 1 - 4 классы

Дано целое число?

Дано целое число.

Напишите программу, которая выводит на экран последнюю букву данного числа, потом вводит её в квадрат и выводит на экран монитора результат.

Safolur74 7 июн. 2020 г., 11:44:24 | 5 - 9 классы

Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа?

Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа.

Паскаль.

Arininaira 17 июн. 2020 г., 08:15:08 | 5 - 9 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

Составьте программу, выводящую на экран все трехзначные числа, сумма цифр которых равна 10.

Marinaivanova13 15 дек. 2020 г., 19:07:28 | 5 - 9 классы

Дано целое число ?

Дано целое число .

Напишите прогу .

, которя выводит на экран последнюю цифру данного числа , затем возводит ее в квадрат и выводит на экран монитора результат.

Вы зашли на страницу вопроса Определим как «красивое» целое положительное трехзначное число Х, для которого выполняется следующее условие : сумма квадратов первой и последней цифр равна квадрату средней цифры?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.