Дан одномерный массив целых чисел, заполненный случайным образом числами из промежутка [ - 40, 30]?

Информатика | 10 - 11 классы

Дан одномерный массив целых чисел, заполненный случайным образом числами из промежутка [ - 40, 30].

Массив данных хранится в файле.

Удалить из него все элементы, которые состоят из одинаковых цифр.

Результат записать в другой файл.

Ответить на вопрос
Ответы (1)
Fusion 28 окт. 2020 г., 01:35:23

Var

m : array [1.

100] of integer ;

t : text ;

begin

assign(t, 'input.

Txt') ;

reset ;

for i : = to 100 do

readln(m[i]) ;

close(t) ;

assign(t, 'output.

Txt') ;

rewrite(t) ;

for i : = 1 to 100 do

if (m[i]div10< ; > ; m[i] mod 10)

then writeln(m[i]) ;

close (t) ;

end ;

Ніка2015 4 апр. 2020 г., 06:42:29 | 10 - 11 классы

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ - 20, 50 ]?

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ - 20, 50 ].

Удалить из него все элементы, в записи которых есть цифра 5.

Вставить число k после всех элементов, кратных своему номеру (k вводится с клавиатуры).

Поменять местами первый положительный и последний отрицательный элементы.

Keti2698 23 дек. 2020 г., 04:21:50 | 10 - 11 классы

Ан массив целых чисел n = 14 заполненный случайным образом числами из промежутка [ - 15 30] 1) удалить последний четный элемент 2) поменять местами первую и вторую его половины?

Ан массив целых чисел n = 14 заполненный случайным образом числами из промежутка [ - 15 30] 1) удалить последний четный элемент 2) поменять местами первую и вторую его половины.

Tatyanan1976 27 дек. 2020 г., 13:44:03 | 10 - 11 классы

Дан массив целых чисел (n = 10), заполненный случайными числами из промежутка [ - 40, 30]?

Дан массив целых чисел (n = 10), заполненный случайными числами из промежутка [ - 40, 30].

1. удалить из него все элементы, которые состоят из одинаковых цифр(включая однозначные числа).

2. вставить число k перед всеми элементами, в которых есть цифра 1(k вводить с клавиатуры).

3. переставить первые три и последние три элемента местами, сохраняя их следование.

Vlarover05 20 июн. 2020 г., 07:02:14 | 10 - 11 классы

Дан массив целых чисел из n элементов, заполненный случайным образом числами из промежутка [ - 10, 60]?

Дан массив целых чисел из n элементов, заполненный случайным образом числами из промежутка [ - 10, 60].

Удалить из него все элементы, в которых последняя цифра нечетная, а само число кратно 3.

Помогите пожалуйста решить в C# (Си шарп).

Александр19833891 9 апр. 2020 г., 02:33:53 | 5 - 9 классы

1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N?

1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N.

Отрицательные элементы заменить на N.

Измененный массив вывести на экран одной строкой.

2. Дан одномерный массив размерностью N, заполненный случайными числами в интервале от - 15 до 20.

Вывести на экран значения элементов массива, абсолютное значение которых > ; 10.

3. Дан одномерный массив размерностью N, заполненный случайными числами.

Каждый третий элемент массива возвести в квадрат, если элемент отрицательный.

Измененный массив вывести на экран.

Sashulya20 15 апр. 2020 г., 18:20:05 | 5 - 9 классы

Дан массив натуральных чисел, заполненный случайными числами?

Дан массив натуральных чисел, заполненный случайными числами.

Найти произведение элементов кратных 3.

Burat125 21 янв. 2020 г., 05:39:06 | 10 - 11 классы

Написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k - ый элемент массива?

Написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k - ый элемент массива.

Массив заполняется случайным образом числами от 0 до 50.

DianaKrav4enko 28 июл. 2020 г., 10:32:45 | 10 - 11 классы

Дан массив целых чисел (n = 25), заполненный случайным образом числами из промежутка [ - 10, 50] : 1) заменить максимальный элемент массива на среднее арифметическое значение этого массива ; 2) найти ?

Дан массив целых чисел (n = 25), заполненный случайным образом числами из промежутка [ - 10, 50] : 1) заменить максимальный элемент массива на среднее арифметическое значение этого массива ; 2) найти сумму положительных элементов, кратных 7.

Chernovdanil2 14 мар. 2020 г., 08:27:02 | 10 - 11 классы

Pascal?

Pascal.

Дан массив.

Найти сумму тех элементов , которые расположены до максимального элемента данной последовательности .

Результат сохранить в файл.

Nurtileuagadil 15 сент. 2020 г., 07:36:24 | 10 - 11 классы

Даны два одномерных массива целых чисел размерностью (15) и (25), заполненных случайным образом числами из промежутка [ - 10, 30]?

Даны два одномерных массива целых чисел размерностью (15) и (25), заполненных случайным образом числами из промежутка [ - 10, 30].

Найти среди четных чисел наибольшее для каждого массива и сравнить.

Вы зашли на страницу вопроса Дан одномерный массив целых чисел, заполненный случайным образом числами из промежутка [ - 40, 30]?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.