Написать в паскале Определить количество дней в году, который вводит пользователь?

Информатика | 10 - 11 классы

Написать в паскале Определить количество дней в году, который вводит пользователь.

В високосном годе - 366 дней, тогда как в обычном 365.

Ответить на вопрос
Ответы (1)
Vladbutin 19 янв. 2020 г., 10:54:20

В високосном годе - 366 дней, тогда как в обычном 365.

Високосными годами являются все года делящиеся нацело на 4 за исключением столетий, которые не делятся нацело на 400.

Var

year : word ;

begin

write('Input year : ') ; readln(year) ;

if year mod 4 = 0 then

if (year mod 100 = 0) and (year mod 400 < ; > ; 0) then

year : = 365

else

year : = 366

else

year : = 365 ;

writeln('The number of days in the year : ', year) ;

end.

1999101615 28 июл. 2020 г., 20:28:56 | 10 - 11 классы

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

В паскале.

Lyudakrivenkov 6 мар. 2020 г., 02:01:33 | 5 - 9 классы

Составить программу в паскале?

Составить программу в паскале!

9 класс!

СРОЧНО!

Пожалуйста!

Без всяких div и mod.

Год является високосным, если его номер кратен 4.

Из кратных 100 високосными являются лишь те года, которые кратны также 400 (например, 1700, 1800 и 1900 — не високосные года, 2000 — високосный).

Дано натуральное число n.

Определить, является ли високосным год с таким номером.

Хинори7337 12 июн. 2020 г., 13:28:17 | 5 - 9 классы

Ученик вводит число соответствующее месяцу?

Ученик вводит число соответствующее месяцу.

Определить какому времени года соответствует этот месяц.

(написать программу в паскале).

Angelinanike 20 окт. 2020 г., 15:24:06 | 5 - 9 классы

Написать программу на паскале : определить является ли год високосном?

Написать программу на паскале : определить является ли год високосном.

Karpenkoy1997 26 мая 2020 г., 03:55:54 | 5 - 9 классы

Написать программу в Паскале Пользователь вводит количество недель, месяцев, лет и получает количество дней за это время?

Написать программу в Паскале Пользователь вводит количество недель, месяцев, лет и получает количество дней за это время.

Считать, что в месяце 30 дней.

9953 2 февр. 2020 г., 21:49:15 | 5 - 9 классы

Написать программу в паскале Пользователь вводит количество дней, указывает процент скидки и вводит сумму?

Написать программу в паскале Пользователь вводит количество дней, указывает процент скидки и вводит сумму.

Рассчитать прибыль, если за каждый день сумма увеличивается на 3 $ и затем применяется скидка, то есть итоговая сумма еще увеличивается на данное число процентов.

Вася162ро 29 июл. 2020 г., 07:11:31 | 5 - 9 классы

Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число?

Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число.

После этого выводит сообщение о том, сколько дней осталось до конца месяца.

Пример работы программы : Сколько дней в текущем месяце?

31 Какое сегодня число?

26 Количество дней до конца текущего месяца : 5.

Windofdeath 12 июн. 2020 г., 14:30:00 | 5 - 9 классы

Вычислите и выведите на экран примерное число прожитых человеком дней (без учѐта високосных лет) , если в году 365 дней, а год рождения и текущий год запрашиваются у пользователя вашей программы?

Вычислите и выведите на экран примерное число прожитых человеком дней (без учѐта високосных лет) , если в году 365 дней, а год рождения и текущий год запрашиваются у пользователя вашей программы.

Паскаль.

Помогите срочно!

Maria199963 9 апр. 2020 г., 02:08:47 | 10 - 11 классы

Человеку сегодня исполнилось R лет?

Человеку сегодня исполнилось R лет.

Сколько ему дней, часов, минут, секунд (високосные годы не учитывать).

Спасибо.

Konovaljva1999 1 сент. 2020 г., 03:04:55 | 10 - 11 классы

Паскаль?

Паскаль.

Написать программу которая после введения месяца, выводит на экран количество дней этого месяца.

На этой странице вы найдете ответ на вопрос Написать в паскале Определить количество дней в году, который вводит пользователь?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.