Задачка в Паскале, помогите решить пожалуйста?

Информатика | 10 - 11 классы

Задачка в Паскале, помогите решить пожалуйста!

Pascal Помогите пожалуйста решить задачку через массив, я плохо понимаю массивы.

Даны числа а1, .

, a50.

Получить сумму тех чисел данной последовательности, которые a)Кратны 5 ; б)нечетны и отрицательны ; в)удовлетворяют условию мод |ai|< ; i ^ 2 И эти все цифры должны быть в одной программе.

Ответить на вопрос
Ответы (1)
Superme3 21 авг. 2020 г., 06:14:29

После выода данных в массив :

Sum : = 0 ;

B : = 0 ;

C : = 0 ;

For i : = 1 to 50 do

Begin

If a[i] mod 5 = 0 Then sum : = sum + a[i] ;

If (a[i] mod 2< ; > ; 0) and (a[i]< ; 0)

Then b : = b + a[i] ;

If abs(a[i])Then c : = c + a[i] ;

End ;

Writeln(sum, ' ', b, ' ', c) ;

Последнее условие это модуль а[i] меньше квадрата i?

Dodokarys 11 мар. 2020 г., 13:24:19 | 5 - 9 классы

Кто знает программу PASCAL помогите пожалуйста мне ЗАДАНИЕ ВО ВЛОЖЕНИЯХ придумайте хотя бы одну задачку со сложным условием которую надо решить в этой программе заранее огромное спасибо?

Кто знает программу PASCAL помогите пожалуйста мне ЗАДАНИЕ ВО ВЛОЖЕНИЯХ придумайте хотя бы одну задачку со сложным условием которую надо решить в этой программе заранее огромное спасибо.

AlexCobron 25 сент. 2020 г., 19:20:35 | 10 - 11 классы

Помогите с программой в Паскале, пожалуйста?

Помогите с программой в Паскале, пожалуйста!

Дан массив из N чисел.

Определить количество чисел, превышающих число 5.

Найти сумму этих чисел.

Напишите программу.

(одномерный массив).

Vovavovan04 15 авг. 2020 г., 18:05:02 | 5 - 9 классы

Помогите, пожалуйста, решить задачку в Паскале?

Помогите, пожалуйста, решить задачку в Паскале.

Monstepilya 28 мар. 2020 г., 08:26:14 | 10 - 11 классы

Дан массив из n чисел?

Дан массив из n чисел.

Найти номер первого чётного элемента массива ; если чётных элементов нет, то ответом должно быть число 0.

Помогите написать программу в паскаль.

NRyabikovaNN 25 сент. 2020 г., 05:39:05 | 10 - 11 классы

Написать программу в Pascal даны целые числа а1?

Написать программу в Pascal даны целые числа а1.

Аn. Если в данной последовательности ни одно четное число не расположено после нечетного.

То получить все отрицательные члены последовательности иначе - положительное.

Privedenie7 2 июл. 2020 г., 15:21:42 | 10 - 11 классы

Помогите решить задачу?

Помогите решить задачу.

Решить через паскаль.

Дан массив В(50) целых чисел.

Подсчитать сумму тех элементов массива, которые нечетны и отрицательны.

ЛанаЛо 18 июл. 2020 г., 14:36:57 | 10 - 11 классы

Даны два массива?

Даны два массива.

Получить третий массив который на четных номерах элементы второго массива на нечетных элементы первого массива.

Решите пожалуйста через pascal ABC и опишите программу.

Zenkova929 24 июл. 2020 г., 13:36:47 | 10 - 11 классы

Pascal?

Pascal.

Дана последовательность чисел .

Вывести на экран суммы положительных и отрицательных чисел данной последовательности.

Iri4241 22 авг. 2020 г., 20:03:43 | 10 - 11 классы

Помогите решить на паскале?

Помогите решить на паскале.

Дан массив, в котором 10 элементов, составить программу для вывода его элемента массива по его индексу.

Pavelpevlov98 9 сент. 2020 г., 14:09:29 | 10 - 11 классы

Дан одномерный массив, получить удвоенную сумму всех положительных членов массива и найти сумму чисел, которые не четные и отрицательные пожалуйста умоляю помогите мне?

Дан одномерный массив, получить удвоенную сумму всех положительных членов массива и найти сумму чисел, которые не четные и отрицательные пожалуйста умоляю помогите мне.

Вы перешли к вопросу Задачка в Паскале, помогите решить пожалуйста?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.