Дан алгоритм на естественном языке : Присвоить А и В начальные значения?

Информатика | 10 - 11 классы

Дан алгоритм на естественном языке : Присвоить А и В начальные значения.

Присвоить С значение А + В Если С больше, чем А, то Присвоить А значение С Присвоить В значение –В Конец ветвления Присвоить А значение С + А.

Чему равны конечные значения А и В после выполнения алгоритма при следующих начальных значениях : А = - 6, В = 3.

Нарисуйте блок - схему этого алгоритма.

Ответить на вопрос
Ответы (1)
Гаррина 2 мая 2020 г., 20:54:11

Var a, b, c : integer ;

begin

a : = - 6 ;

b : = 3 ;

c : = a + b ;

if (c> ; b) then a : = c else b : = - b ; a : = c + a ;

writeln(a, ' ', b) ;

end.

A = - 9

b = - 3.

Nagibatorrr997 16 мар. 2020 г., 06:15:14 | 5 - 9 классы

Чему будут равны a и b после выполнения ВЫЧИСЛИТЕЛЕМ каждого из следующих алгоритмов?

Чему будут равны a и b после выполнения ВЫЧИСЛИТЕЛЕМ каждого из следующих алгоритмов?

Сколько раз будет выполняться тело цикла в каждом из них?

А) Присвоить а значение - 5.

Присвоить b значение - 2.

Пока а + b меньше аb, повторять : присвоить а значение 2а.

Присвоить b значение b + 1.

Конец цикла.

Б) Присвоить а значение 25.

Присвоить b значение 1.

Пока а - b больше а / b, повторять : Присвоить а значение а + 10.

Присвоить b значение - 3b.

Конец цикла.

Screamfrompast 15 мар. 2020 г., 12:56:19 | 10 - 11 классы

Составьте программу обмена значениями двух переменных величин : по следующей схеме : в - присвоить значение с а - присвоить значение в?

Составьте программу обмена значениями двух переменных величин : по следующей схеме : в - присвоить значение с а - присвоить значение в.

Kot1306 13 окт. 2020 г., 02:46:51 | 10 - 11 классы

На рисунке изображена блок - схема?

На рисунке изображена блок - схема.

Какое значение будет присвоено переменной X после выполнения алгоритма?

Решите задачу, решение отразите в отчете.

Msnya281 20 авг. 2020 г., 23:14:28 | 10 - 11 классы

На рисунке изображена блок - схема?

На рисунке изображена блок - схема.

Какое значение будет присвоено переменной S после выполнения алгоритма?

Решите задачу, решение отразите в отчете.

Manovar 30 апр. 2020 г., 16:15:12 | 5 - 9 классы

Дан алгоритм в виде блок схемы : Определите максимально возможное значение Х на входе алгоритма, при котором на экран будет выведено значение переменной В и не будет выведено сообщение «ОШИБКА», если ?

Дан алгоритм в виде блок схемы : Определите максимально возможное значение Х на входе алгоритма, при котором на экран будет выведено значение переменной В и не будет выведено сообщение «ОШИБКА», если известно, что значение переменной А перед выполнением данного алгоритма равно 56, а значение переменной Т по завершении алгоритма равно 1000.

David2456 18 окт. 2020 г., 10:06:09 | 5 - 9 классы

Запишите выражение "Переменной А присвоить значение выражения G M2 - M1 / M2 + M1?

Запишите выражение "Переменной А присвоить значение выражения G M2 - M1 / M2 + M1.

Gfgeufq1 19 февр. 2020 г., 06:47:29 | 5 - 9 классы

Даны две переменные целого типа : A и B?

Даны две переменные целого типа : A и B.

Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения.

Вывести новые значения переменных A и B.

Katuali2003 13 мар. 2020 г., 10:04:10 | 5 - 9 классы

Даны два числа?

Даны два числа.

Если их значения не равны, то присвоить каждому сумму этих значений, а если равны, то присвоить числам нулевые значения.

Вывести новые значения A и B .

Pkirill57 4 янв. 2020 г., 21:32:30 | 5 - 9 классы

Задание1?

Задание1.

Значение переменной Х ввести с клавиатуры.

Переменной У присвоить значение 5.

Вывести на экран информацию «знач.

Х» + 5 = «итог.

Сумма».

Задание 2.

Переменной Х присвоить значение 7.

Переменной Р присвоить значение, равное квадрату Х.

Вывести значения переменных Х и Р (через запятую).

Значение Х увеличить на Х.

Переменной Р присвоить значение, равное корню квадратному из Х.

Вывести значения переменных Х и Р (через запятую).

DIKTANT 2 Задание 1.

Значение переменной Х присвоить в программе.

При неотрицательном значении Х переменной У присвоить значение, равное корню квадратному из Х.

В противном случае, переменной У присвоить значение, равное квадрату Х.

Вывести на экран значение Х и значение У.

Задание 2.

Двум произвольным переменным присвоить произвольным образом соответственно 2 числа.

Двум другим переменным присвоить значения, равные тангенсам двух предыдущих переменных.

Вывести на экран значения всех переменных, а так же сумму значений двух последних переменных.

Помогите сделать пож.

Vovan777vovan 20 дек. 2020 г., 03:45:14 | 10 - 11 классы

Какие значения может присвоить переменная y : = 10 + random(5)?

Какие значения может присвоить переменная y : = 10 + random(5).

Вы зашли на страницу вопроса Дан алгоритм на естественном языке : Присвоить А и В начальные значения?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.