Даны две переменные целого типа : A и B?

Информатика | 5 - 9 классы

Даны две переменные целого типа : A и B.

Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения.

Вывести новые значения переменных A и B.

Ответить на вопрос
Ответы (1)
Kolyadrago1 19 февр. 2020 г., 06:47:34

Var a, b, c : integer ;

begin

readln(a, b) ;

if a< ; > ; b then

begin

c : = a + b ;

a : = c ;

b : = c ;

end

else begin

a : = 0 ;

b : = 0 ;

end ;

writeln('a = ', a, ' b = ', b) ;

end.

Kristikkostrom 20 июн. 2020 г., 22:39:43 | 5 - 9 классы

1)присвоить переменой А сумму переменных В и С2)удвоить значение переменной х3)значение переменной х увеличить на 0?

1)присвоить переменой А сумму переменных В и С

2)удвоить значение переменной х

3)значение переменной х увеличить на 0.

1.

Screamfrompast 15 мар. 2020 г., 12:56:19 | 10 - 11 классы

Составьте программу обмена значениями двух переменных величин : по следующей схеме : в - присвоить значение с а - присвоить значение в?

Составьте программу обмена значениями двух переменных величин : по следующей схеме : в - присвоить значение с а - присвоить значение в.

ММаргаритаКозак 9 дек. 2020 г., 04:14:07 | 10 - 11 классы

Помогите пожалуйста решить задачу в кумире?

Помогите пожалуйста решить задачу в кумире.

Определить по паре переменных всех типов.

Присвоить переменным произвольные значение, соответствующих их типу.

Присвоить одной из переменных каждого типа результаты применения операции сложения / прибавления / объединения в зависимости от типа данных.

Произвести операции разности, умножения и деления над числовыми переменными.

Присвоить логическим переменным результат сравнения суммы и произведения (что больше?

) и разности и деления (что меньше?

).

Nikamisa 2 дек. 2020 г., 21:49:03 | 10 - 11 классы

Дана целочисленная прямоугольная матрица А размерности n * m?

Дана целочисленная прямоугольная матрица А размерности n * m.

Переменной В присвоить значение, равное количеству строк матрицы, содержащих хотя бы один нулевой элемент.

(Помогите написать программы на с + + ).

Viktoriyafomen 18 мар. 2020 г., 02:48:46 | 5 - 9 классы

Pascal?

Pascal.

Даны три переменные вещественного типа : A, B, C.

Если их значения упо - рядочены по возрастанию или убыванию, то удвоить их ; в противном слу - чае заменить значение каждой переменной на противоположное.

Вывести новые значения переменных A, B, C.

Katuali2003 13 мар. 2020 г., 10:04:10 | 5 - 9 классы

Даны два числа?

Даны два числа.

Если их значения не равны, то присвоить каждому сумму этих значений, а если равны, то присвоить числам нулевые значения.

Вывести новые значения A и B .

Rimmaivan4ik8 5 сент. 2020 г., 08:56:20 | 10 - 11 классы

Составить программу?

Составить программу.

Присвоить переменным А, В, С любые положительные значения.

Вычислить значение переменной и вывести D : = (3, 5•À + Â)•2 / 4•C + 5•B ;

Pkirill57 4 янв. 2020 г., 21:32:30 | 5 - 9 классы

Задание1?

Задание1.

Значение переменной Х ввести с клавиатуры.

Переменной У присвоить значение 5.

Вывести на экран информацию «знач.

Х» + 5 = «итог.

Сумма».

Задание 2.

Переменной Х присвоить значение 7.

Переменной Р присвоить значение, равное квадрату Х.

Вывести значения переменных Х и Р (через запятую).

Значение Х увеличить на Х.

Переменной Р присвоить значение, равное корню квадратному из Х.

Вывести значения переменных Х и Р (через запятую).

DIKTANT 2 Задание 1.

Значение переменной Х присвоить в программе.

При неотрицательном значении Х переменной У присвоить значение, равное корню квадратному из Х.

В противном случае, переменной У присвоить значение, равное квадрату Х.

Вывести на экран значение Х и значение У.

Задание 2.

Двум произвольным переменным присвоить произвольным образом соответственно 2 числа.

Двум другим переменным присвоить значения, равные тангенсам двух предыдущих переменных.

Вывести на экран значения всех переменных, а так же сумму значений двух последних переменных.

Помогите сделать пож.

Ника880 7 нояб. 2020 г., 08:48:12 | 5 - 9 классы

Написать программу в паскале Даны две переменных с некоторыми значениями?

Написать программу в паскале Даны две переменных с некоторыми значениями.

Поменять местами значения этих переменных.

Vovan777vovan 20 дек. 2020 г., 03:45:14 | 10 - 11 классы

Какие значения может присвоить переменная y : = 10 + random(5)?

Какие значения может присвоить переменная y : = 10 + random(5).

На этой странице находится вопрос Даны две переменные целого типа : A и B?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.