Даны два числа?

Информатика | 5 - 9 классы

Даны два числа.

Если их значения не равны, то присвоить каждому сумму этих значений, а если равны, то присвоить числам нулевые значения.

Вывести новые значения A и B .

Ответить на вопрос
Ответы (1)
Музикач 13 мар. 2020 г., 10:04:12

Var a, b, c : integer ;

begin

writeln('Введите 2 числа') ;

read(a, b) ;

if a = b then begin

a : = 0 ;

b : = 0 ;

end else

begin c : = a + b ;

a : = c ;

b : = c ;

end ;

writeln(a) ;

writeln(b) ;

end.

Nagibatorrr997 16 мар. 2020 г., 06:15:14 | 5 - 9 классы

Чему будут равны a и b после выполнения ВЫЧИСЛИТЕЛЕМ каждого из следующих алгоритмов?

Чему будут равны a и b после выполнения ВЫЧИСЛИТЕЛЕМ каждого из следующих алгоритмов?

Сколько раз будет выполняться тело цикла в каждом из них?

А) Присвоить а значение - 5.

Присвоить b значение - 2.

Пока а + b меньше аb, повторять : присвоить а значение 2а.

Присвоить b значение b + 1.

Конец цикла.

Б) Присвоить а значение 25.

Присвоить b значение 1.

Пока а - b больше а / b, повторять : Присвоить а значение а + 10.

Присвоить b значение - 3b.

Конец цикла.

Kristikkostrom 20 июн. 2020 г., 22:39:43 | 5 - 9 классы

1)присвоить переменой А сумму переменных В и С2)удвоить значение переменной х3)значение переменной х увеличить на 0?

1)присвоить переменой А сумму переменных В и С

2)удвоить значение переменной х

3)значение переменной х увеличить на 0.

1.

Screamfrompast 15 мар. 2020 г., 12:56:19 | 10 - 11 классы

Составьте программу обмена значениями двух переменных величин : по следующей схеме : в - присвоить значение с а - присвоить значение в?

Составьте программу обмена значениями двух переменных величин : по следующей схеме : в - присвоить значение с а - присвоить значение в.

10Bulat10 12 февр. 2020 г., 08:17:06 | 5 - 9 классы

Написать программу на паскалеЕсли данное число х меньше нуля, то Z присвоить значение большего из 2 чисел х и у, иначе Z присвойте значение полсуммы этих чисел?

Написать программу на паскале

Если данное число х меньше нуля, то Z присвоить значение большего из 2 чисел х и у, иначе Z присвойте значение полсуммы этих чисел.

Nikamisa 2 дек. 2020 г., 21:49:03 | 10 - 11 классы

Дана целочисленная прямоугольная матрица А размерности n * m?

Дана целочисленная прямоугольная матрица А размерности n * m.

Переменной В присвоить значение, равное количеству строк матрицы, содержащих хотя бы один нулевой элемент.

(Помогите написать программы на с + + ).

Виктор41 4 сент. 2020 г., 08:05:01 | 5 - 9 классы

Ввести три целых числа x, y, z?

Ввести три целых числа x, y, z.

Если хотя бы одно из них четное, то первому числу присвоить значение произведения этих чисел.

( pascal abc).

Gfgeufq1 19 февр. 2020 г., 06:47:29 | 5 - 9 классы

Даны две переменные целого типа : A и B?

Даны две переменные целого типа : A и B.

Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения.

Вывести новые значения переменных A и B.

Kirill1234554 2 мая 2020 г., 20:54:10 | 10 - 11 классы

Дан алгоритм на естественном языке : Присвоить А и В начальные значения?

Дан алгоритм на естественном языке : Присвоить А и В начальные значения.

Присвоить С значение А + В Если С больше, чем А, то Присвоить А значение С Присвоить В значение –В Конец ветвления Присвоить А значение С + А.

Чему равны конечные значения А и В после выполнения алгоритма при следующих начальных значениях : А = - 6, В = 3.

Нарисуйте блок - схему этого алгоритма.

Pkirill57 4 янв. 2020 г., 21:32:30 | 5 - 9 классы

Задание1?

Задание1.

Значение переменной Х ввести с клавиатуры.

Переменной У присвоить значение 5.

Вывести на экран информацию «знач.

Х» + 5 = «итог.

Сумма».

Задание 2.

Переменной Х присвоить значение 7.

Переменной Р присвоить значение, равное квадрату Х.

Вывести значения переменных Х и Р (через запятую).

Значение Х увеличить на Х.

Переменной Р присвоить значение, равное корню квадратному из Х.

Вывести значения переменных Х и Р (через запятую).

DIKTANT 2 Задание 1.

Значение переменной Х присвоить в программе.

При неотрицательном значении Х переменной У присвоить значение, равное корню квадратному из Х.

В противном случае, переменной У присвоить значение, равное квадрату Х.

Вывести на экран значение Х и значение У.

Задание 2.

Двум произвольным переменным присвоить произвольным образом соответственно 2 числа.

Двум другим переменным присвоить значения, равные тангенсам двух предыдущих переменных.

Вывести на экран значения всех переменных, а так же сумму значений двух последних переменных.

Помогите сделать пож.

Vovan777vovan 20 дек. 2020 г., 03:45:14 | 10 - 11 классы

Какие значения может присвоить переменная y : = 10 + random(5)?

Какие значения может присвоить переменная y : = 10 + random(5).

Вы перешли к вопросу Даны два числа?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.