1. Одномерный массив заполнен случайным образом?

Информатика | 10 - 11 классы

1. Одномерный массив заполнен случайным образом.

Найти количество четных элементов.

2. Одномерный массив размерностью N , где N - нечетное число, заполнен случайными числами от - 15 до 6.

Все , числа кратные 3 заменить на противоположные.

Ответить на вопрос
Ответы (1)
Nastyabalindov 10 окт. 2020 г., 19:53:41

1 ЗАДАЧА :

var count, i : integer ; A : array [1.

30] of integer ;

begin

for i : = 1 to 30 do

begin A[i] : = - 100 + random(206) ; writeln('A[', i, '] = ', A[i]) ;

end ;

for i : = 1 to 30 do if(A[i] mod 2 = 0) then inc(count) ;

Writeln ; Writeln ;

Writeln('Кол - во четных элементов : ', count) ;

end.

2 ЗАДАЧА :

const N = 30 ;

var count, i : integer ; A : array [1.

N] of integer ;

begin

for i : = 1 to N do

begin A[i] : = - 15 + random(22) ; writeln('A[', i, '] = ', A[i]) ;

end ;

for i : = 1 to 30 do if(A[i] mod 3 = 0) then A[i] : = - A[i] ;

Writeln ; Writeln ;

for i : = 1 to N do writeln('A[', i, '] = ', A[i]) ;

end.

Oliadanila 12 янв. 2020 г., 11:20:40 | 5 - 9 классы

Одномерный массив 7 элементов заполнить случайным образом числами от 5 до 35?

Одномерный массив 7 элементов заполнить случайным образом числами от 5 до 35.

Заменить все элементы массива больше 15 восьмерками, а элементы равные 5 нулями.

Вывести на экран монитора первоначальный и преобразованный массивы в столбик.

Leto7707 19 апр. 2020 г., 12:39:50 | 5 - 9 классы

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО?

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!

1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от - 15 до 35.

Найти сумму элементов данного массива.

2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от - 15 до 35.

Найти значение максимального элемента массива.

Natka16november 15 июн. 2020 г., 14:46:58 | 5 - 9 классы

Одномерный массив из 7 элементов заполнить случайным образом числами от 5 до 9?

Одномерный массив из 7 элементов заполнить случайным образом числами от 5 до 9.

Заменить все элементы массива равные 7 единицами.

Вывести на экран монитора первоначальный и преобразованный массивы в строчку.

Ирисок 5 сент. 2020 г., 10:35:21 | 5 - 9 классы

Помогите решить задачи1?

Помогите решить задачи

1.

Одномерный массив заполнен любыми числами.

Заменить отрицательные элементы их модулями.

2. Одномерный массив заполнен целыми числами.

Возвести в квадрат элементы, стоящие на четных местах.

Lieraievsieiev 2 янв. 2020 г., 16:57:31 | 10 - 11 классы

Составить задачу в Паскале?

Составить задачу в Паскале.

Составьте программу вычисления суммы нечетных элементов одномерного массива А (Т).

Массив заполнить случайным образом.

Lyuba1606 30 апр. 2020 г., 15:12:53 | 10 - 11 классы

Дан двумерный массив размерности 10х10?

Дан двумерный массив размерности 10х10.

Заполнить его случайными числами на отрезке [ - 25, 25].

В каждой строке массива найти количество элементов, больших заданного числа H.

Результат получить в виде одномерного массива.

Вывести исходный массив и полученный результат на печать.

Czar98 6 янв. 2020 г., 15:05:24 | 10 - 11 классы

В одномерном массиве, заполненном случайными числами посчитать сумму и количество четных чисел?

В одномерном массиве, заполненном случайными числами посчитать сумму и количество четных чисел.

Массив размером 20.

Александр19833891 9 апр. 2020 г., 02:33:53 | 5 - 9 классы

1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N?

1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N.

Отрицательные элементы заменить на N.

Измененный массив вывести на экран одной строкой.

2. Дан одномерный массив размерностью N, заполненный случайными числами в интервале от - 15 до 20.

Вывести на экран значения элементов массива, абсолютное значение которых > ; 10.

3. Дан одномерный массив размерностью N, заполненный случайными числами.

Каждый третий элемент массива возвести в квадрат, если элемент отрицательный.

Измененный массив вывести на экран.

YAKUBik 3 мар. 2020 г., 06:46:09 | 10 - 11 классы

Заполнить одномерный массив случайными числами из отрезка [0, 100], состоящих из 10 элементов?

Заполнить одномерный массив случайными числами из отрезка [0, 100], состоящих из 10 элементов.

Найдите размах между наибольшим и наименьшим значением массива.

Liliv1 26 авг. 2020 г., 16:50:59 | 5 - 9 классы

Заполнить одномерный массив числами целыми (от 40, до 400) с помощью функции случайных чисел?

Заполнить одномерный массив числами целыми (от 40, до 400) с помощью функции случайных чисел.

Найти сумму элементов, которые делятся на 5

Pascal.

На этой странице находится ответ на вопрос 1. Одномерный массив заполнен случайным образом?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.