Написать программу в Паскале, которая вычисляет среднее арифметическое ненулевых элементов массива М[1?

Информатика | 5 - 9 классы

Написать программу в Паскале, которая вычисляет среднее арифметическое ненулевых элементов массива М[1.

100], элементы которого вычисляются по формуле : М[i] = sin(i) * cos(i) Очень нужно, пожалуйста.

Ответить на вопрос
Ответы (1)
Madamany181 3 июл. 2020 г., 06:00:32

1. Вот так сейчас решают подобные задачи : / / PascalABC.

NET 3.

1, сборка 1174 от 22.

02. 2016

begin Writeln(Range(1, 100).

Select(i - > ; sin(i) * cos(i)).

Where(x - > ; x< ; > ; 0).

Average)

end.

Тестовое решение : - 0.

00136006072493969

2.

А вот так учат писать это же школьные учителя : / / PascalABC.

NET 3.

1, сборка 1174 от 22.

02. 2016

var m : array[1.

100] of real ; i, k : integer ; s : real ;

begin s : = 0 ; k : = 0 ; for i : = 1 to 100 do begin m[i] : = sin(i) * cos(i) ; if m[i]< ; > ; 0 then begin s : = s + m[i] ; k : = k + 1 end end ; Writeln(s / k)

end.

Тестовое решение : - 0.

00136006072493969.

Ivanivanov2014 24 нояб. 2020 г., 06:14:16 | 10 - 11 классы

Разработать паскаль - программу, вычисляющую среднее арифметическое элементов матрицы?

Разработать паскаль - программу, вычисляющую среднее арифметическое элементов матрицы.

Елена354 2 мар. 2020 г., 12:29:59 | 10 - 11 классы

Составьте программу, которая заполняет массив a[1?

Составьте программу, которая заполняет массив a[1.

10] случайными целыми числами в диапащоне от 1 до 10 и вычисляет среднее арифметическое элементов массива.

Olkaelka78 2 апр. 2020 г., 17:52:54 | 5 - 9 классы

Составьте программу, которая заполняет массив a [1?

Составьте программу, которая заполняет массив a [1.

10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет среднее арифметическое элементов массива.

RotterDam 13 нояб. 2020 г., 18:48:23 | 10 - 11 классы

Ребята, девчата, тут такое затруднение?

Ребята, девчата, тут такое затруднение.

Нужна программа в паскале, только в паскале.

Условие :

Напишите программу которая вычисляет среднее арифметическое элементов таблицы А(3 * 8) .

Программа по двумерным массивам.

Владислав892 21 апр. 2020 г., 14:19:15 | 5 - 9 классы

Составьте программу, которая заполняет массив а [1?

Составьте программу, которая заполняет массив а [1.

10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет среднее арифметическое элементов массива.

Карина19983012 11 июл. 2020 г., 21:10:14 | 10 - 11 классы

Напиши программу, вычисляющую среднее арифметическое заранее созданного массива случайных чисел из 10 элементов?

Напиши программу, вычисляющую среднее арифметическое заранее созданного массива случайных чисел из 10 элементов.

Дилё 25 апр. 2020 г., 08:59:35 | 10 - 11 классы

Написать программу которая вводит n элементов массива и вычисляет произведение первого и последнего элемента массива?

Написать программу которая вводит n элементов массива и вычисляет произведение первого и последнего элемента массива.

Matveu001 7 июл. 2020 г., 12:38:44 | 5 - 9 классы

Паскаль АВС составить программу, которая создает массив случайных чисел размером (N x M), выводит его на экран и вычисляет произведение ненулевых элементов массива?

Паскаль АВС составить программу, которая создает массив случайных чисел размером (N x M), выводит его на экран и вычисляет произведение ненулевых элементов массива.

Ученик141100 27 апр. 2020 г., 14:31:32 | 5 - 9 классы

Дан массив из 5 элементов, найти среднее арифметическое всех элементов массива?

Дан массив из 5 элементов, найти среднее арифметическое всех элементов массива.

Выполнять на паскале.

Нужно написать программу самым легким способом.

Sayras 26 окт. 2020 г., 08:52:27 | 5 - 9 классы

Составьте программу , которая заполняет массив a [1?

Составьте программу , которая заполняет массив a [1.

10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет среднее арифметическое элементов массива .

На странице вопроса Написать программу в Паскале, которая вычисляет среднее арифметическое ненулевых элементов массива М[1? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.