Помогите пожалуйста)Желательно подробно?

Информатика | 10 - 11 классы

Помогите пожалуйста)Желательно подробно.

Ниже записан алгоритм.

Получив на ход число x этот алгоритм , запишет две буквы M, L.

Напишите число “x” при котором алгоритм с начало напишет число 2, а потом 8 .

DIM X, L, M AS INTEGER INPUT X L = 0 : M = 0 WHILE X> ; 0 L = L + 1 IF M< ; (X MOD 10) THEN M = X MOD 10 END IF X = X \ 10 WEND PRINT L, M

в паскале :

var x, L, M : integer ;

begin readln(x) ;

L : = 0 ; M : = 0 ;

while x > ; 0 do

begin

L : = L + 1 ; if M < ; (x mod 10) then begin

M : = x mod 10 ;

end ;

x : = x div 10 ;

end ;

writeln(L) ;

write(M) ;

end.

Ответить на вопрос
Ответы (1)
Galinagen01 13 июл. 2020 г., 21:12:49

Смотрим на предназначение переменных L и M :

L - счетчик того, сколько раз выполняется условие цикла (while x > ; 0).

Т. к.

В конце программы L становится равным 2, значит условие цикла (while x > ; 0) выполняется 2 раза.

M, судя по условию (if M < ; x mod 10) - максимальная цифра числа x, т.

К. x mod 10 - это остаток от деления числа x на десять.

В конце цикла while x приравнивается x div 10 ; кроме того, после 2 проходов цикла, x стало равным 0.

Это дает нам право считать, что начальное число x было двузначным.

Т. к.

В конце программы M становится равным 8, значит максимальная цифра в числе x - это 8.

Значит изначально число x могло быть равно :

18

28

38

48

58

68

78

80

81

82

83

84

85

86

87

88

Т.

К. требуется наибольшее, то выбираем 88.

08041982 19 мар. 2020 г., 10:40:00 | 10 - 11 классы

Ниже записан алгоритм?

Ниже записан алгоритм.

Получив на вход число х, этот алгоритм печатает два числа L и M.

Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 3, а потом 120.

Var х, L, M : integer ;

begin

readln (x) ;

L : = 0 ; M : = 1 ;

while x> ; 0 do

begin

L : = L + 1 ;

M : = M * (x mod 8) ;

х : = x div 8 ;

end ;

writeln(L) ; write(M) ;

end.

Hdbvd 26 мая 2020 г., 01:21:08 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число x, эта программа печатает два числа, L и M.

Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 ; if (M< ; x) and (x mod 2 = 0) then begin M : = x mod 10 ; end ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Gribaneva 19 февр. 2020 г., 20:46:42 | 10 - 11 классы

Определите, какое число будет напечатано в результате выполнения следующего алгоритма : var a, b, t, M, R : integer ; Function F(x : integer) : integer ; begin F : = 3 * (x - 8) * (x - 8) end ; begin ?

Определите, какое число будет напечатано в результате выполнения следующего алгоритма : var a, b, t, M, R : integer ; Function F(x : integer) : integer ; begin F : = 3 * (x - 8) * (x - 8) end ; begin a : = - 20 ; b : = 20 ; M : = a ; R : = F(a) ; for t : = a to b do begin if (F(t) < ; R) then begin M : = t ; R : = F(t) end end ; write(M) ; end.

Дулетол3 31 окт. 2020 г., 09:13:31 | 5 - 9 классы

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; w?

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; writeln(s) end.

ArtDaviant 27 мая 2020 г., 10:44:45 | 10 - 11 классы

Составить программу для подсчета количества "счастливых" шестизначных билетов, при исполнении которой работает не более 50000 арифметических команд?

Составить программу для подсчета количества "счастливых" шестизначных билетов, при исполнении которой работает не более 50000 арифметических команд.

В чем ошибка?

Program upr4 ; var n, m, i : longint ; a, b, c, e, f, k : integer ; begin m : = 0 ; for i : = 100000 to 999999 do begin k : = n mod 10 ; f : = (n div 10) mod 10 ; e : = (n div 100) mod 10 ; c : = (n div 1000) mod 10 ; b : = (n div 10000) mod 10 ; a : = (n div 100000) mod 10 ; if k + f + e = a + b + c then m : = m + 1 else m : = m ; end ; writeln (m) ; end.

ЭммаМяф 8 февр. 2020 г., 20:31:35 | 10 - 11 классы

56) Получив на вход число х, этот алгоритм печатает два числа a и b?

56) Получив на вход число х, этот алгоритм печатает два числа a и b.

Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 2, а потом 15.

Var x, a, b : integer ; begin readln(x) ; a : = 0 ; b : = 0 ; while x > ; 0 do begin a : = a + 1 ; b : = b + (x mod 100) ; x : = x div 100 ; end ; writeln(a) ; write(b) ; end.

Ольгамясникова678930 6 апр. 2020 г., 19:41:35 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число x, эта программа печатает два числа.

Укажите набольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 24.

Var x, a, b : integer ; begin readln(x) ; a : = 0 ; b : = 1 ; while x > ; 0 do begin a : = a + 1 ; b : = b * (x mod 8) ; x : = x div 8 ; end ; writeln(a) ; write(b) ; end.

Arlekino2106 21 авг. 2020 г., 18:55:06 | 10 - 11 классы

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4?

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 If M< ; (x mod 5) then Begin M : = x mod 5 End X : = x div 5 ; End.

Writeln (L) ; write(M) ; End.

Emelyanovadasha 12 мая 2020 г., 12:15:14 | 10 - 11 классы

Ниже записан алгоритм?

Ниже записан алгоритм.

Получив на вход число X, этот алгоритм печатает два числа : a и b.

Укажите наименьшее из таких чисел X при вводе которого алгоритм печатает сначала 15, а потом 7.

Паскаль var x, a, b, k : integer ; begin readln(x) ; a : = 0 ; b : = 10 ; while x> ; 0 do begin k : = x mod 10 ; a : = a + k ; If k< ; b : = k ; x : = x div 10 end ; writeln(a) ; writeln(b) ; end.

Pirverdaynmail 30 дек. 2020 г., 07:09:35 | 5 - 9 классы

9 класс?

9 класс.

Сделайте программу в паскале Ввести натуральное число и определить, какие цифры встречаются несколько раз, если никакие не повторяются вывести : "Цифры не повторяются.

"

У меня получилось ну это не правильно!

Program five ;

var n, m, i, j, k : integer ;

begin

write('Введите число : ') ;

readln(n) ;

for i : = 0 to 9 do

begin

k : = 0 ;

m : = n ;

while m0 do

begin

j : = m mod 10 ;

if j = i then k : = k + 1 ;

m : = m div 10 ;

end ;

writeln('цифра ', i, ' встречается ', k, ' раз') ;

end ;

end.

Если вам необходимо получить ответ на вопрос Помогите пожалуйста)Желательно подробно?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.