56) Получив на вход число х, этот алгоритм печатает два числа a и b?

Информатика | 10 - 11 классы

56) Получив на вход число х, этот алгоритм печатает два числа a и b.

Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 2, а потом 15.

Var x, a, b : integer ; begin readln(x) ; a : = 0 ; b : = 0 ; while x > ; 0 do begin a : = a + 1 ; b : = b + (x mod 100) ; x : = x div 100 ; end ; writeln(a) ; write(b) ; end.

Ответить на вопрос
Ответы (1)
Танюшксав 8 февр. 2020 г., 20:31:37

Наибольший х - 1500.

08041982 19 мар. 2020 г., 10:40:00 | 10 - 11 классы

Ниже записан алгоритм?

Ниже записан алгоритм.

Получив на вход число х, этот алгоритм печатает два числа L и M.

Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 3, а потом 120.

Var х, L, M : integer ;

begin

readln (x) ;

L : = 0 ; M : = 1 ;

while x> ; 0 do

begin

L : = L + 1 ;

M : = M * (x mod 8) ;

х : = x div 8 ;

end ;

writeln(L) ; write(M) ;

end.

Hdbvd 26 мая 2020 г., 01:21:08 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число x, эта программа печатает два числа, L и M.

Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 ; if (M< ; x) and (x mod 2 = 0) then begin M : = x mod 10 ; end ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Egorchugunov 2 мая 2020 г., 08:11:51 | 10 - 11 классы

Получив на вход число х , этот алгоритм печатает два числа а и b?

Получив на вход число х , этот алгоритм печатает два числа а и b.

Скажите наибольшее из таких чисел х , при вводе которых алгоритм печатает сначала 2 потом 63

din x, a, b as integer

input x

a = 0 : b = 1

while x> ; 0

a = a + 1

b = b * (x mod 10)

x = x \ 10

wend

print a

print b.

Ulka8 20 февр. 2020 г., 05:17:15 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО?

ПОМОГИТЕ СРОЧНО!

Ниже написана программа.

Получив на вход число x, эта программа печатает два числа, a и b.

Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 9.

ПОЖАЛУЙСТА С РЕШЕНИЕМ!

Var x, a, b : integer ; begin readln (x) ; a : = 0 ; b : = 1 ; while x > ; 0 do begin a : = a + 1 ; b : = b * (x mod 5) ; x : = x div 5 ; end ; writeln (a) ; write (b) ; end.

Robert777 10 апр. 2020 г., 01:30:01 | 10 - 11 классы

Пожалуйста, помогите?

Пожалуйста, помогите!

Не понимаю даже, как к заданию подступиться.

На языке программирования Паскаль написан текст программы.

Получив на вход число x, этот алгоритм печатает два числа a и b.

Укажите наименьшее из таких чисел x, при котрых алгоритм печатает сначала 3, а потом 7.

​var x, a, b : integer ; begin ​readln(x) ; ​a : = 0 ; b : = 0 ; ​while x> ; 0 do ​begin ​a : = a + 1 ; ​b : = b + (x mod 10) ; ​x : = x div 10 ; ​end ; ​writeln(a) ; write(b) ; end.

Fityuzka 24 янв. 2020 г., 07:56:14 | 10 - 11 классы

Получив на вход число x, этот алгоритм печатает число M?

Получив на вход число x, этот алгоритм печатает число M.

Известно, что x > ; 100.

Укажите наименьшее такое (т.

Е. большее 100) число x, при вводе которого алгоритм печатает 2.

Var x, L, M : integer ; begin readln(x) ; L : = x - 12 ; M : = x + 12 ; while L < ; > ; M do if L > ; M then L : = L - M else M : = M – L ; writeln(M) ; end.

Ответ нужен с пояснением плиииззз.

Ольгамясникова678930 6 апр. 2020 г., 19:41:35 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число x, эта программа печатает два числа.

Укажите набольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 24.

Var x, a, b : integer ; begin readln(x) ; a : = 0 ; b : = 1 ; while x > ; 0 do begin a : = a + 1 ; b : = b * (x mod 8) ; x : = x div 8 ; end ; writeln(a) ; write(b) ; end.

Arlekino2106 21 авг. 2020 г., 18:55:06 | 10 - 11 классы

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4?

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 If M< ; (x mod 5) then Begin M : = x mod 5 End X : = x div 5 ; End.

Writeln (L) ; write(M) ; End.

Artem180504 27 февр. 2020 г., 04:29:44 | 10 - 11 классы

Var x, L, M : integer ; begin readln(x) ; L : = x - 16 ; M : = x + 16 ; while L < ; > ; M do if L > ; M then L : = L - M else M : = M – L ; writeln(M) ; end?

Var x, L, M : integer ; begin readln(x) ; L : = x - 16 ; M : = x + 16 ; while L < ; > ; M do if L > ; M then L : = L - M else M : = M – L ; writeln(M) ; end.

20 (№ 424) Ниже записан алгоритм.

Получив на вход число x, этот алгоритм печатает число M.

Известно, что x > ; 100.

Укажите наименьшее такое (т.

Е. большее 100) число x, при вводе которого алгоритм печатает 16.

Emelyanovadasha 12 мая 2020 г., 12:15:14 | 10 - 11 классы

Ниже записан алгоритм?

Ниже записан алгоритм.

Получив на вход число X, этот алгоритм печатает два числа : a и b.

Укажите наименьшее из таких чисел X при вводе которого алгоритм печатает сначала 15, а потом 7.

Паскаль var x, a, b, k : integer ; begin readln(x) ; a : = 0 ; b : = 10 ; while x> ; 0 do begin k : = x mod 10 ; a : = a + k ; If k< ; b : = k ; x : = x div 10 end ; writeln(a) ; writeln(b) ; end.

Если вам необходимо получить ответ на вопрос 56) Получив на вход число х, этот алгоритм печатает два числа a и b?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.