Ниже записана программа?

Информатика | 10 - 11 классы

Ниже записана программа.

Получив на вход число x, эта программа печатает два числа.

Укажите набольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 24.

Var x, a, b : integer ; begin readln(x) ; a : = 0 ; b : = 1 ; while x > ; 0 do begin a : = a + 1 ; b : = b * (x mod 8) ; x : = x div 8 ; end ; writeln(a) ; write(b) ; end.

Ответить на вопрос
Ответы (1)
Oljtutush86 6 апр. 2020 г., 19:41:40

В цикле а увеличивается каждый раз на 1, значит, цикл идет 3 раза.

B каждый раз умножается на остаток деления х на 8.

Получается 24 = 1 * 4 * 6 = 2 * 3 * 4 = 2 * 2 * 6

х каждый раз целочисленно делится на 8.

Последний раз получается 0.

Пусть остатки были равны 1, 4 и 6.

Тогда число х должно быть равно 1 + (4 + 6 * 8) * 8 = 417.

Пусть остатки были равны 2, 3 и 4.

Тогда число х должно быть равно 2 + (3 + 4 * 8) * 8 = 282.

Пусть остатки были равны 2, 2 и 6.

Тогда число х должно быть равно 2 + (2 + 6 * 8) * 8 = 402.

Наибольшее из чисел - 417.

08041982 19 мар. 2020 г., 10:40:00 | 10 - 11 классы

Ниже записан алгоритм?

Ниже записан алгоритм.

Получив на вход число х, этот алгоритм печатает два числа L и M.

Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 3, а потом 120.

Var х, L, M : integer ;

begin

readln (x) ;

L : = 0 ; M : = 1 ;

while x> ; 0 do

begin

L : = L + 1 ;

M : = M * (x mod 8) ;

х : = x div 8 ;

end ;

writeln(L) ; write(M) ;

end.

Hdbvd 26 мая 2020 г., 01:21:08 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число x, эта программа печатает два числа, L и M.

Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 ; if (M< ; x) and (x mod 2 = 0) then begin M : = x mod 10 ; end ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Йчуметнлщдшщгапм5689 22 авг. 2020 г., 00:02:41 | 5 - 9 классы

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END?

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END.

Алеся111111112 18 дек. 2020 г., 19:24:47 | 10 - 11 классы

Требовалось написать программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10 ^ 9, и выводится сумма цифр этого числа?

Требовалось написать программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10 ^ 9, и выводится сумма цифр этого числа.

Программист торопился и написал программу неправильно : var N : longint ; sum, d : integer ; begin readln(n) ; sum : = 0 ; while N > ; 0 do begin d : = N mod 10 ; N : = N div 10 ; sum : = sum + 1 ; end ; writeln(sum) ; end.

Последовательно выполните следующее.

1. Напишите, что выведет эта программа при вводе числа 256.

2. Приведите пример такого трехзначного числа, при вводе которого программа выдаёт правильный результат.

3. Найдите все ошибки в этой программе ( их может быть одна или несколько).

Ulka8 20 февр. 2020 г., 05:17:15 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО?

ПОМОГИТЕ СРОЧНО!

Ниже написана программа.

Получив на вход число x, эта программа печатает два числа, a и b.

Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 9.

ПОЖАЛУЙСТА С РЕШЕНИЕМ!

Var x, a, b : integer ; begin readln (x) ; a : = 0 ; b : = 1 ; while x > ; 0 do begin a : = a + 1 ; b : = b * (x mod 5) ; x : = x div 5 ; end ; writeln (a) ; write (b) ; end.

Robert777 10 апр. 2020 г., 01:30:01 | 10 - 11 классы

Пожалуйста, помогите?

Пожалуйста, помогите!

Не понимаю даже, как к заданию подступиться.

На языке программирования Паскаль написан текст программы.

Получив на вход число x, этот алгоритм печатает два числа a и b.

Укажите наименьшее из таких чисел x, при котрых алгоритм печатает сначала 3, а потом 7.

​var x, a, b : integer ; begin ​readln(x) ; ​a : = 0 ; b : = 0 ; ​while x> ; 0 do ​begin ​a : = a + 1 ; ​b : = b + (x mod 10) ; ​x : = x div 10 ; ​end ; ​writeln(a) ; write(b) ; end.

ЭммаМяф 8 февр. 2020 г., 20:31:35 | 10 - 11 классы

56) Получив на вход число х, этот алгоритм печатает два числа a и b?

56) Получив на вход число х, этот алгоритм печатает два числа a и b.

Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 2, а потом 15.

Var x, a, b : integer ; begin readln(x) ; a : = 0 ; b : = 0 ; while x > ; 0 do begin a : = a + 1 ; b : = b + (x mod 100) ; x : = x div 100 ; end ; writeln(a) ; write(b) ; end.

Arlekino2106 21 авг. 2020 г., 18:55:06 | 10 - 11 классы

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4?

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 If M< ; (x mod 5) then Begin M : = x mod 5 End X : = x div 5 ; End.

Writeln (L) ; write(M) ; End.

Artem180504 27 февр. 2020 г., 04:29:44 | 10 - 11 классы

Var x, L, M : integer ; begin readln(x) ; L : = x - 16 ; M : = x + 16 ; while L < ; > ; M do if L > ; M then L : = L - M else M : = M – L ; writeln(M) ; end?

Var x, L, M : integer ; begin readln(x) ; L : = x - 16 ; M : = x + 16 ; while L < ; > ; M do if L > ; M then L : = L - M else M : = M – L ; writeln(M) ; end.

20 (№ 424) Ниже записан алгоритм.

Получив на вход число x, этот алгоритм печатает число M.

Известно, что x > ; 100.

Укажите наименьшее такое (т.

Е. большее 100) число x, при вводе которого алгоритм печатает 16.

Emelyanovadasha 12 мая 2020 г., 12:15:14 | 10 - 11 классы

Ниже записан алгоритм?

Ниже записан алгоритм.

Получив на вход число X, этот алгоритм печатает два числа : a и b.

Укажите наименьшее из таких чисел X при вводе которого алгоритм печатает сначала 15, а потом 7.

Паскаль var x, a, b, k : integer ; begin readln(x) ; a : = 0 ; b : = 10 ; while x> ; 0 do begin k : = x mod 10 ; a : = a + k ; If k< ; b : = k ; x : = x div 10 end ; writeln(a) ; writeln(b) ; end.

На этой странице находится вопрос Ниже записана программа?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.