Составить программу для подсчета количества "счастливых" шестизначных билетов, при исполнении которой работает не более 50000 арифметических команд?

Информатика | 10 - 11 классы

Составить программу для подсчета количества "счастливых" шестизначных билетов, при исполнении которой работает не более 50000 арифметических команд.

В чем ошибка?

Program upr4 ; var n, m, i : longint ; a, b, c, e, f, k : integer ; begin m : = 0 ; for i : = 100000 to 999999 do begin k : = n mod 10 ; f : = (n div 10) mod 10 ; e : = (n div 100) mod 10 ; c : = (n div 1000) mod 10 ; b : = (n div 10000) mod 10 ; a : = (n div 100000) mod 10 ; if k + f + e = a + b + c then m : = m + 1 else m : = m ; end ; writeln (m) ; end.

Ответить на вопрос
Ответы (1)
Firs2011 27 мая 2020 г., 10:44:50

Для начала - откуда взялась переменная n?

Manyuny 26 мар. 2020 г., 03:31:54 | 10 - 11 классы

Работаем с паскаль, помогите вычислить устно : a : = 75 mod 5 б)b : = 97 div 9 в)c : = 13 mod 7 г)kl : = (50 div 4) mod 5 д) fl : = 82 mod (30 div 7)?

Работаем с паскаль, помогите вычислить устно : a : = 75 mod 5 б)b : = 97 div 9 в)c : = 13 mod 7 г)kl : = (50 div 4) mod 5 д) fl : = 82 mod (30 div 7).

BGrygorenko 24 апр. 2020 г., 03:14:36 | 5 - 9 классы

Язык программирования Паскаль Вычислить 27 div 4 27 mod 4 - 7 div 2 - 7 mod 2 - 14 div 3 - 14 mod 3?

Язык программирования Паскаль Вычислить 27 div 4 27 mod 4 - 7 div 2 - 7 mod 2 - 14 div 3 - 14 mod 3.

Алрпвиыд 8 сент. 2020 г., 09:21:35 | 5 - 9 классы

Что такое div и mod в информатике и как их использовать в программе КуМир?

Что такое div и mod в информатике и как их использовать в программе КуМир?

Ledidi457 17 дек. 2020 г., 00:01:23 | 5 - 9 классы

Выполняется ли равенство :(264 mod 100) div 10 = (368 div 10) mod 10?

Выполняется ли равенство :

(264 mod 100) div 10 = (368 div 10) mod 10.

LesyaLesya86 4 нояб. 2020 г., 09:18:04 | 10 - 11 классы

Найти значение выражения : 1) 25 / 2 = _________ 9) 220 div 10 mod 3 = ________ 2) 25 div 2 = ______ 10) 220 mod 10 div 3 = ________ 3) 25 mod 2 = ______ 11) - 16 mod 11 * 3 = __________ 4) 15 + 21 di?

Найти значение выражения : 1) 25 / 2 = _________ 9) 220 div 10 mod 3 = ________ 2) 25 div 2 = ______ 10) 220 mod 10 div 3 = ________ 3) 25 mod 2 = ______ 11) - 16 mod 11 * 3 = __________ 4) 15 + 21 div 2 = ____ 12) 3 div (5 + 3) = __________ 5) 2 div 3 = _______ 13) 3 div 5 + 3 = _________ 6) 2 mod 3 = _______ 14) ( - 19 + 9) div - 5 = ________ 7) 11 mod 5 = _____ 15) (16 mod 6) / (2 div 1) = ____ 8) 14 mod (5 + 3) = ____ 16) 16 mod 6 / 2 div 1 __________.

Андрейгречка 11 мар. 2020 г., 19:46:09 | 10 - 11 классы

Определить значение выражения : 45 MOD 7 + 5 DIV 4 * 2 37 MOD (7 + 5) DIV 4 * 2 93 MOD ((7 + 5) DIV 4) * 2?

Определить значение выражения : 45 MOD 7 + 5 DIV 4 * 2 37 MOD (7 + 5) DIV 4 * 2 93 MOD ((7 + 5) DIV 4) * 2.

E97M 13 дек. 2020 г., 23:59:56 | 5 - 9 классы

5 * 7 div 2 mod 7?

5 * 7 div 2 mod 7.

0 = - 7 mod 10 + 16 div 2 / 5 =

23 mod 0 * 5div 3 =

12 / 2 mod 5 + 12 div 2 =

40 / (10 div 2) + 8 mod 3 =

12 div 4 - 20 mod 4 =.

Никосru 3 мая 2020 г., 04:58:38 | 5 - 9 классы

Почему не работает программа?

Почему не работает программа?

В любом случае выходит, что билет не счастливый.

Посмотрите, очень срочно, спасибо.

Program primer ;

var x, i, h1, h2, h3, h4, h5, h6, s1, s2 : integer ;

begin

Write (' Введите номер билета ') ;

readln (x) ;

h1 : = x div 100000 ;

h2 : = x mod 100000 div 100000 ;

h3 : = x mod 100000 div 10000 ; h4 : = x mod 100000 div 1000 ; h5 : = x mod 100000 div 100 ; h6 : = x mod 100000 div 10 ; s1 : = h1 + h2 + h3 ;

s2 : = h4 + h5 + h6 ;

if s1 = s2 then writeln (' билет счастливый ')

else writeln (' билет несчастливый ') ;

readln ;

end.

Deputatova1 23 нояб. 2020 г., 23:25:35 | 5 - 9 классы

Язык Pascal что означает : mod и div ?

Язык Pascal что означает : mod и div ?

Fazipan 21 нояб. 2020 г., 18:51:38 | 10 - 11 классы

Что означает div и mod в паскале?

Что означает div и mod в паскале?

Вы открыли страницу вопроса Составить программу для подсчета количества "счастливых" шестизначных билетов, при исполнении которой работает не более 50000 арифметических команд?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.