Вы ввели трехзначное число?

Информатика | 10 - 11 классы

Вы ввели трехзначное число.

Затем ввели любую цифру.

Составьте программу, определяющую, есть ли в этом числе данная цифра.

Ответить на вопрос
Ответы (1)
Knigograd1564 21 окт. 2020 г., 11:58:53

Pascal :

var n, m : longint ; f : boolean ;

begin write ('Decimal : ') ; readln(n) ; write ('Number : ') ; readln (m) ; f : = true ; while (n< ; > ; 0) do begin if ((n mod 10) = m) then begin f : = true ; break ; end ; n : = n div 10 ; end ; if f then writeln ('YES!

') else writeln ('NO') ; readln ;

end.

C + + :

#include < ; iostream> ;

using namespace std ;

int main()

{ int n, m ; bool f = false ; cout < ; < ; "Decimal : " ; cin > ; > ; n ; cout < ; < ; "Number : " ; cin > ; > ; m ; while (n!

= 0) { if ((n%10) = = m) { f = true ; break ; } n / = 10 ; } if (f) cout < ; < ; "YES!

" < ; < ; endl ; else cout < ; < ; "NO!

" < ; < ; endl ; return 0 ;

}.

Wedoma 27 апр. 2020 г., 02:36:46 | 5 - 9 классы

1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом?

1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом.

2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом.

8 класс.

Leva2222222 25 нояб. 2020 г., 12:31:49 | 5 - 9 классы

Как составить программу?

Как составить программу?

Составьте программу, определяющею, является ли последняя цифра введенного целого числа нечетным числом?

Myrick 10 авг. 2020 г., 07:02:32 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти сумму цифр числа.

(Написать программу на языке Паскаль).

Karasik04 15 сент. 2020 г., 19:55:03 | 10 - 11 классы

Вы ввели трехзначное число?

Вы ввели трехзначное число.

Затем ввели любую цифру.

Составьте программу, определяющую, есть ли в этом числе данная цифра.

И объясните.

Лили20151 10 сент. 2020 г., 02:02:35 | 5 - 9 классы

Составить программу по задаче :Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное"?

Составить программу по задаче :

Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное".

Elektricman242 19 июл. 2020 г., 06:10:30 | 5 - 9 классы

Составьте, программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом?

Составьте, программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом.

Auezbaeva1 26 мар. 2020 г., 21:47:52 | 10 - 11 классы

Ввели трехзначное число, определить есть в нем повторяющиеся цифры?

Ввели трехзначное число, определить есть в нем повторяющиеся цифры.

Паскаль.

Павел547 8 сент. 2020 г., 15:52:54 | 10 - 11 классы

Дано целое трехзначное положительное число n?

Дано целое трехзначное положительное число n.

Составьте программу которая определяет входит ли в него цифра восемь.

Помогите пожалуйста!

Огонёк123 17 янв. 2020 г., 21:57:58 | 10 - 11 классы

Составьте программу в результате выполнения которой выясняется входят ли четные цифры в запись данного трехзначного числа?

Составьте программу в результате выполнения которой выясняется входят ли четные цифры в запись данного трехзначного числа.

Мухтар7 11 авг. 2020 г., 21:59:02 | 5 - 9 классы

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые?

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые.

На этой странице находится ответ на вопрос Вы ввели трехзначное число?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.