ПАСКАЛЬ?

Информатика | 5 - 9 классы

ПАСКАЛЬ!

Найти величину наибольшего из отрицательных чисел последовательности из 100 целых чисел.

Ответить на вопрос
Ответы (1)
Marinakomarine 24 нояб. 2020 г., 08:30:41

Предположим, что последовательность же задана, то есть вводить ее мы не будем.

Последовательность представляет собой массив чисел а.

N : = 1 ; k : = 0 ;

for i : = 1 to 100 do if (a[i]< ; 0) then k : = k + 1 ; проверяем наличие отрицательных

if (k = 0) then writeln("Отрицательных нет.

") else begin

for i : = 1 to 100 do if (a[i]< ; 0) then n : = a[i] ; находим хотя бы один отрицательный

for i : = 1 to 100 do if ((a[i]< ; 0) AND (a[i]> ; n) then n : = a[i] ; находим наибольший отрицательный

writeln("Наибольшее из отрицательных чисел данной последовательности - ", n) ;

end ;

end.

Сень123 26 сент. 2020 г., 08:30:05 | 5 - 9 классы

ПОМОГИТЕ С ПАСКАЛЕМ?

ПОМОГИТЕ С ПАСКАЛЕМ.

С клавиатуры вводятся 7 целых чисел.

Вычислить количество отрицательных членов этой последовательности.

1nadin228 11 июн. 2020 г., 20:12:20 | 10 - 11 классы

Вводится произвольная последовательность целых чисел?

Вводится произвольная последовательность целых чисел.

Найти наибольшее из всех чисел.

Olga050577 16 дек. 2020 г., 12:21:35 | 5 - 9 классы

Дана непустая последовательность положительный целых чисел, за которой следует 0?

Дана непустая последовательность положительный целых чисел, за которой следует 0.

Найти сумму всех четных чисел этой последовательности

Записать, как программу в паскале.

Я112яя 23 июл. 2020 г., 22:35:13 | 5 - 9 классы

Дана последовательность чисел?

Дана последовательность чисел.

Найти произведение всех четных отрицательных чисел.

Zhenk2011 20 июн. 2020 г., 10:41:16 | 10 - 11 классы

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел?

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел.

( На языке Паскаль С + + ).

Rjrjhtdf84 7 мая 2020 г., 23:26:52 | 5 - 9 классы

Дана последовательность чисел, заканчивающаяся нулем?

Дана последовательность чисел, заканчивающаяся нулем.

Найти сумму отрицательных и произведение положительных чисел.

Напишите в паскале.

1Демон1 31 дек. 2020 г., 04:01:46 | 10 - 11 классы

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем?

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем.

Найти количество отрицательных чисел и сумму чисел кратных 4.

Islan03 7 дек. 2020 г., 06:48:48 | 10 - 11 классы

Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности)?

Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности).

Найти первое отрицательное число этой последовательности.

Заранее благодарю за ответы.

Mixail174o 17 нояб. 2020 г., 09:29:31 | 5 - 9 классы

Даю все баллы?

Даю все баллы!

Найти сумму отрицательных чисел в паскале.

Секрет86 13 сент. 2020 г., 18:49:23 | 5 - 9 классы

Ввести с клавиатуры n - любых чисел , найти количество отрицательных чисел( Паскаль )?

Ввести с клавиатуры n - любых чисел , найти количество отрицательных чисел( Паскаль ).

На этой странице сайта вы найдете ответы на вопрос ПАСКАЛЬ?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.