Дана последовательность чисел, заканчивающаяся нулем?

Информатика | 5 - 9 классы

Дана последовательность чисел, заканчивающаяся нулем.

Найти сумму отрицательных и произведение положительных чисел.

Напишите в паскале.

Ответить на вопрос
Ответы (1)
NIKITOSHKA 7 мая 2020 г., 23:26:57

Program a ;

var i, s, r : integer ;

begin

s : = 1 ;

read(i) ;

while i< ; > ; 0 do

begin

if (i< ; 0)and(i< ; > ; 0) then r : = r + 1 else s : = s * i ;

read(i) ;

end ;

writeln(s, r) ;

end.

Lindasayfutdin1 17 окт. 2020 г., 00:46:28 | 5 - 9 классы

Программа в Паскале нужна, пожалуйста?

Программа в Паскале нужна, пожалуйста!

Даю 60 баллов!

С клавиатуры вводится последовательность из N чисел, положительных и отрицательных.

Какая сумма чисел по модулю больше, положительных или отрицательных?

Jorjiya 21 дек. 2020 г., 13:54:33 | 10 - 11 классы

Даны 5 чисел, найти сумму и кол - во положительных и произведение и кол - во отрицательных?

Даны 5 чисел, найти сумму и кол - во положительных и произведение и кол - во отрицательных.

Мухаметкалиева 30 янв. 2020 г., 05:55:18 | 10 - 11 классы

Дана не пустая последовательность чисел заканчивающаяся нулем?

Дана не пустая последовательность чисел заканчивающаяся нулем.

Найти максимум.

Bjasiya 20 окт. 2020 г., 04:14:28 | 5 - 9 классы

Записать, как програму в паскале Дана последовательность чисел, оканчивающихся нулем?

Записать, как програму в паскале Дана последовательность чисел, оканчивающихся нулем.

Найти произведение чисел, оканчивающихся цифрой 5.

Olga050577 16 дек. 2020 г., 12:21:35 | 5 - 9 классы

Дана непустая последовательность положительный целых чисел, за которой следует 0?

Дана непустая последовательность положительный целых чисел, за которой следует 0.

Найти сумму всех четных чисел этой последовательности

Записать, как программу в паскале.

Я112яя 23 июл. 2020 г., 22:35:13 | 5 - 9 классы

Дана последовательность чисел?

Дана последовательность чисел.

Найти произведение всех четных отрицательных чисел.

Zhenk2011 20 июн. 2020 г., 10:41:16 | 10 - 11 классы

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел?

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел.

( На языке Паскаль С + + ).

Роман49 22 авг. 2020 г., 14:14:31 | 10 - 11 классы

Даны 5 чисел, найти сумму и кол - во положительных и произведение и кол - во отрицательных?

Даны 5 чисел, найти сумму и кол - во положительных и произведение и кол - во отрицательных.

Блок схема.

Zenkova929 24 июл. 2020 г., 13:36:47 | 10 - 11 классы

Pascal?

Pascal.

Дана последовательность чисел .

Вывести на экран суммы положительных и отрицательных чисел данной последовательности.

ГиперГолубь 19 апр. 2020 г., 15:49:51 | 10 - 11 классы

Напишите программу, которая вводит последовательность целых чисел заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности?

Напишите программу, которая вводит последовательность целых чисел заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности.

Вопрос Дана последовательность чисел, заканчивающаяся нулем?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.