Помогите пожалуйста решить в паскале АВC / линейные массивы?

Информатика | 5 - 9 классы

Помогите пожалуйста решить в паскале АВC / линейные массивы.

№4 вставка.

В линейный массив целых чисел на 7 - е место вставить число равное квадрату первого элемента.

№5. Преобразование.

Дан массив из четного числа элементов.

Поменять местами его половины.

Ответить на вопрос
Ответы (1)
Abdrahmanov 10 июн. 2020 г., 12:06:52

№5

const n = 10 ;

var A : array [1.

N]of integer ;

i, r : integer ;

begin cls ; for i : = 1 to n do read(A[i]) ; for i : = 1 to(n div 2)do begin r : = A[i] ; A[i] : = A[i + (n div 2)] ; A[i + (n div 2)] : = r ; end ; for i : = 1 to n do write(A[i] : 3) ;

end.

Galinatitova48 23 нояб. 2020 г., 07:17:13 | 10 - 11 классы

Помогите с паскалем?

Помогите с паскалем!

Написать программу.

Составить блок схему.

Вставить заданное число в массив целых чисел перед последним четным элементом.

Миньон4 2 янв. 2020 г., 08:46:10 | 10 - 11 классы

Дан массив всех целых чисел ?

Дан массив всех целых чисел .

Найти сумму элементов в массиве.

(Паскаль).

Keti2698 23 дек. 2020 г., 04:21:50 | 10 - 11 классы

Ан массив целых чисел n = 14 заполненный случайным образом числами из промежутка [ - 15 30] 1) удалить последний четный элемент 2) поменять местами первую и вторую его половины?

Ан массив целых чисел n = 14 заполненный случайным образом числами из промежутка [ - 15 30] 1) удалить последний четный элемент 2) поменять местами первую и вторую его половины.

Kankulieva 2 апр. 2020 г., 05:35:13 | 10 - 11 классы

Паскаль?

Паскаль.

Задано массив целых чисел упорядочений по убыванию А(1 ; n) и число В.

Для числа В найти такое место среди элементов массива А , чтоб после вставки числа В на это место упорядоченность массива не нарушалась.

Если впоследствии равенства между собою значений элементов массива А число может вставляться на разные места, то следует выяснить самое близкое к началу массива место.

Елизаветаа654 26 февр. 2020 г., 21:17:46 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива.

Число элементов в массиве не более 10 - ти Pascal.

Dzhambaev09 10 июн. 2020 г., 23:22:15 | 10 - 11 классы

Помогите с паскалем?

Помогите с паскалем.

В линейный массив вещественных чисел на 8 - е место вставить элемент, равный сумме первых 10 элементов массива.

Fazka11 27 мая 2020 г., 00:26:08 | 10 - 11 классы

8. Дан целочисленный линейный массив?

8. Дан целочисленный линейный массив.

Вставить в него число 100 после m - го элемента, если этот элемент четный.

В противном случае – перед ним.

Амика2 14 июн. 2020 г., 14:17:04 | 5 - 9 классы

Дан линейный массив А[1?

Дан линейный массив А[1.

N], содержащий целые числа.

Получить те элементы массива , которые являются полными квадратами.

Anime2003 14 мая 2020 г., 09:42:11 | 10 - 11 классы

Дан массив целых чисел из 12 элементов?

Дан массив целых чисел из 12 элементов.

Поменять местами первый отрицательный с первым положительным.

Kostiaboik200 28 нояб. 2020 г., 11:45:33 | 5 - 9 классы

Помогите написать проги 1?

Помогите написать проги 1.

Замените все элементы массива целых чисел С(n) на противоположные по знаку 2.

Найти произведение элементов массива целых чисел А(n), меньших 3 3.

В линейный массив вещественных чисел на К - тое место вставить элемент, равный среднему арифметическому элементов массива.

Вопрос Помогите пожалуйста решить в паскале АВC / линейные массивы?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.