Дан массив целых чисел из 12 элементов?

Информатика | 10 - 11 классы

Дан массив целых чисел из 12 элементов.

Поменять местами первый отрицательный с первым положительным.

Ответить на вопрос
Ответы (1)
Adelganibaeff 14 мая 2020 г., 09:42:15

Var

A : array[1.

12] of integer ;

i, FLAG, INDMAX, INDMIN, k : integer ;

begin

randomize ;

Writeln('Исходный массив : ') ;

for i : = 1 to 12 do begin A[i] : = random(20) - 10 ; writeln('A[', i, '] = ', A[i]) ; end ; i : = 0 ;

FLAG : = 1 ; While FLAG< ; > ; 0 do begin i : = i + 1 ; if A[i]< ; 0 then begin INDMIN : = i ; FLAG : = 0 ; end ; end ;

i : = 0 ;

FLAG : = 1 ;

While FLAG< ; > ; 0 do begin i : = i + 1 ; if A[i]> ; 0 then begin INDMAX : = i ; FLAG : = 0 ; end ; end ;

K : = A[INDMAX] ; / / Замена

A[INDMAX] : = A[INDMIN] ;

A[INDMIN] : = K ;

writeln('Конечный массив : ') ;

for i : = 1 to 12 do writeln('A[', i, '] = ', A[i]) ;

end.

Ніка2015 4 апр. 2020 г., 06:42:29 | 10 - 11 классы

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ - 20, 50 ]?

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ - 20, 50 ].

Удалить из него все элементы, в записи которых есть цифра 5.

Вставить число k после всех элементов, кратных своему номеру (k вводится с клавиатуры).

Поменять местами первый положительный и последний отрицательный элементы.

Valeri2004 7 мар. 2020 г., 05:28:51 | 5 - 9 классы

Дан массив положительных и отрицательных чисел?

Дан массив положительных и отрицательных чисел.

Вывести количество положительных и отрицательных чисел, стоящих на нечетных местах.

Срочно!

Katyahey 17 нояб. 2020 г., 17:52:13 | 10 - 11 классы

В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы?

В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы.

Risha88 8 мая 2020 г., 22:23:56 | 5 - 9 классы

Кто решит задачу?

Кто решит задачу?

Дан массив из N целых чисел.

Написать программу, определяющую, есть ли в массиве два соседних положительных элемента.

Если есть, то вывести индекс первого элемента, входящего в первую пару.

Елизаветаа654 26 февр. 2020 г., 21:17:46 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива.

Число элементов в массиве не более 10 - ти Pascal.

Cat200235 10 июл. 2020 г., 02:03:00 | 5 - 9 классы

Дано : Массивы А(10), В(15)?

Дано : Массивы А(10), В(15).

Поменять местами их первые положительные элементы .

Для нахождения первого положительного элемента и его номера в массиве использовать подпрограмму.

Сделать в паскале.

ZxDenxz225 4 февр. 2020 г., 10:24:08 | 10 - 11 классы

Дан массив целых чисел из 17 элементов?

Дан массив целых чисел из 17 элементов.

Определить частное от деления суммы положительных элементов массива на модуль суммы отрицательных элементов.

Ксюха7777 7 апр. 2020 г., 08:53:50 | 5 - 9 классы

Дан массив целых чисел из N элементов, введенных с клавиатуры?

Дан массив целых чисел из N элементов, введенных с клавиатуры.

Посчитать сколько в нем отрицательных, положительных и нулевых чисел?

Anatolijokshin 14 дек. 2020 г., 08:51:45 | 5 - 9 классы

Поменять местами первое положительное число с последним отрицательным числом в одномерном массиве из N целочисленых элементов (программа для PascalABC )?

Поменять местами первое положительное число с последним отрицательным числом в одномерном массиве из N целочисленых элементов (программа для PascalABC ).

КонфФфета 19 окт. 2020 г., 17:22:51 | 10 - 11 классы

Дан массив целых чисел , определить в нем количество положительных и отрицательных?

Дан массив целых чисел , определить в нем количество положительных и отрицательных.

На этой странице сайта размещен вопрос Дан массив целых чисел из 12 элементов? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.