Помогите с паскалем?

Информатика | 10 - 11 классы

Помогите с паскалем!

Написать программу.

Составить блок схему.

Вставить заданное число в массив целых чисел перед последним четным элементом.

Ответить на вопрос
Ответы (1)
Sergey200720 23 нояб. 2020 г., 07:17:14

Const m = 10 ;

var a : array[1.

M + 1] of integer ; i, k : integer ;

begin

write ('Исходный массив : ') ;

for i : = 1 to m do

begin a[i] : = random(100) ; write (a[i], ' ; ') ; end ;

writeln ;

write('Введите число : ') ;

readln(k) ;

for i : = m + 1 downto 1 do begin a[i] : = a[i - 1] ; if a[i] mod 2 = 0 then begin a[i - 1] : = k ; break ; end ; end ;

write('Измененный массив : ') ;

for i : = 1 to m + 1 do write (a[i], ' ; ') ;

end.

Slender2774 30 янв. 2020 г., 19:21:30 | 10 - 11 классы

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ?

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ!

Задан целочисленный массив из 10 случайных целых чисел.

Выполнить сортировку элементов массива, стоящих на четных номерах по убыванию методом пузырька.

Lenar1998 15 сент. 2020 г., 11:19:43 | 10 - 11 классы

Разделить массив, заполненный случайным образом только положительными числами, на два - четных и нечетных?

Разделить массив, заполненный случайным образом только положительными числами, на два - четных и нечетных.

Составить блок схему и написать программу.

Ivasishina2002 14 июн. 2020 г., 04:17:57 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста!

Нужно составит блок - схему алгоритма.

Задание : в последовательности целых чисел определить максимальное четное число и его порядковый номер.

P. S.

Мне не нужна программа, которая вычисляет это(Паскаль или еще какая - нибудь).

Мне нужна блок - схема!

Naska84 6 мая 2020 г., 03:17:04 | 5 - 9 классы

Составить программу и блок схему вывода на экран всех четных двузначных чисел?

Составить программу и блок схему вывода на экран всех четных двузначных чисел.

Dfyz192837465 22 янв. 2020 г., 10:09:25 | 10 - 11 классы

Написать программу на языке паскаль ?

Написать программу на языке паскаль .

ПЖЛ ПОМАГИТЕ дан одновременный массив из п целых чисел .

Составить программу вычисления суммы элементов стоящих на четных местах.

Надежда19841 23 июл. 2020 г., 09:17:50 | 10 - 11 классы

Дан одномерный массив целых чисел?

Дан одномерный массив целых чисел.

Найти сумму всех четных элементов массива, стоящих на четных местах (имеющих четные номера).

Массив задается с помощью генератора случайных чисел.

Если можно с блок - схемой.

Polyakovae10 29 нояб. 2020 г., 01:20:23 | 5 - 9 классы

Задан массив из случайных чисел из ста элементов?

Задан массив из случайных чисел из ста элементов.

Найти минимальный элемент массива.

Составить блок - схему.

Pool658 18 июл. 2020 г., 00:28:34 | 5 - 9 классы

Написать программу в Паскале?

Написать программу в Паскале.

Даны два числа.

Меньшее из них замените полусуммой этих чисел, а большее - их произведением.

Составить блок - схему.

Timahau 19 дек. 2020 г., 10:57:17 | 10 - 11 классы

Написать программу в АВС Паскаль?

Написать программу в АВС Паскаль.

Дан массив целых чисел.

Найти количество пар соседних элементов, в которых одно число четное, а другое отрицательное.

Выведите также сформированный массив и все искомые пары соседних элементов.

Пасека1 24 нояб. 2020 г., 06:40:01 | 10 - 11 классы

Помогите , пожалуйста , составить программу в Паскале + блок - схема?

Помогите , пожалуйста , составить программу в Паскале + блок - схема.

На странице вопроса Помогите с паскалем? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.