Дано натуральное число N, в котором все цифры различны?

Информатика | 5 - 9 классы

Дано натуральное число N, в котором все цифры различны.

Найти остаток от деления максимальной цифры на минимальную цифру данного числа.

Ответить на вопрос
Ответы (1)
Lesia8224 11 нояб. 2020 г., 22:37:26

Var n, i, min, max : integer ;

begin ;

readln(n) ;

max : = 0 ;

min : = 10 ;

while n> ; 1 do

begin ;

if n mod 10> ; max then max : = n mod 10 ;

if n mod 10< ; min then min : = n mod 10 ;

n : = n div 10 ;

end ;

writeln('Result : ', max mod min) ;

end.

Lapteva240677 21 дек. 2020 г., 02:11:37 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найти максимальную цифру.

В паскале.

Через while.

Shkurapetsveta 16 февр. 2020 г., 02:35:28 | 10 - 11 классы

Дано натуральное число в котором все цифры различны определить порядочный номер его максимальной цифры?

Дано натуральное число в котором все цифры различны определить порядочный номер его максимальной цифры.

Nshaposhnik 29 мар. 2020 г., 18:01:36 | 5 - 9 классы

Дано натуральное число : − найти сумму цифр этого числа ; − верно ли, что число начинается и заканчивается одной и той же цифрой?

Дано натуральное число : − найти сумму цифр этого числа ; − верно ли, что число начинается и заканчивается одной и той же цифрой.

Li15 19 сент. 2020 г., 23:20:09 | 5 - 9 классы

1) дано четырёхзначное число?

1) дано четырёхзначное число.

Вывести максимальную и минимальную цифру.

Pascal abc

2) дано четырёхзначное число.

Что больше : произведение цифр числа или их утроенная сумма.

Pascal ABC.

Ymnji 18 окт. 2020 г., 16:51:49 | 10 - 11 классы

1. Дано натуральное число n?

1. Дано натуральное число n.

Переставить его цифры так, чтобы образовалось минимальное число, записанное теми же цифрами.

Jkjfghjgh 6 нояб. 2020 г., 12:06:13 | 5 - 9 классы

Срочно помощь нужна?

Срочно помощь нужна.

Дано натуральное число N.

1. Вывести на экран минимальную цифру числа и разряд, в котором она находится ; 2.

Вывести на экран максимальную цифру числа и разряд, в котором она находится ; 3.

Вывести на экран сумму максимальной и минимальной цифры.

4. Выяснить, сколько раз в натуральном числе встречается его максимальная цифра.

5. Проверить на четность минимальную цифру числа N.

Пример Введите натуральное число N : 388456 Минимальная цифра - 3, находится в разряде 5 ; Максимальная цифра - 8, находится в разряде 4 ; Сумма максимальной и минимальной цифры - 11 ; Максимальная цифра встречается 2 раза ; Минимальная цифра - нечетная.

Ivanushun12345 2 июл. 2020 г., 12:04:02 | 5 - 9 классы

Pascal ABC?

Pascal ABC.

Дано натуральное число "n".

Составьте программу которая выводит максимальную цифру этого числа.

Вадим2351 14 мая 2020 г., 00:59:34 | 10 - 11 классы

Дано натуральное число n?

Дано натуральное число n.

Проверить будут ли все цифры числа различными паскаль.

Nastenkastasevi 22 нояб. 2020 г., 03:21:15 | 10 - 11 классы

Дано натуральное число определить его максимальную цифру?

Дано натуральное число определить его максимальную цифру.

Lerchik1204 3 нояб. 2020 г., 02:25:45 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Найти максимальную цифру.

В паскале.

Через процедуры.

На этой странице сайта размещен вопрос Дано натуральное число N, в котором все цифры различны? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.