Срочно помощь нужна?

Информатика | 5 - 9 классы

Срочно помощь нужна.

Дано натуральное число N.

1. Вывести на экран минимальную цифру числа и разряд, в котором она находится ; 2.

Вывести на экран максимальную цифру числа и разряд, в котором она находится ; 3.

Вывести на экран сумму максимальной и минимальной цифры.

4. Выяснить, сколько раз в натуральном числе встречается его максимальная цифра.

5. Проверить на четность минимальную цифру числа N.

Пример Введите натуральное число N : 388456 Минимальная цифра - 3, находится в разряде 5 ; Максимальная цифра - 8, находится в разряде 4 ; Сумма максимальной и минимальной цифры - 11 ; Максимальная цифра встречается 2 раза ; Минимальная цифра - нечетная.

Ответить на вопрос
Ответы (1)
Annekorzh 6 нояб. 2020 г., 12:06:19

Var i, d, dmin, dmax, kmax, imin, imax : integer ; n : longint ;

begin Write('Введите натуральное число N : ') ; Read(n) ; dmin : = 10 ; dmax : = - 1 ; {больше большего и меньше меньшего} i : = 0 ; repeat d : = n mod 10 ; n : = n div 10 ; Inc(i) ; if dmax< ; d then begin dmax : = d ; kmax : = 1 ; imax : = i end else if dmax = d then Inc(kmax) ; if dmin> ; d then begin dmin : = d ; imin : = i end until n = 0 ; Writeln('Минимальная цифра - ', dmin, ' находится в разряде ', imin, ' ; ') ; Writeln('Максимальная цифра - ', dmax, ' находится в разряде ', imax, ' ; ') ; Writeln('Сумма максимальной и минимальной цифры - ', dmin + dmax, ' ; ') ; Writeln('Максимальная цифра встречается ', kmax, ' раз(а) ; ') ; Write('Минимальная цифра - ') ; if (dmin mod 2) = 0 then Writeln('четная.

') else Writeln('нечетная.

')

end.

Тестовое решение :

Введите натуральное число N : 388456

Минимальная цифра - 3 находится в разряде 6 ;

Максимальная цифра - 8 находится в разряде 4 ;

Сумма максимальной и минимальной цифры - 11 ;

Максимальная цифра встречается 2 раз(а) ;

Минимальная цифра - нечетная.

Nizami2000 29 янв. 2020 г., 23:46:35 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Вывести порядковый номер его минимальной цифры.

Паскаль.

Shkurapetsveta 16 февр. 2020 г., 02:35:28 | 10 - 11 классы

Дано натуральное число в котором все цифры различны определить порядочный номер его максимальной цифры?

Дано натуральное число в котором все цифры различны определить порядочный номер его максимальной цифры.

Rleisan 26 июн. 2020 г., 03:47:58 | 10 - 11 классы

Pascal?

Pascal.

Тема : Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа.

2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа.

Li15 19 сент. 2020 г., 23:20:09 | 5 - 9 классы

1) дано четырёхзначное число?

1) дано четырёхзначное число.

Вывести максимальную и минимальную цифру.

Pascal abc

2) дано четырёхзначное число.

Что больше : произведение цифр числа или их утроенная сумма.

Pascal ABC.

Милкашоколад 22 дек. 2020 г., 17:50:09 | 5 - 9 классы

Д / З по теме "Алгоритмическая конструкция : цикл" ЗАДАЧА "Разбор числа на цифры" Ввести многозначное число?

Д / З по теме "Алгоритмическая конструкция : цикл" ЗАДАЧА "Разбор числа на цифры" Ввести многозначное число.

Найти : младшую цифру числа ; старшую цифру числа ; сумму цифр числа ; произведение цифр ; количество цифр ; минимальную цифру числа ; максимальную цифру числа ; количество нулевых цифр ; сумму четных цифр ; произведение цифр, кратных 3.

СРОООООООООЧно.

Ymnji 18 окт. 2020 г., 16:51:49 | 10 - 11 классы

1. Дано натуральное число n?

1. Дано натуральное число n.

Переставить его цифры так, чтобы образовалось минимальное число, записанное теми же цифрами.

Dasyona1 11 нояб. 2020 г., 22:37:20 | 5 - 9 классы

Дано натуральное число N, в котором все цифры различны?

Дано натуральное число N, в котором все цифры различны.

Найти остаток от деления максимальной цифры на минимальную цифру данного числа.

Aleksach1 27 дек. 2020 г., 02:32:43 | 10 - 11 классы

Помогите написать программу)))Задано трехзначное число, определить :1) сумму цифр этого числа ;2) произведение ;3) минимальную цифру ;4) максимальную цифру этого числа?

Помогите написать программу)))

Задано трехзначное число, определить :

1) сумму цифр этого числа ;

2) произведение ;

3) минимальную цифру ;

4) максимальную цифру этого числа.

Nastenkastasevi 22 нояб. 2020 г., 03:21:15 | 10 - 11 классы

Дано натуральное число определить его максимальную цифру?

Дано натуральное число определить его максимальную цифру.

ТошаКотов 4 нояб. 2020 г., 06:42:34 | 1 - 4 классы

Вводится натуральное число n требуется найти сумму четных цифр числа 2) найти количество цифр 2 в числе 3) найти максимальную нечетную цифру в числе ПАСКАЛЬ СРОЧНО?

Вводится натуральное число n требуется найти сумму четных цифр числа 2) найти количество цифр 2 в числе 3) найти максимальную нечетную цифру в числе ПАСКАЛЬ СРОЧНО!

Если вам необходимо получить ответ на вопрос Срочно помощь нужна?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.