Записать, как програму в паскале Дана последовательность чисел, оканчивающихся нулем?

Информатика | 5 - 9 классы

Записать, как програму в паскале Дана последовательность чисел, оканчивающихся нулем.

Найти произведение чисел, оканчивающихся цифрой 5.

Ответить на вопрос
Ответы (1)
Niksleptsov02 20 окт. 2020 г., 04:14:34

Var x, p : longint ;

begin Writeln('Вводите через пробел натуральные числа, 0 - конец ввода') ; p : = 1 ; repeat Read(x) ; if x < ; > ; 0 then if (x mod 5) = 0 then p : = p * x until x = 0 ; Writeln('Произведение чисел, оканчивающихся цифрой 5, равно ', p)

end.

Тестовое решение :

Вводите через пробел натуральные числа, 0 - конец ввода

3 4 15 7 25 2 5 0

Произведение чисел, оканчивающихся цифрой 5, равно 1875.

Olga050577 16 дек. 2020 г., 12:21:35 | 5 - 9 классы

Дана непустая последовательность положительный целых чисел, за которой следует 0?

Дана непустая последовательность положительный целых чисел, за которой следует 0.

Найти сумму всех четных чисел этой последовательности

Записать, как программу в паскале.

Anastasi482 18 июл. 2020 г., 06:14:14 | 5 - 9 классы

Решите пожалуйста в паскале задачи 1)Дана непустая последовательность целых чисел, оканчивающаяся нулем?

Решите пожалуйста в паскале задачи 1)Дана непустая последовательность целых чисел, оканчивающаяся нулем.

Найти : а) сумму всех чисел последовательности, больших числа x ; б) количество всех четных чисел последовательности.

2)Дана последовательность ненулевых целых чисел, оканчивающая нулем.

Оп - ределить, сколько раз в этой последовательности меняется знак.

(Например, в последовательности 10, –4, 12, 56, –4 знак меняется 3 раза.

).

Wordless 26 янв. 2020 г., 21:32:02 | 10 - 11 классы

Дан массив целых чисел?

Дан массив целых чисел.

Все элементы, оканчивающиеся цифрой 4, уменьшить вдвое на с + +.

Гоаркристине 5 окт. 2020 г., 00:50:37 | 5 - 9 классы

Надо сделать в паскале 1)Дан одномерный массив вещественных чисел?

Надо сделать в паскале 1)Дан одномерный массив вещественных чисел.

Найти минимальный элемент массива.

2) Дана последовательность 7 чисел.

Вычислите сумму элементов данной последовательности меньших нуля.

Спасибо.

Shjwjan 14 янв. 2020 г., 09:31:33 | 10 - 11 классы

Паскаль Пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента?

Паскаль Пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента.

Определите наибольшее число последовательности.

Rjrjhtdf84 7 мая 2020 г., 23:26:52 | 5 - 9 классы

Дана последовательность чисел, заканчивающаяся нулем?

Дана последовательность чисел, заканчивающаяся нулем.

Найти сумму отрицательных и произведение положительных чисел.

Напишите в паскале.

InnaPshonko 23 дек. 2020 г., 16:50:27 | 5 - 9 классы

Помогите пожалуйста, язык программирования паскаль?

Помогите пожалуйста, язык программирования паскаль.

1)Дана последовательность чисел, оканчивающихся 0.

Определите сумму всех двузначных положительных и четных чисел.

2)дана последовательность из n чисел.

Сколько чисел этой последовательности являются двузначными, у которых последняя цифра 3.

Akimovari 4 сент. 2020 г., 16:41:15 | 5 - 9 классы

Даны числа от 1 до n?

Даны числа от 1 до n.

Найти произведение чисел кратных 3 и оканчивающихся на 1.

1Демон1 31 дек. 2020 г., 04:01:46 | 10 - 11 классы

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем?

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем.

Найти количество отрицательных чисел и сумму чисел кратных 4.

Rudtatv 16 сент. 2020 г., 03:09:44 | 5 - 9 классы

Помогите решить задачу на c + + вот зададча Дана последовательность чисел, оканчивающаяся числом 1000?

Помогите решить задачу на c + + вот зададча Дана последовательность чисел, оканчивающаяся числом 1000.

Определите какое из чисел, оканчивающихся нулем, наибольшее в этой последовательности.

1000 элементом последовательности не считается.

Гарантируется, что хотя бы одно такое число в последовательности есть.

Если вам необходимо получить ответ на вопрос Записать, как програму в паскале Дана последовательность чисел, оканчивающихся нулем?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.