С клавиатуры вводится трёхзначное число?

Информатика | 10 - 11 классы

С клавиатуры вводится трёхзначное число.

Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях.

Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

Нужно написать.

Ответить на вопрос
Ответы (1)
Antonmaslennik 9 сент. 2020 г., 16:22:11

Program prog ;

uses crt ;

var x, k : integer ;

begin ;

clrscr ;

write('Введите трехзначное число х = ') ;

readln(x) ;

if ((x div 1000) = 0) and (abs(x div 100)> ; 0 )then

begin while abs(x)> ; 0 do begin ; if (x mod 10) mod 2 = 0 then k : = k + 1 ; x : = x div 10 ; end ;

if k = 3 then writeln('Да')

else writeln('Нет') ;

end

else

writeln('Неверное число') ;

end.

Alikaalika 27 авг. 2020 г., 23:16:26 | 10 - 11 классы

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры)?

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры).

H1ghonline 10 февр. 2020 г., 04:28:55 | 5 - 9 классы

Составте программу , вычисления суммы цифр трёхзначного числа а?

Составте программу , вычисления суммы цифр трёхзначного числа а.

Значение а введите с клавиатуры Пример ввода : 375 Пример вывода : Сумма цифр числа 375 равна 15 2) Составте программу , которая получает 'перевёртыш' трёхзначного числа а.

Значение а введите с клавиатуры Пример ввода : 375 Пример вывода : 573.

Alkiso 14 авг. 2020 г., 02:22:22 | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

Напишите программу, которая вводит трёхзначное число и разбивает его на цифры.

Например, при вводе числа 123 программа должна вывести"1, 2, 3".

Inessik 16 апр. 2020 г., 08:23:38 | 10 - 11 классы

С клавиатуры вводится трёхзначное число?

С клавиатуры вводится трёхзначное число.

Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях.

Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

ЕкАтЕрИнА01 22 авг. 2020 г., 08:19:51 | 5 - 9 классы

С клавиатуры вводится любое целое трёхзначное число, найти сумму цифр этого числа?

С клавиатуры вводится любое целое трёхзначное число, найти сумму цифр этого числа.

(Dev C + + ).

DanielRuss 2 апр. 2020 г., 04:07:08 | 10 - 11 классы

Клавиатуры вводится трёхзначное число?

Клавиатуры вводится трёхзначное число.

Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях.

Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

Лёликет 15 дек. 2020 г., 13:58:06 | 10 - 11 классы

1) С клавиатуры вводится трёхзначное число?

1) С клавиатуры вводится трёхзначное число.

Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях.

ТаткаТаточка 3 мая 2020 г., 01:57:08 | 5 - 9 классы

С клавиатуры вводится 5 - значное число?

С клавиатуры вводится 5 - значное число.

Если первая и последняя цифры этого числа четные, вывести на экран "четные", в противном случае вывести "нечетные" помогите пж.

Balashovamarin 2 июл. 2020 г., 18:04:30 | 5 - 9 классы

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное?

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное.

Входные данные : Входная строка содержит единственное натуральное число.

Выходные данные : Если введённое число – трёхзначное, нужно вывести ответ YES, если нет, то вывести ответ NO.

Dnlg 5 июл. 2020 г., 05:02:40 | 5 - 9 классы

Очень нужна помощь ?

Очень нужна помощь !

С клавиатуры вводятся трёхзначные числа до тех пор, пока первая цифра не станет равна третьей.

Вывести на экран только те числа, где сумма цифр меньше десяти.

Паскаль abc.

На этой странице вы найдете ответ на вопрос С клавиатуры вводится трёхзначное число?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.