Д / З по теме "Алгоритмическая конструкция : цикл" ЗАДАЧА "Разбор числа на цифры" Ввести многозначное число?

Информатика | 5 - 9 классы

Д / З по теме "Алгоритмическая конструкция : цикл" ЗАДАЧА "Разбор числа на цифры" Ввести многозначное число.

Найти : младшую цифру числа ; старшую цифру числа ; сумму цифр числа ; произведение цифр ; количество цифр ; минимальную цифру числа ; максимальную цифру числа ; количество нулевых цифр ; сумму четных цифр ; произведение цифр, кратных 3.

СРОООООООООЧно.

Ответить на вопрос
Ответы (1)
Zhilyaeva 22 дек. 2020 г., 17:50:13

Var a, st, summ, pr, count, min, max, count0, SummCh, pr3 : integer ;

begin write('Введите число ') ; readln(a) ; writeln ; writeln('Младшая цифра числа : ', a mod 10) ; max : = a mod 10 ; min : = max ; Summ : = 0 ; SummCh : = 0 ; pr : = 1 ; count : = 0 ; count0 : = 0 ; pr3 : = 1 ; while a < ; > ; 0 do begin count : = count + 1 ; Summ : = summ + a mod 10 ; pr : = pr * (a mod 10) ; if (a mod 10) mod 2 = 0 then SummCh : = SummCh + a mod 10 ; if (a mod 10 < ; > ; 0) and ((a mod 10) mod 3 = 0) then Pr3 : = Pr3 * (a mod 10) ; if a mod 10 = 0 then count0 : = count0 + 1 ; if a mod 10 > ; max then max : = a mod 10 ; if a mod 10 < ; min then min : = a mod 10 ; if a div 10 = 0 then St : = a mod 10 ; a : = a div 10 ; end ; writeln('Старшая цифра числа : ', St) ; writeln('Сумма цифр числа : ', Summ) ; writeln('Произведение цифр числа : ', Pr) ; writeln('Количество цифр числа : ', count) ; writeln('Минимальная цифра числа : ', min) ; writeln('Максимальная цифра числа : ', max) ; writeln('Количество нулевых цифр : ', count0) ; writeln('Сумма четных цифр : ', SummCh) ; writeln('Произведение цифр кратных 3 : ', Pr3) ; writeln ;

end.

Coololenrogat 24 дек. 2020 г., 19:54:37 | 5 - 9 классы

Составить программу, подсчитывающую количество цифр числа n, сумму его цифр и определяющую его первую цифру?

Составить программу, подсчитывающую количество цифр числа n, сумму его цифр и определяющую его первую цифру.

Alisa16 10 дек. 2020 г., 02:58:32 | 5 - 9 классы

Ввести целое число и найти сумму его цифр?

Ввести целое число и найти сумму его цифр.

Пример : Введите целое число : 1234 Сумма цифр числа 1234 равна 10.

Jkjfghjgh 6 нояб. 2020 г., 12:06:13 | 5 - 9 классы

Срочно помощь нужна?

Срочно помощь нужна.

Дано натуральное число N.

1. Вывести на экран минимальную цифру числа и разряд, в котором она находится ; 2.

Вывести на экран максимальную цифру числа и разряд, в котором она находится ; 3.

Вывести на экран сумму максимальной и минимальной цифры.

4. Выяснить, сколько раз в натуральном числе встречается его максимальная цифра.

5. Проверить на четность минимальную цифру числа N.

Пример Введите натуральное число N : 388456 Минимальная цифра - 3, находится в разряде 5 ; Максимальная цифра - 8, находится в разряде 4 ; Сумма максимальной и минимальной цифры - 11 ; Максимальная цифра встречается 2 раза ; Минимальная цифра - нечетная.

Абвс03 24 мар. 2020 г., 01:36:07 | 5 - 9 классы

Дано трехзначное число, необходимо найти старшую цифру, младшую, кол - во цифр и их сумму?

Дано трехзначное число, необходимо найти старшую цифру, младшую, кол - во цифр и их сумму.

Вывести на экран надпись, какая из цифр наибольшая.

Dasyona1 11 нояб. 2020 г., 22:37:20 | 5 - 9 классы

Дано натуральное число N, в котором все цифры различны?

Дано натуральное число N, в котором все цифры различны.

Найти остаток от деления максимальной цифры на минимальную цифру данного числа.

Aleksach1 27 дек. 2020 г., 02:32:43 | 10 - 11 классы

Помогите написать программу)))Задано трехзначное число, определить :1) сумму цифр этого числа ;2) произведение ;3) минимальную цифру ;4) максимальную цифру этого числа?

Помогите написать программу)))

Задано трехзначное число, определить :

1) сумму цифр этого числа ;

2) произведение ;

3) минимальную цифру ;

4) максимальную цифру этого числа.

Yashina05 11 окт. 2020 г., 16:50:16 | 10 - 11 классы

Вычислите сумму цифр в числе?

Вычислите сумму цифр в числе.

(Например, в числе 352 сумма цифр = 10).

Единорог1в1кармане 28 мар. 2020 г., 06:32:39 | 5 - 9 классы

9. Дано трехзначное число?

9. Дано трехзначное число.

Определить : а) Является ли сумма его цифр двузначным числом ; b) Является ли произведение его цифр трехзначных числом ; c) Больше ли числа А произведение его цифр ; число А – любое, оно вводится с клавиатуры ; d) Кратна ли пяти сумма его цифр ; e) Кратна ли сумма его цифр числу А ; число А – любое, оно вводится с клавиатуры ; Числа вводить, пока не будет введён нуль.

Блок - схему и программу.

Пожалуйста : ).

Vipaybashev1 16 окт. 2020 г., 18:36:21 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Определить : a) Количество цифр в этом числе ; б)Сумму его цифр ; в)Первую цифру числа n ;

ТошаКотов 4 нояб. 2020 г., 06:42:34 | 1 - 4 классы

Вводится натуральное число n требуется найти сумму четных цифр числа 2) найти количество цифр 2 в числе 3) найти максимальную нечетную цифру в числе ПАСКАЛЬ СРОЧНО?

Вводится натуральное число n требуется найти сумму четных цифр числа 2) найти количество цифр 2 в числе 3) найти максимальную нечетную цифру в числе ПАСКАЛЬ СРОЧНО!

Вы перешли к вопросу Д / З по теме "Алгоритмическая конструкция : цикл" ЗАДАЧА "Разбор числа на цифры" Ввести многозначное число?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.