ВОПРОС №216817 (ТИП : C) Дано трехзначное число?

Информатика | 5 - 9 классы

ВОПРОС №216817 (ТИП : C) Дано трехзначное число.

В нем зачеркнули последнюю цифру и приписали ее в начале.

Написать программу, которая находит получаемое число.

(никакие поясняющие записи в программе делать не нужно!

Библиотеку conio.

H и команду getch() перед отправкой файла необходимо удалить!

)

Пример входных и выходных данных № теста Входные данные Выходные данные 456 645.

Ответить на вопрос
Ответы (1)
300350 16 окт. 2020 г., 12:10:40

Var a, a1, a2, a3 : integer ;

begin

write ('Введите трехзначное число : ') ; read (a) ;

a1 : = a div 100 mod 10 ;

a2 : = a mod 100 div 10 ;

a3 : = a mod 10 ;

writeln ('Полученное число : ', a3, a1, a2) ;

end.

Layzy 28 нояб. 2020 г., 08:35:55 | 5 - 9 классы

Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код?

Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код.

Используйте процедуру входные данные 5 выходные данные 101 входные данные - 14 выходные данные - 1110.

Schura97 3 июл. 2020 г., 10:20:09 | 10 - 11 классы

Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Задано натуральное число N?

Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Задано натуральное число N.

ВЫХОДНЫЕ ДАННЫЕ Определите количество нулей в его записи.

Edmobil49 11 июн. 2020 г., 00:38:36 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Написать программу, которая определяет сколько раз входит в него цифра 4.

(никакие поясняющие записи в программе делать не нужно!

Библиотеку conio.

H и команду getch() перед отправкой файла необходимо удалить!

)(с + + ).

Ddannya 10 дек. 2020 г., 10:29:38 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Напишите программу, которая определяет : есть ли среди цифр заданного целого трёхзначного числа одинаковые ; Пример входных данных : 123 121 122 Пример выходных данных : Нет Да Да.

Варя81 7 окт. 2020 г., 00:35:35 | 5 - 9 классы

Напишите программу, которая заменяет расширение у заданного имени файла?

Напишите программу, которая заменяет расширение у заданного имени файла.

Входные данные Первая строка содержит имя файла, которое нужно изменить.

Во второй строке записано нужное расширение.

Выходные данные Программа должна вывести изменённое имя файла с заданным расширением.

Примеры входные данные qwerty exe выходные данные qwerty.

Exe входные данные qwetry.

Old. pas html выходные данные qwetry.

Old. html.

Ginnger 5 окт. 2020 г., 00:35:56 | 5 - 9 классы

Дано натуральное трехзначное число a?

Дано натуральное трехзначное число a.

Сформировать число b, такое что : число сотен в нем равнялось бы цифре сотен числа а, увеличенной на цифру единиц числа а, число десятков в b обнулить, а вместо единиц поставить число десятков от числа а.

(никакие поясняющие записи в программе делать не нужно!

Библиотеку conio.

H и команду getch() перед отправкой файла необходимо удалить!

) Пример входных и выходных данных № теста |Входные данные |Выходные данные ______________________________________ 1 | 473 | 707 Ответ : Прикрепите файл с программой в формате CPP, PAS, CS, FS или JAVA.

Ваш ответ будет проверен автоматически.

ТАРАНТУЛ2004 25 дек. 2020 г., 10:54:01 | 5 - 9 классы

Напишите программу в Boland Pascal?

Напишите программу в Boland Pascal.

ЗАДАНО ТРЕХЗНАЧное числою напечатать в обратном порядке .

Входные данные Целое трехзначное число.

Выходные данные Целое трехзначное число напечатать в обратном порядке Пример входных данных423 .

Пример выходных данных 324.

Serjana 9 окт. 2020 г., 05:42:28 | 10 - 11 классы

Уровень B?

Уровень B.

Задача M.

Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO

Уровень C.

Задача O.

Две одинаковые цифры Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 212 выходные данные YES входные данные 12345 выходные данные NO.

Маша133 31 окт. 2020 г., 06:11:15 | 10 - 11 классы

Напишите программу, которая удаляет из строки все повторяющиеся символы?

Напишите программу, которая удаляет из строки все повторяющиеся символы.

Входные данные

На вход программы подаётся строка, содержащая символы таблицы ASCII.

Выходные данные

Программа должна вывести исходную строку, из которой удалены все повторяющиеся символы.

Примеры

входные данные

abc13a1b2z3c

выходные данные

abc132z

входные данные

QWasd123

выходные данные

QWasd123

Pascal ABC 1.

8.

Akolesova2002 30 нояб. 2020 г., 01:46:11 | 5 - 9 классы

Дано натуральное число N?

Дано натуральное число N.

Напишите функцию (Pascal), вычисляющую сумму цифр числа N.

Входные данные

Задано единственное число N

Выходные данные

Необходимо вывести сумму цифр числа N.

Примеры

входные данные

12

выходные данные

3

ПРОГРАММА БЫЛА, НО ВВОДИЛ 12 И ВЫВОДИЛ ВМЕСТО 3, 0.

На странице вопроса ВОПРОС №216817 (ТИП : C) Дано трехзначное число? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.