Составить программу в паскалеВвести число?

Информатика | 5 - 9 классы

Составить программу в паскале

Ввести число.

Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на 5, если нечетное - возвести в квадрат.

Ответить на вопрос
Ответы (1)
Magisternev 28 февр. 2020 г., 11:50:50

Var n : longint ;

c : real ;

begin write ('N = ') ; readln(n) ; if (n mod 2 = 0) and (n> ; 0) then c : = n / 4 else if (n mod 2 = 0) and (n< ; 0) then c : = n * 5 else if (n mod = 1) then c : = sqr(n) ; write (c : 0 : 2) ;

end.

Lenar1998 15 сент. 2020 г., 11:19:43 | 10 - 11 классы

Разделить массив, заполненный случайным образом только положительными числами, на два - четных и нечетных?

Разделить массив, заполненный случайным образом только положительными числами, на два - четных и нечетных.

Составить блок схему и написать программу.

Tubgf 13 мар. 2020 г., 18:52:11 | 10 - 11 классы

Составить алгоритм блок схему и программу для решения задачи ввести число если оно положительное разделить на 4 если отрицательное или равно нулю умножить на 5?

Составить алгоритм блок схему и программу для решения задачи ввести число если оно положительное разделить на 4 если отрицательное или равно нулю умножить на 5.

Natasha1 5 апр. 2020 г., 09:25:57 | 10 - 11 классы

Ввести число?

Ввести число.

Если оно четное, разделить его на 4, если нечетное - умножить на 5 (Паскаль).

Vladlalalaalala 7 дек. 2020 г., 22:41:27 | 5 - 9 классы

Ввести число?

Ввести число.

Если оно положительное, возвести его в квадрат, иначе возвести его в куб.

Солнце12 12 авг. 2020 г., 08:04:02 | 5 - 9 классы

Написать программу на языке паскаль Определить является ли число четным или нечетным?

Написать программу на языке паскаль Определить является ли число четным или нечетным.

НастяБойцова12 5 мар. 2020 г., 16:11:07 | 5 - 9 классы

Напишите программу на паскале А?

Напишите программу на паскале А.

Выясните какие числа ввел пользователь : положительное или отрицательное?

Б. выясните какие числа ввел пользователь : четное или нечетное ?

Lana537 28 авг. 2020 г., 21:53:25 | 10 - 11 классы

Введите с клавиатуры число , если оно четное , то уменьшить его в 10 раз , если не четное, то возвести в квадрат?

Введите с клавиатуры число , если оно четное , то уменьшить его в 10 раз , если не четное, то возвести в квадрат.

Паскаль.

Максум2 12 июн. 2020 г., 08:01:23 | 5 - 9 классы

Ввести три числа четные числа возвести в квадрат не четные оставить без изменений?

Ввести три числа четные числа возвести в квадрат не четные оставить без изменений!

Помогите плиз.

Marina19998 8 янв. 2020 г., 17:51:43 | 5 - 9 классы

Задача введите 3 числа четные числа возвести в квадрат нечётное оставить без изменений программа (паскаль)?

Задача введите 3 числа четные числа возвести в квадрат нечётное оставить без изменений программа (паскаль).

Annkom 1 дек. 2020 г., 21:10:11 | 5 - 9 классы

Составить программу на языке Паскаль если два числа положительные, то возвести оба числа в квадрат если оба числа отрицательные, то найти их модуль?

Составить программу на языке Паскаль если два числа положительные, то возвести оба числа в квадрат если оба числа отрицательные, то найти их модуль.

Вы открыли страницу вопроса Составить программу в паскалеВвести число?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.