Разделить массив, заполненный случайным образом только положительными числами, на два - четных и нечетных?

Информатика | 10 - 11 классы

Разделить массив, заполненный случайным образом только положительными числами, на два - четных и нечетных.

Составить блок схему и написать программу.

Ответить на вопрос
Ответы (1)
Efimenkosveta7 15 сент. 2020 г., 11:19:46

Uses crt ;

const n = 10 ;

var a, b, c : array [1.

N] of integer ; x, y, z, k : integer ;

begin y : = 0 ; z : = 0 ; for x : = 1 to n do begin a[x] : = random(100) + 1 ; if a[x] mod 2 = 0 then begin inc(y) ; b[y] : = a[x] ; end else begin inc(z) ; c[z] : = a[x] ; end ; write(a[x] : 4) ; end ; writeln ; k : = y ; for y : = 1 to k do write(b[y] : 4) ; writeln ; k : = z ; for z : = 1 to k do write(c[z] : 4) ;

end.

Galinatitova48 23 нояб. 2020 г., 07:17:13 | 10 - 11 классы

Помогите с паскалем?

Помогите с паскалем!

Написать программу.

Составить блок схему.

Вставить заданное число в массив целых чисел перед последним четным элементом.

VJGinger 8 авг. 2020 г., 22:37:09 | 5 - 9 классы

Пожалуйста помогите) 1) написать программу , заполняющую массив из 10 элементов числами от 10 до 1?

Пожалуйста помогите) 1) написать программу , заполняющую массив из 10 элементов числами от 10 до 1.

2)написать программу подсчитывающую количество нечетных элементов в массиве случайных чисел.

3) программа заполняет массив случайными числами от - 10 до 10 и находит сумму отрицательных и положительных элементов.

Tubgf 13 мар. 2020 г., 18:52:11 | 10 - 11 классы

Составить алгоритм блок схему и программу для решения задачи ввести число если оно положительное разделить на 4 если отрицательное или равно нулю умножить на 5?

Составить алгоритм блок схему и программу для решения задачи ввести число если оно положительное разделить на 4 если отрицательное или равно нулю умножить на 5.

Firuzjon2 28 февр. 2020 г., 11:50:46 | 5 - 9 классы

Составить программу в паскалеВвести число?

Составить программу в паскале

Ввести число.

Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на 5, если нечетное - возвести в квадрат.

Naska84 6 мая 2020 г., 03:17:04 | 5 - 9 классы

Составить программу и блок схему вывода на экран всех четных двузначных чисел?

Составить программу и блок схему вывода на экран всех четных двузначных чисел.

Fediral 23 дек. 2020 г., 07:55:47 | 5 - 9 классы

Написать программу нахождения суммы четных и нечетных элементов массива, заполненного случайным образом от - 100 до 100 помогите пожалуйста?

Написать программу нахождения суммы четных и нечетных элементов массива, заполненного случайным образом от - 100 до 100 помогите пожалуйста!

Нужна программа в Pascal!

Ksenijaksusha 20 окт. 2020 г., 22:51:03 | 10 - 11 классы

Помогите написать программу в с + + ?

Помогите написать программу в с + + .

Используя оператор if нужно написать программу , где пользователь вводит число , а программа отображает одно из трех сообщений : число является четным , положительным .

Или число является нечетным , положительным.

Или отрицательным.

Солнце12 12 авг. 2020 г., 08:04:02 | 5 - 9 классы

Написать программу на языке паскаль Определить является ли число четным или нечетным?

Написать программу на языке паскаль Определить является ли число четным или нечетным.

Abramovavictorya 23 февр. 2020 г., 04:32:51 | 5 - 9 классы

Написать программу заполнения массива случайными числами из диапазона от - 20 до 20 и вывода порядковых номеров четных чисел?

Написать программу заполнения массива случайными числами из диапазона от - 20 до 20 и вывода порядковых номеров четных чисел.

Helen6595 22 сент. 2020 г., 06:21:03 | 5 - 9 классы

Составить блок схему Определить, является ли натуральное число, введенное с клавиатуры в память компьютера, четным?

Составить блок схему Определить, является ли натуральное число, введенное с клавиатуры в память компьютера, четным.

Результат показать на экране в виде сообщения («число четное», «число нечетное»).

На этой странице находится вопрос Разделить массив, заполненный случайным образом только положительными числами, на два - четных и нечетных?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.