Ввести три числа четные числа возвести в квадрат не четные оставить без изменений?

Информатика | 5 - 9 классы

Ввести три числа четные числа возвести в квадрат не четные оставить без изменений!

Помогите плиз.

Ответить на вопрос
Ответы (2)
Kotno4ec 12 июн. 2020 г., 08:01:26

Var a, b, c : integer ; beginRead(a, b, c) ; If a mod 2 = 0 thena : = a * a ; If b mod 2 = 0 thenb : = b * b ; If c mod 2 = 0 thenc : = c * c ; Writeln(a, ' ', b, ' ', c)end.

BreinGuy 12 июн. 2020 г., 08:01:30

Var i : integer ; a : array[1.

3] of integer ;

begin Write('Введите три целых числа : ') ; Read(a[1], a[2], a[3]) ; for i : = 1 to 3 do begin if a[i] mod 2 = 0 then a[i] : = sqr(a[i]) ; Write(a[i], ' ') end

end.

Пример выполнения

Введите три целых числа : 17 - 8 14

17 64 196.

Legostin2014 26 февр. 2020 г., 19:47:35 | 5 - 9 классы

Помогите с информатикой пожалуйста (Написать короткую програмку в FreePascal) Ввести 2 числа, если сумма четная делить на 2, если нет оставить без изменений?

Помогите с информатикой пожалуйста (Написать короткую програмку в FreePascal) Ввести 2 числа, если сумма четная делить на 2, если нет оставить без изменений.

Заранее спасибо).

Firuzjon2 28 февр. 2020 г., 11:50:46 | 5 - 9 классы

Составить программу в паскалеВвести число?

Составить программу в паскале

Ввести число.

Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на 5, если нечетное - возвести в квадрат.

Kcy81 12 июл. 2020 г., 17:04:03 | 5 - 9 классы

Ввести целое число и определить, верно ли, что все его цифры четные?

Ввести целое число и определить, верно ли, что все его цифры четные.

(Кумир).

Диана199 5 июн. 2020 г., 08:11:23 | 10 - 11 классы

Ввести два числа, если они оба четные, найти наибольшее из них?

Ввести два числа, если они оба четные, найти наибольшее из них.

Pascal.

Natasha1 5 апр. 2020 г., 09:25:57 | 10 - 11 классы

Ввести число?

Ввести число.

Если оно четное, разделить его на 4, если нечетное - умножить на 5 (Паскаль).

Vladlalalaalala 7 дек. 2020 г., 22:41:27 | 5 - 9 классы

Ввести число?

Ввести число.

Если оно положительное, возвести его в квадрат, иначе возвести его в куб.

Vvveron 22 окт. 2020 г., 17:02:37 | 10 - 11 классы

Ввести число если оно четное кратное 7 и не кратное 5 то увеличить его на 6?

Ввести число если оно четное кратное 7 и не кратное 5 то увеличить его на 6.

Lana537 28 авг. 2020 г., 21:53:25 | 10 - 11 классы

Введите с клавиатуры число , если оно четное , то уменьшить его в 10 раз , если не четное, то возвести в квадрат?

Введите с клавиатуры число , если оно четное , то уменьшить его в 10 раз , если не четное, то возвести в квадрат.

Паскаль.

Marina19998 8 янв. 2020 г., 17:51:43 | 5 - 9 классы

Задача введите 3 числа четные числа возвести в квадрат нечётное оставить без изменений программа (паскаль)?

Задача введите 3 числа четные числа возвести в квадрат нечётное оставить без изменений программа (паскаль).

Dghjgyik 27 авг. 2020 г., 22:20:11 | 5 - 9 классы

Ввести 3 числа чётные возвести в квадрат, а не чётные оставить без изменений?

Ввести 3 числа чётные возвести в квадрат, а не чётные оставить без изменений.

На странице вопроса Ввести три числа четные числа возвести в квадрат не четные оставить без изменений? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.