Дается последовательность из N чисел?

Информатика | 10 - 11 классы

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Ответить на вопрос
Ответы (1)
Anastazia2108 13 дек. 2020 г., 23:55:46

Сделал разницу значений.

Сначала вводится длинна массива.

Сделано через динамический массив!

Поставь наилучшее решение!

)

var a : array of Integer ; n, i, max, min : Integer ;

begin

Readln(n) ;

SetLength(a, n) ;

for i : = 0 to Length(a) do readln(a[i]) ;

max : = a[0] ;

for i : = 0 to Length(a) do if a[i]> ; max then max : = a[i] ;

min : = a[0] ;

for i : = 0 to Length(a) do if a[i]< ; min then min : = a[i] ; Writeln ; Writeln(max - min) ;

readln ;

end.

Макс451564 3 янв. 2020 г., 16:14:15 | 10 - 11 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных Первая строка входного файла содержит целое число N (1 < ; = N < ; = 100000).

В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Татьяна821 22 окт. 2020 г., 01:31:31 | 10 - 11 классы

Дана последовательность чисел?

Дана последовательность чисел.

Найти минимальное и максимальное число и вычислить их среднее арифметическое.

Red1374 2 янв. 2020 г., 07:12:40 | 1 - 4 классы

Задача А МаксМин Дается последовательность из N чисел?

Задача А МаксМин Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Иииааа 9 янв. 2020 г., 18:20:47 | 10 - 11 классы

Помогите, пожалуйста, с задачей по программированию?

Помогите, пожалуйста, с задачей по программированию.

С клавиатуры вводится неограниченная последовательность чисел.

Ввод последовательности заканчивается 0.

Найти максимальное и минимальное число этой последовательности.

Atey94033 9 апр. 2020 г., 22:40:15 | 5 - 9 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных Первая строка входного файла содержит целое число N (1 < ; = N < ; = 100000).

В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Формат выходных данных Выведите ответ к задаче.

Гоаркристине 5 окт. 2020 г., 00:50:37 | 5 - 9 классы

Надо сделать в паскале 1)Дан одномерный массив вещественных чисел?

Надо сделать в паскале 1)Дан одномерный массив вещественных чисел.

Найти минимальный элемент массива.

2) Дана последовательность 7 чисел.

Вычислите сумму элементов данной последовательности меньших нуля.

Спасибо.

Olga1110 18 мая 2020 г., 07:19:07 | 5 - 9 классы

15 баллов?

15 баллов!

Дается последовательность из 5 чисел, выведите разницу между максимальным и минимальным элементами последовательности.

Напишите программу в паскале.

Любая последовательность чисел, решите, прошу( Только чтоб на уровне 9 класса, без всяких там команд которые мы еще не изучали, сейчас проходим массивы, по этой теме задача.

Nastiyazulina 23 сент. 2020 г., 03:20:02 | 10 - 11 классы

Найти максимальный элемент и его номер в последовательности в паскале?

Найти максимальный элемент и его номер в последовательности в паскале.

Преставки 14 окт. 2020 г., 08:21:42 | 10 - 11 классы

Задана последовательность из 10 целых чисел?

Задана последовательность из 10 целых чисел.

Для каждого элемента начиная со второго найти разницу с предыдущим элементом (ai - ai - 1).

Bambik 23 нояб. 2020 г., 17:27:44 | 5 - 9 классы

С клавиатуры вводится последовательность из n чисел ?

С клавиатуры вводится последовательность из n чисел .

Определите сумму максимального и минимального числа данной последовательности.

Нарисовать блок схему !

Язык программирования : Паскаль .

Вы открыли страницу вопроса Дается последовательность из N чисел?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.